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Preface

This Preface contains the following sections:
“About This Manual” on page liii describes this manual and its intended audience.

« “Conventionsin This Manual” on page v describes the text formatting, syntax
notation, and flags used in this manual.

« “Available Documentation” on page lviii describes the printed and online
documentation that accompanies Stylus Studio® 2009°%.

« “Technical Support” on page Iviii provides information on contacting Technical
Support.

About This Manual

This manual describes how to use Stylus Studio 2009 to develop XML applications. Itis
assumed that you are familiar with XML and the concepts of it and its related
technologies.

This manual has the following chapters:

o Chapter 1, Getting Started with Stylus Studi o®, provides step-by-step instructionsfor
editing an XML document, applying a stylesheet, creating a dynamic Web page,
debugging stylesheets and Java files, and mapping an XML document with one
schemato an XML document with another schema.

o Chapter 2, Editing and Querying XML, describes how to update an XML document
in the text, tree, schema, and grid views of the XML editor. It also provides
information about how to query documents and handle query results.
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Chapter 3, Converting Non-XML Filesto XML, describes how to use DataDirect
XML Converters™ and Stylus Studio custom XML converters to convert files (EDI,
CSV, binary, and others) to XML.

Chapter 4, Converting EDI to XML, describes how to usethe EDI to XML moduleto
convert EDI documentsto XML, and how to create and use Standard Exchange
Format (SEF) files to describe custom EDI structures.

Chapter 5, Working with XSLT, includesatutorial for using XSLT and understanding
how X SLT works. It providesinformation and instructions for using the XSLT editor
to create, modify, and apply stylesheets. It also contains reference information for the
various X SLT instructions you can specify in a stylesheet.

Chapter 6, Creating XSLT Using the XSLT Mapper, describes how to use the Stylus
Studio XML mapper. The XML mapper generates a stylesheet for transforming an
XML document that uses one schemato an XML document that uses another schema.

Chapter 7, Debugging Stylesheets, describes how to use the Stylus Studio debugging
features.

Chapter 8, Defining XML Schemas, provides information and instructions for
creating and editing DTDs and XML Schema documents.

Chapter 9, Defining Document Type Definitions,provides information about how to
use the Stylus Studio Document Type Definition (DTD) editor to definea DTD.

Chapter 10, Writing X Path Expressions, includes complete information about how to
define a query, which must be an XPath expression. In addition to explicitly running
aquery on an XML document, you specify queriesasthevaluesof sel ect and mat ch
attributes in styleshests.

Chapter 11, Working with XQuery in Stylus Studio, describes how to work with
XQuery in Stylus Studio, including how to use the XQuery debugger.

Chapter 12, Composing Web Service Calls, describes how to design, compose, and
test aWeb service call without writing any code, and how to use the Web servicecalls
you create elsewhere in Stylus Studio.

Chapter 13, Working with WSDL Documents, describes how to compose and review
Web Services Description Language (WSDL) documentsin Stylus Studio.

Chapter 14, Building XML Pipelines, describes how to use Stylus Studio to create an
XML pipeline application that chains together two or more XML transformations,
and how to generate Java code you can use to deploy that application.

Chapter 15, Publishing XML Data, describes how to use Stylus Studio to use XML
Publisher to generate X Query or XSLT that createsHTML+CSS or X SL-FO reports
using XML and non-XML data sources.

liv
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Chapter 16, Integrating with Third-Party File Systems, describes how Stylus Studio
isintegrated with third-party file systems like RainingData® TigerLogic® XML Data
Management Server (TigerLogic XDMS).

Chapter 17, Extending Stylus Studio, provides a description of advanced Stylus
Studio features, including information about using the Stylus Studio custom
document wizard.

Chapter 18, The Stylus Studio Java API, was deprecated in Stylus Studio 2007 XML
Enterprise Suite Release 2. The functionality provided by the Stylus Studio Java API
has been replaced by DataDirect XML Converters™ standalone components for
Java™ and .NET. See the DataDirect XML Converters documentation for more
information: http://www.xmlconverters.com/doc/..

Conventions in This Manual

This section describes the typographical and formatting conventions used in this manual
for text, notes, warnings, and important messages.

Typographical Conventions

This manual uses the following typographical conventions:

Bold typeface in this font indicates keyboard key names (such as Tab or Enter) and
the names of windows, menu commands, buttons, and other user-interface elements.
For example, “ From the File menu, select Open.”

Italic text emphasizes new terms when they are introduced.
Code samples appear in text like this:
- Xdebug - Xnoagent - Xrunj dwp:transport=dt_socket,
server =y, suspend=n, addr ess=8000 - Dj ava. conpi | er =NON\E
Monospace typeface indicates text that might appear on a computer screen such as
» Code that the user must enter
= System output (such as responses, error messages, and so on)
» Filenames and pathnames
= Software component names, such as class and method names

Essentially, monospace typeface indicates anything that the computer is*saying,” or
that must be entered into the computer in alanguage that the computer “understands.”
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Bold monospace typeface emphasizestext that would otherwise appear in monospace
typeface.

Monospace typeface in italics Of Bold monospace typeface in italics (depending
on context) indicates variables or placeholders for values you supply or that might
vary from one case to another.

0 Procedures are introduced this way:

Syntax Notation

This manual uses the following syntax notation conventions:
o Brackets ([ 1) in syntax statements indicate parameters that are optional.

« Braces({ 1) indicate that one (and only one) of the enclosed itemsis required. A
vertical bar (|) separates the alternative selections.

« Ellipses(...) indicate that you can choose one or more of the preceding items.

Information Alerts

Thismanual highlights special kinds of information by shading the information area, and
indicating the type of alert in the left margin.

Tip A Tip flag identifies information that can help you use Stylus Studio more effectively —
short-cuts, alternatives, and information about system behavior are all examples of tips.

Note A Note flag indicatesinformation that complementsthe main text flow. Such information
is especially needed to understand the concept or procedure being discussed.

Important AnImportant flag indicatesinformation that must be acted upon within the given context
in order for the procedure or task (or other) to be successfully completed.

Warning A Warning flag indicates information that can cause loss of data or other damage if
ignored.
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Edition Alerts

Not all features are supported in all editions of Stylus Studio. Documentation that
describes features peculiar to agiven edition isidentified with an aert like the following:

XML Pipelines are available only in Stylus Studio XML Enterprise Suite.

See “ Stylus Studio Editions” on page 3 for more information about the features that are
availablein a given edition.

Video Alerts

Stylus Studio provides dozens of video demonstrations of editing tools and features for
XSLT, XQuery, XML Schema, relational-toXML conversion, and others. Sectionsin the
documentation that describe a Stylus Studio feature for which avideo demonstration
exists include an alert like the following:

Watch it! You can view a video demonstration of this feature by clicking the
television icon or by clicking this link: watch a video on Custom XML
Conversions.

Clicking either the television icon or the hyperlink launches the video.

Video Descriptions

You can find descriptions of all Stylus Studio video demonstrations here:
http://www.StylusStudio.com/xml_videos.html
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Available Documentation

Table 1 lists the documentation supplied with Stylus Studio® 2009. In addition to the
documentation listed in this table, Stylus Studio® 2009 comes with sample files. All
documentation is included with the Stylus Studio® 2009 media and downloads.

Table 1. The Stylus Studio® 2009 Documentation Set

Document

Description

Sylus Sudio® 2009 User Guide Describes how to use Stylus Studio to develop XML applications

using XML, SQL/XML, XQuery, Web Services, and XSLT.

ReadMe

Describes featuresin the current release of Stylus Studio® 2009
plus late-breaking information and known issues. The release
notes arelocated in the \doc directory where you installed Stylus
Studio.

Online help

Stylus Studio’s online help system can be accessed from the
application by pressing F1 or by selecting Help >
Documentation from the menu bar. You can also view the help
independently of the application, by opening ide. chminthe\doc
directory where you installed Stylus Studio.

Technical Support

Submit questions and report problems using the Stylus Studio Developer Network
(SSDN). SSDN has numerous active forums, including specialized forums for

XQuery

XSLT

Code samples and utilities
General technical questions
Feature requests

SSDN isfully searchable, and contains current as well as historical information about
Stylus Studio and XML technologies. If you cannot find the answer to the question you
have, submit it to the forum and a Stylus Studio technician will respond to you.

When submitting a question or reporting an issue, it often helps to state the version of
Stylus Studio you are running (click Help > About Stylus Studio on the menu bar) aswell

[viii
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Technical Support

as any other information about your environment you think might be relevant (such asthe
JVM version you are using, for example).
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Chapter1 = Getting Started with Stylus Studio®

Stylus Studio® isan integrated development environment (IDE) for XML and related
technologies. Stylus Studio allows you to design, develop, and test XML applications
using itsintuitive graphical interface, textual editors, and debuggers for XML, XML
Schema, DTD, XQuery, XSLT, Web services, and Java.

Stylus Studio - [order. pipeline ™] =1
x

E_w File Edit ¥ew Project Debug ZMLPipeline SourceControl Tools Wwindow Help

EE R B Xk ($ M8 e

LR el
P ti R P
;:r:;las i X A D,de,_pip___'| XML Pipeline Editor
Mame Eutract full order in... I - 1
_waquery file file: /4 /c: /Program ... L ag [Soenarial Vi [:] YR U &l UeEIIheE (EnE

DB Connections A | Tookax

L] L] 2
(ConvertToXML ([ ConvertToRmL

ED ::} Choose  ConvertFromxML ZonvertToxXML
Properties window :\1 X
i T

[]
[e]
L]

Canvas

X

ipeline Pipeline Input Pipeline Output

£ 3
o e
SEEET-TE Stop Walidate
BE B0
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HEL-FO
@ A] y @
oy PA @ 3
For Help, press F1 MUM

Figure 1. Stylus Studio’s XML Pipeline Editor
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Stylus Studio includes modules for:

XML

XQuery

XSLT

XML Pipelines

XML reporting
Relational data sources
DTD

XML Schema

Web services

Java

Converting non-X ML filesto XML, and vice versa

Each module has one or more editors to help you author, edit, and debug XML
applications.

This chapter provides atour of the basic operations Stylus Studio provides with each of
itsmodules. It also includesinformation about opening filesin any module, using projects
to organize files, and setting options that affect all modules.

This chapter is organized as follows:

“Stylus Studio Editions’ on page 3

“Integrated Components’ on page 4

“Starting Stylus Studio” on page 8

“Updating an XML Document — Getting Started” on page 10
“Working with Stylesheets — Getting Started” on page 30
“Using the XSLT Mapper — Getting Started” on page 41
“Debugging Stylesheets — Getting Started” on page 49
“Defining aDTD — Getting Started” on page 57

“Defining an XML Schema Using the Diagram Tab — Getting Started” on page 62
“Opening Filesin Stylus Studio” on page 87

“Working with Projects’ on page 95

“Customizing Tool Bars’ on page 113

“Specifying Stylus Studio Options’ on page 115

“Defining Keyboard Shortcuts’ on page 120
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“Using Stylus Studio from the Command Line’ on page 123
“Managing Stylus Studio Performance” on page 127
“Configuring Java Components’ on page 131

Stylus Studio Editions

Stylus Studio is offered in several editions to provide atool that is appropriate for every
level of user, from integration architects and application developers providing enterprise-
class solutions, to students and non-professional users just starting out with XML and
related technologies.

Stylus Studio XML Enterprise Suite

Stylus Studio XML Enterprise Suite is Stylus Studio’s most comprehensive XML |IDE,
offering acomplete and robust set of tools for writing, testing, debugging, and deploying
XML applications. In addition to editors for XML, XML Schema, XQuery, and XSLT,
Stylus Studio XML Enterprise Suite provides the following features exclusive to this
edition of Stylus Studio:

Javaand C# for .NET code generation for deployment of XQuery and XSLT
transformations

The ahility to expose XML Schemato Java bindings

XQuery and XSLT Profilersto help you gather performance metrics and troubl eshoot
performance bottlenecks

Custom XML Conversions, amodulethat allowsyou to easily convert non-XML files
like EDI and CSV to XML

Web Service Call Composer to help you build and test calls to hundreds of industry-
standard Web services

Integration with Raining Data Tiger Logic XDMS
Support for OASIS catal ogs, including dozens of catal ogs bundled with Stylus Studio

Stylus Studio XML Professional Suite

Stylus Studio XML Professiona Suite provides a complete set of tools for the XML
application developer, including XML Differencing for comparing multiple XML
documents and folders.

XML Differencing is also included in Stylus Studio XML Enterprise Suite.
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Stylus Studio Home Edition

Stylus Studio Home Edition isavalue-priced XML IDE that provides an excellent way to
learn about and work with XML and its rel ated technol ogies. Stylus Studio Home Edition
offers many of the features of Stylus Studio XML Professional Suite, allowing you to do
real work with XML, XML Schema, XSLT, DTD, and other important XML
technologies.

Edition Alerts

&

The Stylus Sudio® 2009 User Guide describes features found in all Stylus Studio
editions. Alerts, like the one shown here, are used to identify documentation describing
features found only in particular Stylus Studio editions.

,:""3 The XML Editor Grid tab is available only in Stylus Studio XML Enterprise Suite

and Stylus Studio XML Professional Suite.

More Information

For a compl ete description of Stylus Studio XML Enterprise Suite, Stylus Studio XML
Professional Suite, and Stylus Studio Home Edition, see the Stylus Studio Web site:
http://www.StylusStudio.com/xml_feature_comparison.html

Integrated Components

Stylus Studio XML Enterprise Suite is fully integrated with these DataDirect products:
« DataDirect XML Converters™ for Java

o DataDirect XML Converters™ for .NET

o DataDirect XQuery®

The XML Converters™ are high-performance Java™ and .NET componentsthat provide
bi-directional, programmatic access to virtually any non-XML fileincluding EDI, flat
files, and other legacy formats. DataDirect XML Converters allow developersto
seamlessly stream any non-XML dataas XML to industry-leading XML processing
components or to any application. They support StAX, SAX, XmlReader, XmIWriter,
DOM and I/O streaming interfaces, and can be embedded directly for transformation
purposes, or as part of achain of programsincluding XSLT and XQuery, or even inside
XML pipelines. DataDirect XML Converters maximize developer productivity and
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provide afast, scalable solution for converting between EDI and other legacy formats and
XML.

DataDirect XQuery® isan X Query processor that enables developersto accessand query
XML, relational data, SOAP messages, EDI, legacy, or a combination of data sources,
and, in addition, provides full update support for relational data. DataDirect X Query
supportsthe X Query for Java™ (X QJ) API, and iseasily embedded into any Javaprogram
—it does not require any other product or application server, and has no server of its own.

Evaluation copies of these DataDirect products are installed in the \Components directory
where you installed Stylus Studio. These copies provide full development libraries,
sample code, and user documentation.

How Stylus Studio Uses Integrated Components

Stylus Studio uses the DataDirect X Query® and XML Converters™ engines to process
XQuery and XML conversions. These processing engines run under the covers
throughout Stylus Studio —in the XQuery module, EDI to XML Conversions module,
XML Pipelines module, and the Custom XML Conversions module, to name afew.

You can also use the APIs for these components to build and test applications that run
outside Stylus Studio. You might, for example, want to build an X Query application using
Java or C# code for .NET generated by Stylus Studio for the X Query you develop using
the Stylus Studio X Query module.

Managing Component Licenses

Each DataDirect component is installed with an evaluation license that allows you to
develop and test X Query and XML conversion applications. Applicationsthat you deploy
outside Stylus Studio might require alicense for DataDirect XML Converters™,
DataDirector XQuery®, or both, regardless of whether the application is built using a
DataDirect API or simply takes advantage of the XQuery or XML Converters processing
engines.

The Stylus Studio License Manager

The Stylus Studio License Manager allows you to perform the following tasks for
DataDirect X Query® and XML Converters™ components. You can

« Extend the evaluation period

o Addand remove license keys
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The License Manager is on the Components page of the Options dialog box (click Tools
> Options on the Stylus Studio menu). As seen in the following illustration, licenses for
each component are managed separately:

Options §|
© Gen:«:;lication Settings =
Editor General m Files\Styluz Studio 2009 3ML Enterprise Suite\Componentz\D atalirect X Query E]
Editar Sensei
Editor Format Lizenze b anager
B ack-mapping

. Ewaluation; all databases; unlimited CPUs; expires Thu Sep 25 09:23:56 EDT 2008
Spell Checking

Components
ML Converters For Java

Add ] [ Remove ] [Extand Evaluation

Custorn ¥ alidation Engines
55 Module Settings

£ EDI toxML

ED| Viewer Settings
3 Java

Diebugger
£ Web Service Call Composer

Figure 2. Stylus Studio License Manager

The component name Folder field displays the location of the DataDirect component
installation whose license you wish to manage. You can use the License Manager to

manage license keys for
« The copies of the DataDirect components that are installed with Stylus Studio. This
is the default.

« Standalone ingtallations of the DataDirect components. If you acquired a separate
copy of a DataDirect component, you can specify its URI in the component name
Folder field.

How to Extend an Evaluation

O To extend an evaluation:

1. Select the component whose evaluation you wish to extend from the Components
tree in the Options diaog box.

2. If necessary, changethe URI in the component name Folder field to point to the folder
where the component whose license you wish to manage is installed.
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Click the Extend Evaluation button.
An entry field appearsin the License Manager list box.

Replace the instructional text with the IPE key.

Press Enter or click the OK button.
Thelicenseis added to your XML Converters™ installation.

Click OK to close the Options dialog box.

How to Add a License

00 To add alicense:

1.

Select the component for which you wish to add alicense from the Components tree
in the Options dialog box.

If necessary, changethe URI in the component name Folder field to point to thefolder
where the component whose license you wish to add isinstalled.

Click the Add button.
An entry field appearsin the License Manager list box.

Replace the instructional text with the IPE key.

Press Enter or click the OK button.
Thelicense for your XML Converters™ installation is added to the license manager.

Click OK to close the Options dialog box.

How to Remove a License

00 To remove alicense:

1.

Select the component whose license you wish to remove from the Components tree
in the Options dialog box.

If necessary, changethe URI in the component name Folder field to point to thefolder
where the component whose license you wish to remove is installed.

Select the license you want to remove from the License Manager list box.

Click the Remove button.
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5. Press Enter or click the OK button.
Thelicense is removed from the license manager.

6. Click OK to close the Options dialog box.

Starting Stylus Studio

Throughout this chapter, you perform exercises that require you to first start Stylus
Studio. For example, if you installed Stylus Studio XML Enterprise Suite, you would
0 Select Start > Programs > Stylus Studio XML Enterprise Suite > Stylus Studio.

The path shown here assumes that you accepted the defaults when you installed Stylus
Studio. If you did not, you must alter your selection path accordingly.

You can also start Stylus Studio by double-clicking the desktop icon, which is added to
your desktop by default when you install Stylus Studio:

Figure 3. Example of a Stylus Studio Desktop Icon
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On startup, Stylus Studio displaysthe Tip of the Day diaog box.

o dia - [order. pipe =]
{ew File Edit Wiew Project Debug x¥MLPipeline SourceControl Tools Window Help x
) ¢
& Tip of the Day
Project ] T
= 53_-' examples @ - :
i Did you know...
Qg “  voEs
orde The new XML Fipeline Editor, available in Stylus Studio - Toolbox
= creat] | 2007 XML Enterprise Suite, helps you create an XML e
= pipeling - a chain of XML transformations and flow &
s OES | ontral operations. You can use data from numerous P
ar C1E3 | cnirees (ML, relational, Web services, CSY, EDI, and Choose
3 Al others), and generate Java code to execute the XML b
(3 stocks pipeline as an application. Click File = New = XL
3 servet Pipeline to get started E
=23 query
o books. ConvwertFromiML
i b?UkS‘U' [¥] Show Tips at Startup
o Mizedcat —
=23 WideoCenter L -I::>D‘[E
= mavies html LE =
o videos. kml | | ComvertTosmL
s Wideoswed 2 < | > v
For Help, press F1 ML

Figure 4. Stylus Studio on Startup (XML Enterprise Suite Shown)

Getting Updates

By default, Stylus Studio checks the Stylus Studio Web site for newer versions each time
you start the application. You can review and modify this and other application settings
by selecting Tools > Options from the menu bar and selecting the Application Settings
page.

If you want, you can perform this check manually by selecting Help > Check for latest
version from the Stylus Studio menu.

Getting Help

Asyou use Stylus Studio, you can press F1 at any time to obtain context-sensitive help.
If you want, you can open the online help manually (and independent of the Stylus Studio
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application) by selecting Start > Programs > Stylus Studio XML Edition Name> Stylus
Studio Documentation.

Note The online documentation is not installed with Stylus Studio. The first time you access
the online documentation, you are prompted to download it from the Stylus Studio web
site. By default, the online documentation is installed in the \doc directory where you
installed Stylus Studio.

Updating an XML Document — Getting Started

Each of the following topics contains instructions for editing a sample XML document.
You should perform the stepsin each topic before you move on to the next topic. After the
first topic, some steps depend on actions you performed in a previoustopic. This
introduction to updating XML documentsin Stylus Studio is organized as follows:

« “Opening a Sample XML Document” on page 10

o “Updating the Text of a Sample Document” on page 12

« “Updating the Schema of a Sample Document” on page 18

« “Updating the Tree Representation of a Sample Document” on page 24
o “Updating a Sample Document Using the Grid Tab” on page 27

Opening a Sample XML Document

[0 To open the your-quotes.xml sample XML document in Stylus Studio:

1. IntheFile Explorer window, navigate to the examples\quotes directory inyour Stylus
Studio installation directory.

Tip The\examples directory isasibling of \bin.

2. Double-click your-quotes.xml.
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Stylus Studio displays the your-quotes.xm1 document in the XML editor. Theinitial
view of the document is the Text view, asyou can see by the tab at the bottom of the

window.
Stylus Studio - [your-quotes.xml]
E_xm File Edit W¥iew Project Debug #ML SourceControl Tools ‘wWindow Help x
g n= . =
g‘;,’iﬁ 1 - L8 % = 0
: = [
24| o |
L yuul-quot...|
GoemWr £ A W
E< = A~
= < =
< =EML Innovations< =
< =EMLT< =
< *Nasdag NM3< >
< =7 16 >
< =27 1/4< =
= >=1.58< >
< =108, 10 5/8< =
< =27 9/16, 26 1/2< =
< =105, 100< =
< =27 11/16é< =
< =27 3/8< >
< B
= = =
T < *%8L Solutions< = v
\Text ATree }\‘Grid }\‘Sc:hemal#r
For Help, press F1 Ln1Col 1 Char 60 (0x003C) MM

Figure 5. Editors Use Color-Keyed Text

Tip Stylus Studio usesdifferent colorsto distinguish markup, tag names, and datain all of its
text editors. Orange, for example, identifies elements that are not associated with a
schema. You can change the colorsfor editorsindividually. Select Tools > Options from
the menu bar, then select Editor Format. You select the editor whose settings you want to
modify using the Editor drop-down list.

Alternatives
The File Explorer window is the primary way to open and access filesin Stylus Studio,
but you can also open files using:

« TheOpen dialog box, which is displayed when you select File > Open from the menu
bar or click the Open @ button on the tool bar, for example.

« TheProject window, which is displayed on the left of the Stylus Studio desktop. The
Project window shows only those files associated with Stylus Studio projects.
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For more information

See “Opening Filesin Stylus Studio” on page 87 to learn more about the File Explorer
window.

See “Working with Projects’ on page 95 to learn more about projectsin Stylus Studio.

Updating the Text of a Sample Document

When you update an XML document in the Text view of the XML editor, you can usethe
usual editing tools, aswell as tools tailored for handling XML.

Each of the following topics containsinstructions for editing a sample XML document.
You should perform the stepsin each topic before you move on to the next topic. After the
first topic, some steps depend on actions you performed in a previous topic.

For more information on editing tools and features, see “Using the Text Editor” on
page 141.

This section provides instructions for

« “Displaying Line Numbers’ on page 12

« “Adding Elementsin the Text View of a Sample Document” on page 13

« “Copying and Pasting in the Text View of a Sample Document” on page 14

« “Undoing Operationsin the Text View of a Sample Document” on page 14

o “Inserting Indentsin the Text View of a Sample Document” on page 15

o “Querying in the Text View of a Sample Document” on page 16

« “Deleting and Saving Queries’ on page 17

Displaying Line Numbers

Stylus Studio letsyou optionally display line numbersin most of itseditors. Line numbers
provide simple, unobtrusive points of reference that can make working large or complex
documents easier. Line numbers are off by default; turn them on now.

0 To display line numbers:

1. Select Tools > Options from the Stylus Studio menu.
Stylus Studio displays the Options dialog box.

12
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2. Click Application Settings > Editor General.
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I General - —
pplication Settings Editor: | #ML Editor b Mewline format | Preserve Original -
M E ditor General [] Show line numbers . ‘wiord delfimiters: | <3""=.2 A0
Editor Farmat Tiatle sl eokiAy
B ack-mapping : ]
Spell Checking Indenter Settings Tah Settings
File Types ] Preserve hailing/leading whitespace () Keep Tabs
JavaVitual Machine Prezerve newlines between elements () Insert Spaces
Custom Tools
Custom File Systems Wiap attributes if they exceed column | 256 Tab Size: |4
Customn Document Wizards
Custom ¥ alidation Engines
I3 Module Settings Sense:
[E9 DBtaXML Sensge: enabled Auto-close open tag when tping </
& Defait Datebase Connact . [#] swtamatically insert attribute value  [] Add chozing bag when creating new tag
arva
Debugger Dropdown delay: Short : Long
7 ‘Web Service Call Composer
P'D_"-” Settings [ Do not add *Created with Stz Studio” comment at the end of a document
£ ML Diff
Engine
Presentation 3

Figure 6. Sense:X and Other Editor Features are in the Options Dialog Box

3. Select XML Editor from the Editor drop-down list.
4. Click Show line numbers.

5. Click OK.

Adding Elements in the Text View of a Sample Document

0 To add elements in the Text view of your-quotes.xml:
1. Inthe XML editor window, click in thefirst line just after <ticker>.

2. Press Enter and type <quote><company>data</.

Sense:X™ Auto-Completion

As soon as you type the closing forward slash, Stylus Studio displays company> because
itisthe only element that is appropriate to close. Automatic closing of open tagsis part
of Stylus Studio’s Sense: X intelligent editing. You can change this and other Sense: X
optionson the Editor General page of the Options dialog box —for example, you can have
Stylus Studio display alist of appropriate elements, even if that list includes one only
item.
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Stylus Studio’s Sense: X provides even greater functionality if the document you are
editing has either aDTD or XML Schema associated with it. See “ Sense:X Speeds
Editing” on page 143 for more information.

Copying and Pasting in the Text View of a Sample Document

0 To copy and paste elements in the Text view of your-quotes.xml:
1. Usethe mouse to select the text for one quote element and its contents.

2. Inthe menu bar, select Edit > Copy.
Alternatives. Press Ctrl+C or click Copy.

3. Scroll downinthe XML editor and click just before </tickers.

4. Inthe menu bar, select Edit > Paste.

Stylus Studio copies the quote element here, but the indentations are not quite right.
Instructions for fixing this arein the topic “Inserting Indents in the Text View of a
Sample Document” on page 15.

Alternatives: Press Ctrl+V or click Paste. B .

Undoing Operations in the Text View of a Sample Document

0 To undo operations performed on the your-quotes.xml document:

1. Inthe menu bar, select Edit > Undo to remove the text you just pasted.
Alternative: Press Ctrl+Z.

2. Inthe menu bar, select Edit > Redo to replace the text you just removed.
Alternative: Press Ctrl+Y.

3. Inthe XML editor window, click Indent XML Tags s ¢ , which isthe left most button.

Stylus Studio displays a message that alerts you that there is an open tag for a quote
element but no close tag. The messages indicates the line and column in which the
error was found.

4. Intheaert box, click OK. Because the document is not well-formed XML, Stylus
Studio does not insert indents in the document. The next topic, “Inserting Indentsin
the Text View of a Sample Document” on page 15, shows how to fix the document so
that it is well-formed.
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5. Inthe menu bar, click Edit.

The Undo and Redo operations are no longer active. After you click the Indent XML
Tags button, you cannot automatically undo or redo recent changes. It does not matter
whether or not Stylus Studio actually inserts the indents. After you make another
change, the Undo operation becomes active again.

Inserting Indents in the Text View of a Sample Document

[0 To insertindents in your-quotes.xml:

1. Inthe XML editor tool bar, click Indent XML Tags +¢ again.

Stylus Studio displays the message that indicates that a close tag is missing. It
specifiesthe element name, and the line and column numbers that identify where the
error was found.

2. Intheadert box, click OK.
Stylus Studio moves the cursor so that it appearsimmediately after the quote tag that
has no closing tag.

Tip The current cursor location within the document is displayed as line/column
coordinatesin the Stylus Studio status bar at the bottom of the Stylus Studio window.

11 = =105,100= =

1z < =27 11/1é< >
13 < =27 3/8< =

14 |« >

?

LT e e

Figure 7. Document Position Displayed in Status Bar

<
\Text ATree I}‘Glit:l .}\ Schema .'"

3. Inline2, click after the </company> tag and type </. By default, Stylus Studio displays
quote> because it is the only element that is appropriate to close.

4. Inthe XML Editor tool bar, click Indent XML Tags & & .

Thistime, Stylus Studio correctly indents the XML text.
Indent XML Tags changes your XML document by inserting white space. If thisis
undesirable, and you want to check for well-formedness, click the Tree tab at the bottom

of the XML Editor window. If the document is well-formed, Stylus Studio displaysthe
tree representation. If the document isnot well formed, Stylus Studio displays a message
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that indicates the reason the document is not well formed and the location of the error or
omission.

Querying in the Text View of a Sample Document

You use the XPath Query Editor to query XML documents using X Path. Stylus Studio
supports both XPath 2.0 and 1.0. The default is X Path 2.0.

The XPath Query Editor is a dockable window that appearsto the right of the XML
document window. If you do not seeiit, click the Show XPath Query Editor button ([I4]).

Ex»ﬂ File Edit Wew Project Debug XML SourceControl Tools ‘Window Help

™1 - I = @ : #h

#Path Query Editor

D

Mamespace LRI Prefix from D ocument Fedefined Prel

ML youl-quol...|
o mate | @ F 4
= < =

#XML Innovafflons-
FEMLI<
>Nasdag NME<
==7/16<
=27 1/4< >
==1.58<
=108, 10 3
=Z7 9716,

=105, 100=
=27 11/16<
=27 3/8= >

L & 1

AA A A A A A A A A A

14 < >
15 M < =

X80 Solutions<
=EELE =
>Nasdag NME<

==9/16+< = v
b

A A A

<
\Text A Tree } Grid J, Schema /

Ln 1 Col 1 Char 60 {0x003C) MUM

Figure 8. XPath Query Editor

[l To query your-quotes.xml:
1. Click the Query 1 tab in the XPath Query Editor.

2. Type /ticker/quote and click the Execute Query button ((® ).

Stylus Studio runsthe /ticker/quote query on your-quotes.xml, and displays the
results at the bottom of the XPath Query Editor window.

3. Inthe Query Output window, expand the second quote element to view its contents.
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4. Click the symbol element.

In the Text view, Stylus Studio uses its back-mapping feature to move the cursor to
the source element for the symbol result element you clicked.

BT & Yx[O $ S Qi #h 4

H#Path Guery Editor L o=

PO 23 [a)

o
i A E s (f f. & Marmespace LRI Prefix fram Document Redefined Prefix

< = ~
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*Nasdaqg NM3<
==T7/16< =
=27 1/4< =
==-1.58< 1 /ticker/quote
=108, 10 5/8<
27 9/16, 26 :
=105, 100= >
=27 11/16<
=27 3/8< =

e pour-quot. .. |

Queryl

Mo~ omom bW ok =

A A A A A A A A A A

Tag Walue
"% company X3L Solutions

19

\ Test i Tree }, Grid J, Schema / = . D
Ln 17 Col 30 Char 0 {0x0000) MUM

Figure 9. Backmapping from XPath Query Result to XML Document

5. Inthe Text view, click the down arrow to the right of the query field.

6. Inthe XPath Query Editor window, click the New Query button ([0)).
Stylus Studio adds a new tab for each query you define.

7. Type //company and click the Execute Query button ([ ).
Stylus Studio runs the new query and displays the results.

8. Closethe XPath Query Editor window by clicking the x in that window’s upper right
corner.

Deleting and Saving Queries

You cannot explicitly delete aquery. In addition, queries you define are not saved with an
XML document unlessthat document belongsto a Stylus Studio project —if you closethe
XML document and then reopen it, the queries you defined in the previous editing session
are no longer there.
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For more information
See “Using the XPath Query Editor” on page 680 to learn more about the X Path Query
Editor.

See “Working with Projects’ on page 95 to learn more about projects and their role in
Stylus Studio.

Updating the Schema of a Sample Document
This section provides instructions for updating the internal DTD for your-quotes.xm1.

When an XML document has an external DTD, you can view the external DTD in the
Schema tab of the XML Editor, but you cannot edit it. To be ableto edit an external DTD,
you must open it in the DTD editor. When an XML document has an internal DTD, you
can view and edit it in both the Schema tab and the Text tab of the XML editor.

You should have already performed the steps in “ Updating the Text of a Sample
Document” on page 12. Each of the following topics containsinstructions for editing the
sample XML document. You should perform the stepsin each topic before you move on
to the next topic. After the first topic, some steps depend on actions you performed in a
previous topic.

This section includes the following topics:

o “Creating a Sample Schema’ on page 18

« “Defining a Sample Element” on page 20

« “Adding an Element Reference to a Sample Schema” on page 22

o “Defining an Entity in a Sample Schema” on page 23

« “Exploring Other Featuresin a Sample Schema’ on page 23

For more information, see “Defining a DTD — Getting Started” on page 57.

Creating a Sample Schema

0 To create the schema of a sample XML document:

1. If itisnot already open, open your-quotes.xml. See “Opening a Sample XML
Document” on page 10 if you need help with this step.

2. At the bottom of the XML editor window, click the Schema tab.
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Stylus Studio displays the Schema tab, and opens the Properties window. The
Schema tab displaysa DTD tree, which is currently empty.

Stylus Studio - [your-quotes.xml]

Eile Edit Yiew Project Debug XML DTD XMLSchema SourceContral Tools Window Help
= = Ei ? dh
Froperties x your-quol...‘
F & WS |§| v T T2 [ |z: //company v
PCEE oo |
N

Figure 10. Default Schema Tab for Document With no Schema

3. To create aschemafor your-quotes.xml, select XML > Create Schema from XML
Content from the Stylus Studio menu.

Stylus Studio displays the Create Schema or DTD dialog box. By default, Stylus
Studio generates an internal DTD and insertsit in aboCTYPE element at the beginning
of the document. You can also use this dialog box to generate an external XML
Schemaor DTD.

Create Schema or DTD fXI

Use this dialog box to generate =ML Schema or a DTD based
on the current XML document's content

(%) Generate %MLS chema

Output File: | B

() Generate DTD

[ 0K ] [ Cancel ]

Figure 11. Create Schema or DTD Based on XML Content
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4.

Click Yes toinstruct Stylus Studio to create a DTD based on the XML document

content.

Stylus Studio displays atree representation of the new, internal DTD. It also displays
the Properties window.

7 Stylus Studio - [your-quotes.xml *] =1
Eile Edit “iew Project Debug XML DTD ¥MLSchema SourceControl Tools \Window Help o
Hr=zE = B 7 dh
Properties x youl-quo..."
ra 4
= & B
"E ticker
"5 quote
"® company
"8 symbol

®® sxchange
Enk "% change
Bt "3 last
®® potchange
"% yrhighlow
®® davhighlow
"8 volume
"% prevelose
®® open

T i %

\Text }‘Tree }‘ Grid ;\Sehama l{r

For Help, press F1

UM

Figure 12. Result of Generating a Schema Based on XML Content

Defining a Sample Element

0 To define a new element in the Schema view of the sample schema:

1.

Click the company element in the Schema tab.

20
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This selectsthe company element definition and displaysthe propertiesfor the company
element in the Properties window.

Stylus Studio - [your-quotes.xml]

wa Fila Edit VWiew Project Debug XML DTD SourceControl Tools Window Help x
# 2@l BT s
Properties x 5
| yOUr-quo....
Type Element 5 |
MName COmMpany e
Content Model Mixed W @ fdebv x <.g + ¥ WS E'“
% B & DTD ~
®® ticker
1 "% gquote
"o
B symbol

"% exchange

hance .
Tewt p Tree f Giid Schemal,rJ

JFor Help, press F1 UM
Figure 13. Properties Window Displays Element Properties

The Content Model property indicates the allowable contents for a company €lement.
Inthisexample, itisMixed, which meansthat a company €lement can contain specified
elements (as opposed to all elements defined in this DTD), attributes, and raw data.

Tip Windowslikethe Properties and Query Output windows are docking windows—you
can changetheir location within the Stylus Studio window, or separate them from the
Stylus Studio entirely, by dragging them to the desired location.

2. Click the DTD node.

Intheleft tool bar, Stylus Studio activates only those buttonsthat are applicableto the
DTD —you can add elements, entities, comments, and so on. But you cannot add an
attribute definition, a reference to an element, or a #PCDATA node, for example.

3. Inthelefttool bar, click New Element Definition ¥:® . Stylus Studio displaysan entry
field at the bottom of the tree.

+ U preve lose
+-®% open
|

-]

Iy
Figure 14. Entry Field for a New DTD Element

4. Typelocation and press Enter. Stylus Studio displays the properties for the new
location element in the Properties window.
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5.

In theleft tool bar, click New Modifier 5. Stylus Studio displays a drop-down menu
of optionsthat specify the rules for the occurrence of the children of the new element.

+-®® prevelose
+-®% open
=™ location

0 v

Cptional

Cne or More
Choice
Segquence
One

Figure 15. Drop-Down List for Modifier Values

Double-click zero or More (or click onceto select it and press Enter).

In the left tool bar, click Add #PCDATA #3 . Your definition of the Tocation element
specifiesthat it can contain only raw data.

Adding an Element Reference to a Sample Schema

0 To update the definition of the quote element to include an optional Tocation

element:

1. Inthe Schema tab, expand the quote element.

2. Click its Sequence modifier.

3. Intheleft tool bar, click New Modifier §J.
Stylus Studio displays an entry field for the new modifier at the end of the list of
modifiers that already apply to the sequence modifier. The entry field consists of a
drop-down list of available values for the new modifier.

4. Inthe drop-down list, double-click Optional.

5. Intheleft tool bar, click New Reference to Element E: Stylus Studio displays an
entry field after the new Optional modifier.

6. Type location and press Enter.

7. Tomovethelocation element to be earlier in the sequence, click its Optional
modifier.

8. Inthe XML editor top tool bar, click Move Up 4 repeatedly until thelocation

element is where you want it to be.

22
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Defining an Entity in a Sample Schema

[0 To define an entity in the internal DTD for your-quotes.xml:

1.
2.

Click the DTD node.

In the left tool bar, click New Entity .

At the end of the schema, Stylus Studio displaysEnt and aentry field for the name of
the new entity.

Type TcecC for the name of the entity and press Enter.
In the Properties window, Stylus Studio displays the properties for the new entity.

In the Properties window, double-click the value field.

Type The Country’s Best Computer Company and press Enter.

Exploring Other Features in a Sample Schema

0 To toggle white space or validate your document:

1.

Click Toggle Display of White Space w3 to display nodesthat represent white space
inthe DTD. Click the button again to hide the white space nodes.
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2.

Click validate Document .

Stylus Studio displays a message in the Output window that indicates that the
document is valid.

Stylus Studio - [your-quotes.xml *]

Eile Edit Wiew Project Debug XML DTD XMLSchema SourceControl Tools Window Help X
= M & B Ei ] ? &4
Properties b4 A
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Figure 16. Output Window After Schema Validation

Updating the Tree Representation of a Sample Document

This section provides instructions for updating the DOM tree representation of the your-
quotes.xm1 document.

You should have already performed the stepsin “Updating the Schema of a Sample
Document” on page 18. Each of the following topics containsinstructions for editing the
sample XML document. You should perform the steps in each topic before you move on
to the next topic. After the first topic, some steps depend on actions you performed in a
previous topic.

This section includes the following topics:

“Adding an Element to a Sample Document Tree” on page 25

“Changing an Element’s Data in a Sample Document Tre€” on page 25

“Adding Attributes and Other Node Types to a Sample Document Tree” on page 26
“Adding an Entity Reference to a Sample Document Tree” on page 27

24
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Adding an Element to a Sample Document Tree

[0 To add an element to the tree representation of your-quotes.xml:

1.

Tip

If it isnot already open, open your-quotes.xml.
See “Opening a Sample XML Document” on page 10 if you need help with this step.

At the bottom of the XML Editor window, click the Tree tab.
Stylus Studio closes the Properties window.

You can close the Output window if it is still open from the previous exercise.

Click the plus sign next to the ticker element to expose the children of the ticker
element.

Click New Element ¥:® in thel€ft tool bar to add a quote element to the document.
Stylus Studio displays a drop-down menu that lists the elements you can add at that
position in the tree.

Click quote and press Enter.

Stylus Studio displaysafield next to the new quote element. The DTD allowsagquote
element to contain data.

Click outside the field to close it without entering data.

Changing an Element’s Data in a Sample Document Tree

0 Inthe Tree tab of your-quotes.xml, to change the data that an element contains:

1.
2.
3.

Expand the third quote element.
Click the symbol element.

In the XML Editor top tool bar, click Change Value s# .

Stylus Studio activates the field to the right of the symbol element and selects the
current value.

In the active field, type xsoL and press Enter.

To theright of the exchange element, right-click Nasdag NMS.
Stylus Studio displays a shortcut menu.

Click Change Value. Stylus Studio activates the val ue field for the exchange €lement.
In the active field, type NYSE and press Enter.
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Adding Attributes and Other Node Types to a Sample Document Tree

[0 To add attributes and other types of nodes to your-quotes.xml:

1.
2.

Click the last quote element in the tree.

Click New Attribute .

Stylus Studio displays an attribute name field immediately below the selected quote
element.

ynul-qun,,,’|
& ns Vi) V2 [ |
Tag Walue

+-®% quote

=
@
*\@ Company HTHML Promises
" symhol HTHMLP
.'[: exchange Nasdag NMS

Figure 17. Adding a New Element to a Document Tree

In the attribute name field, type agent and press Enter.

Stylus Studio displays a default value for the attribute, Text, in an entry field to the
right of the new attribute.

In the attribute value field, type Star Brokers and press Enter.

Stylus Studio displays an entry field for a new attribute name, allowing you to easily
add anumber of attributes, one after the other.

Click outside the attribute name field to closeit.

In the XML editor top tool bar, click Validate Document [%].

Stylus Studio displays a message in the Output window that indicates that the
document is not valid. The DTD does not specify the agent attribute for the quote
element. Stylus Studio allows you to modify your document in invalid ways, which
you might want to do during application design. The validation feature informs you
that your document isinvalid when you try to validate the document.

Click the agent attribute.
In the XML Editor top tool bar, click Delete Node 3 .

Click validate Document again.

Stylus Studio displays a message in the Output window that indicates that the
document is now valid.

26
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Adding an Entity Reference to a Sample Document Tree

[0 To add an entity reference to your-quotes.xml:

1.
2.

If itisnot already selected, click the quote element you defined in the previoustopic.
In the | eft tool bar, click New Element ¥:® to add subelements to the new quote
element.

Stylus Studio displays adrop-down menu that lists anumber of el ementsthat you can
insert at this point. Scroll the list to view them all.

Click company, which isfirst in the list, and press Enter.

Stylus Studio displaysafield next to the element name. You can enter data here, such
asthe name of the company. But rather than entering data, suppose you want to refer
to an entity. To refer to an entity:

Click outside the field or press the Esc key.

Click New Entity Reference (4], which isthe last button in the left tool bar.

Stylus Studio displays a drop-down menu that lists the defined entities.

If the New Entity Reference button is not active, click Toggle Display of Entity
References [Fjt inthe XML editor top tool bar. This button allows you to control
whether you can refer to entities.

Double-click TCBCC.

Stylus Studio inserts the text The Country’s Best Computer Company asthe value for
the company €lement.

Click the Text tab at the bottom of the XML editor window.

Stylus Studio displays the &TBCC; entity reference in the new company element.

Click the Tree tab.

Updating a Sample Document Using the Grid Tab

{"5; The XML Editor Grid tab is available only in Stylus Studio XML Enterprise Suite
and Stylus Studio XML Professional Suite.

This section provides instructions for updating the your-quotes.xm1 document using the
Grid tab of the XML Editor. The Grid tab is useful for displaying structured data. Itisa
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convenient way to view adocument that contains multiple instances of the same type of
element, for example.

Watch it! You can view a video demonstration of this feature by clicking the
television icon or by clicking this link: watch the XML Grid Editor video.

A complete list of the videos demonstrating Stylus Studio’s featuresis here:
http://www.stylusstudio.com/xml_videos.html.
(0 To update an XML document using the Grid tab:

1. If itisnot aready open, open your-quotes.xml.
See “Opening a Sample XML Document” on page 10 if you need help with this step.

2. At the bottom of the XML Editor window, click the Grid tab.
Stylus Studio displays atable that contains the XML data.

youl-quol...‘
* F1| T2 b/
"% Tay Hame
= ticker -
"% Tag Hame "% company =8 symbol "% exchange
quote HML Innovations EMLTI Nasdag NMS
quote X3L Solutions E3LI Nasdac NH3
gquote HTHL Promises HTHMLF MNasdag NMS
4 ]
\ Text }\Trae }\Grid A Schema f

Figure 18. Grid Tab

The left most column, with the Tag Name heading, contains the children of the
<ticker> element. The remaining columns contain the grandchildren of the <ticker>
element. The heading of each column identifies the element name — company,
symbol, and so on.

Tip You can resize columns by dragging the handle on the column heading’s right side.
You can change the element order in the document by dragging the handle on the
column heading’s | eft side. Stylus Studio swaps positions with the column on which
you come to rest.

3. Select thelast row by clicking to the left of the last <quote> element.
Therow is highlighted in blue.
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4. Click the Insert row after () button.

A new instance of the <quote> element isadded to the document. The cursor is placed
in the <company> element cell.

"% Tay Hame
= ticker
®® Tag Hame " company "® symbol ®® exchange
quote XML Inncovations XMLI Nasdag NMS
quote 3L Solutions HZL3 Nasdag NMS
quote HTML Promises HTMLP Nasdag NM3

Figure 19. Grid with a New Row
5. TypexML Designs and press Enter.
Stylus Studio creates the value for the <company> subelement.
6. PressTab (or usetheright arrow key) to move the cursor to the next cell in the row.

7. Repeat Step 5 and Step 6 to create values for the <symbo1> and <exchange>
subelements.

8. If you want, you can continue to add the data contained in a quote €lement.

Modifying Values

It is easy to change and delete values in grid fields:

« To changethe value of any field, double-click the field and type the new data. Press
Enter to save the change.

« Todeetethevalueof afield, double-click thefield, select the text you want to delete,
and press the Del ete key.

Moving Around the Grid
You can move around the grid using the mouse and the keyboard.
Using the mouse, click where you want to place the cursor.

Using the keyboard:

« Usethe Tab key to advance the focusto the next cell; use Shift + Tab to move the
focusto the previous cell

o Usethe arrow keysto move the focusin the direction of the arrow you choose
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Working with Stylesheets — Getting Started

Thissection helpsyou get started working with XSLT stylesheets. To focuson stylesheets
that map XML to XML, see“Using the XSLT Mapper — Getting Started” on page 41. To
learn about using XML Publisher to generate XSLT for dynamic HTML reports, see
Chapter 15, “Publishing XML Data.”

Except for the first topic, each of the following topics contains instructions for working
with asample XSLT stylesheet. You should perform the stepsin each topic before you
move on to the next topic. After the first topic, some steps depend on actions you
performed in a previous topic.
Thisintroduction to working with stylesheets in Stylus Studio is organized as follows:
o “Opening a Sample Stylesheet” on page 30
o “XSLT Stylesheet Editor Quick Tour” on page 31

“XSLT Scenarios’ on page 35

To get started, you'll need to start Stylus Studio if you haven't already. See “ Starting
Stylus Studio” on page 8 if you need help with this step.

Opening a Sample Stylesheet

[0 To open the your-quotes.xs1 sample XSLT stylesheet in Stylus Studio:

1. IntheFile Explorer or Open dialog box, navigate to the examples\quotes directory in
your Stylus Studio installation directory.

Alternative: If the Stylus Studio examples project isopen, you can accessthisfilefrom
the Project window. To open the examples project, open examples.prj in the Stylus
Studio examples directory.
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2. Double-click your-quotes.xsl. Stylus Studio displaysthe your-quotes.xs1 document
in the XSLT Source tab of the XSLT editor.

il Stylus Studio - [your-quotes.xml]
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Figure 20. Stylus Studio’s XSLT Editor

Aswith the XML Editor, Stylus Studio uses different colors to distinguish markup,
tag names, and datain the XSLT Editor.

XSLT Stylesheet Editor Quick Tour

When you usethe Stylus Studio X SLT stylesheet editor, youwork with XSLT stylesheets,
XML source documents, and result documents. This quick tour is organized to introduce
you to some of the main features for working with XSLT in Stylus Studio:

o “Partsof the XSLT Editor” on page 32
o “Exploring the XSLT Source Tab” on page 32
« “Exploring the Params/Other Tab” on page 35
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Parts of the XSLT Editor

The XSLT Editor consists of four tabs that allow you to work with XSLT in different
ways, based on your preferences and the functionality that you desire.

Tip

Note

XSLT Source. Use the XSLT Source tab when you want to directly edit or view the
XSLT source code that comprises your stylesheet. The XSLT Source tab can also be
agood way to learn more about XSLT.

XSLT sourceis aso visible from a pane within the Mapper tab.

Mapper. The Mapper tab allows you to create XSLT by graphically mapping source
document nodesto nodesin atarget document. Stylus Studio interprets the mappings
to generate X SLT that will yield adocument conforming to the document described
in the Set Target Document pane.

Using the Mapper tab is discussed in detail in “Using the XSLT Mapper — Getting
Started” on page 41.

Params/Other. You use the Params/Other tab to specify the encoding Stylus Studio
uses to store the stylesheet, the stylesheet’s output method, and the encoding Stylus
Studio uses for the document that results from applying this stylesheet. You can also
use this tab to view default values for parameters used by your stylesheet.

Exploring the XSLT Source Tab

0O To work with the XSLT Source tab:

1.

In the stylesheet text, click anywhere below the third xsl:template instruction (line
11).

32
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In the status bar just below the XSLT Editor tool bar, Stylus Studio displays match: /.
Thisindicates that the location you clicked isinside atemplate that matches the root

node.

& = youl-quol...|

e e B |vourquates v 3 B % ==

@ v |E- g ticker
1 <IDOCTYPE xsl:styleshest [ ~ # sk, quote
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z <xsl:template mateh="text () |@*"=<uxsl:valus-of select
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=] <xsl:template match="*|/"><xsl:value-of select="."/>
10

11 <xsl:template match="/"><HTML>

12 <HEAD

13 <TITLE*Your-Stock-COuote. com</TITLE>

14 </ HEAD>
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< >
\XSLT Source AMapper }\Params.-"Dther .}

Figure 21. Current Template Identity Is Displayed at the Top of the Editor

2. Click inthe xsl:stylesheet instruction (line 5).
Now the status bar is blank. Thisinstruction is not part of atemplate.

3. Inthe XSLT Editor tool bar, click Add a new template T .

Stylus Studio inserts the following after the last template already specified in the
stylesheset.

<xsT:template match="NewTemplate">
</xs1:template>

To define anew template, replace NewTemplate With the match pattern you want, and
add contents to the new template as needed.

Tip You can also create a new template by double-clicking a node on the schematree.
Templates that match nodesin the XSLT document are displayed with acheck in the
schema tree, as shown here.

W B volume

& prevolose

e l open
Yellow indicates that the text cursor inthe XSLT source is within that template.
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Tip

Inthe X SLT Editor tool bar, click Template Mode ' = , whichistheright most button.
Stylus Studio displays only the new template.

%j_voul-qun...‘|
R B prane VD 3 K[ @
@EWW_—@ - |- g ticker
1 <xzl:template mateh="NewTemplate'> - ifa QUOtE
‘ |
3 </xsl:template>

Figure 22. Use Template Mode to Focus on a Single Template

You can edit the stylesheet in either template mode or in full source mode. Intemplate
mode, Stylus Studio displays one template at atime. In full source mode, Stylus
Studio displays the whol e stylesheet.

In large or complex stylesheets, use the XSLT Editor’s status bar to identify the
current template.

In the upper right corner of the editing pane, click the down arrow.

Stylus Studio displays alist of the templates in the stylesheet with their match
patterns.

ﬁjyoul-qun...‘|
F. T3 P |yourquotes v = R

L ticker
-k quote

match: texti)|i@*
mateh: *|f
match:/

mateh: Mew Template

Figure 23. You Can Show Individual Templates in a Stylesheet

Click match: *|/. This displays the template that matches every element and the root
node.

Every stylesheet that Stylus Studio createsincludes two built-in templates. One built-
in template matches every el ement and the root node. The other built-in template
matches all text and attribute nodes. See“ Using Stylus Studio Default Templates’ on
page 426.

To delete atemplate, click the match pattern for the template you want to delete and
then click Delete template ¥ inthe XSLT Editor tool bar. You must bein template
mode to delete atemplate.
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7. Click Full Source Mode

Stylus Studio displays the complete stylesheet. The cursor is at the beginning of the

template that was being displayed in template mode.

Exploring the Params/Other Tab

00 Click the Params/Other tab:

Drop-down menus let you specify the encoding format used to store the stylesheet in
Stylus Studio, as well as method and encoding output attributes. A simple grid displays
the name, source URL, and default value of any global parameters used by the active
stylesheet, as well as by any imported ones.

#5LT Encaoding:

Output method:

unspecified

ﬁ:ﬂyoul-qun...’|

UTF-3 v

<xzhoutputs attributes:

Output Encoding:

b

b

[ Indent

Fead-anly list of global parameters from this and included/imparted stylesheets:

Farameter

Source File

Default alue

iXSLT Source R td apper }\F’arams/Dlher /

Figure 24. Specify XSLT Parameters Here or in XSLT Source

All information that you can specify in the Params/Other tab can a so be specified in the
XSLT source. For example, you can specify the XSLT encoding in the processing
instruction at the beginning of the stylesheet; you can specify the output method and
encoding with the xs1:output instruction. Stylus Studio automatically updates the XSLT
source with any changes you make in the Params/Other tab, and vice versa.

XSLT Scenarios

To apply a stylesheet to an XML document in Stylus Studio, you use a scenario. A
scenario isagroup of customizable settings that allows you to experiment with different
source XML documents (that is, the XML document to which you will apply the XSLT),
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Tip

processors, parameter values, post-processors, and profiling settings. You can also use
scenarios to perform validation on the XML document that results from the XSLT
processing. (Validation is always performed before any post-processing you specify.)
rScenario Properties @1

Existing scenarios: - " ——
g Prafiling Options alidation Post-process

Video Scenario 1

General Parameter Values Processor

Source #ML URL:
file: /#/c: /Program Files/Stylus Studia <ML Professional Edition/ex E]

Output URL [optional]:

v (J
Baze URL for HTML links resolution [optional):
file: /#/c: /Program Files/Stylus Studia <ML Professional Edition/ex  +

Store paths relative to <SLT document path

[] Preview result in an external application

[ 0k ] [ Cancel ]

Figure 25. Scenarios Let You Easily Test Stylesheets and XML Source

You can define multiple scenarios using different settings to see how each affects
document processing. Stylus Studio also supports scenarios for Web service calls,
XQuery, and XML pipelines.

An XSLT scenario is defined by a single stylesheet-XML document pair. You can
associate any number of scenarios with a stylesheet, though only one scenario can bein
effect at the timethe XSLT is processed. Similarly, you can associate any number of
scenarios with an XML source document.

Stylus Studio lets you work with several XSLT processors, including Saxon, MSXML
and .NET.

A scenario has aready been created for the your-quotes.xs1 stylesheet, using the your-
quotes.xm1 asthe source XML document. Run the scenario now and look at the output
created by the XSLT defined in your-quotes.xsT.
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00 To run ascenario, click Preview Result & .

Stylus Studio processesthe source XML document using the X SLT stylesheet you specify
and displays the results in the Preview window.

v File Edit View Project Debug XSLT SourceControl Tools Window Help x
A = [ ™. e =
A Mmi = & & il i L & [ &
7
iy i your-quol...|
BT ¥l = S5
match: text(@* - B g ticker
<IDOCTYPE xsl:stylesheet [ ~ @ xmlr:s
<1ENTITY nhsp "&#lée0; "= = i guote
]=
<xsl:stylesheet version="1.0" zmlns:xsl="http:/ wmm. w3, org/ls
<xsl:template match="text() | @*"><xsl:valus-of select="."/></2
e
4 2 b
\XSLT Source AMapper }‘Params.-"tlther }'
Processing complete [B81 ms)
Presvigw x
> S
Your-Stock-Quotes.com
-
______
SUMMARY
Symbol: Last: Change: % Change:
HMLI 2714 16 -1.58
KELS 45 316 916 -1.23
HTMLP AN +1/8 +1.14 a
\your-quotes [wour-quotes ksl l,rf
JFor Help, press F1 Lnlcoll TLIM

Figure 26. XSLT Processing Results are Shown in the Preview Window

By default, results are displayed using a Web browser. If you choose, you can display

resultsin tree or text format, by clicking Preview in Tree |'L: and Preview Text inthe
Preview window tool bar.

Usethescroll bar to review theHTML inthe Preview window. You can seethat the values
come from the XML document your-quotes.xm1.

Tip Ifitisnot aready open, you can open the source XML document specified in ascenario
by clicking Open XML From Scenario &7 inthe XSLT Editor tool bar.
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Working with Scenarios

To defineadditional scenarios, click the down arrow next to the scenario fieldinthe XSLT
Editor tool bar, and click Create Scenario. After you have more than one scenario, click
the same down arrow to select the scenario you want to use to preview aresult.

To changethe properties of ascenario, or to delete a scenario, select the scenario you want
to change or delete, and then click Browse | ... | to the right of the scenario name field.
Stylus Studio displays the Scenario Properties dialog box.

About Preview

When you preview aresult, Stylus Studio automatically savesthe changesyou have made
to the document. If you want to revert to the document’s previous state, you can use the
undo function (Edit > Undo).

Working with a Sample Result Document

0 To work with a sample result document, follow these steps:

1. InthePreview window, click anywherein the display.
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Using its back-mapping functionality, Stylus Studio displays the template in the
XSLT Editor’s status bar and flags the line that generated the line you clicked with a

blue pointer.

: Stylus Studio - [your-quotes.xml]

gl template match="/".. in your-quotes. =zl [line BE]

l[=
SUMMARY

wr File Edit Wiew Project Debug XSLT SourceControl Tools Window Help X
) = - pa
FARY=] " | Llﬂ:l 0 & N s 0 |
A = —
4 it 5 B 0 B2
Praoject
wir YOUr-quotk..._
% Falder i |
= &R Other Documents R [pourquotes - v = =
. YOUr-guotes.sml = s ! 'E -
v your-gquotes.xsl match:/ - B § ticker ”
<TD width="1Z20"> ~ = E“U‘e
< size="-1"= : zonr:bpjny
} <xzl:value-of select="petchange' 1 E};Change
= = l charge
</TD= v, I last
F A mD ' . l petchange
I 0 . v
\XSLT Source AMapper }\Paramsa‘Dther }
Processing complete [20 ms]
Preview ®
b Your-Stock-Quotes.com &/ Backmep Stack

Symbol: Last: Change: % Change:
ML 1M 718
XKSLS 45 316 -9/16 b
4 2w
\your-quotes [wour-quotes. xzl] /
lFor Help, press F1 Ln 86 Col 1 UM

Figure 27. Back-mapping Shows which XSLT Generated a Result
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2. Intheleft tool bar of the Preview window, click Preview Text [£]. Stylus Studio
displays the HTML file that generates the browser display.

-

Teview x

[ = = = http-equiv="Content-Type" < onteil Back-map Stack
e XMLI) : szl template match="/"".. in your-quates.=sl [line ...
- =/ Bx= == e ==
& TELE) :
</Bw< >< >< =<
§ HTMLE) :
T < = = =< =

1 _’|L|‘| | ¥

A our-quates. html [your-quotes. xz|

Figure 28. You Can Render XSLT Results as Plain HTML

3. ClickanywhereintheHTML display. Thegray backgroundidentifiesany HTML that
was generated by the same template.

Thisworksin reverse aswell. If you click aline in atemplate (full source mode or
template mode), Stylus Studio uses a gray background to display the HTML
generated by that template.

4. Intheleft tool bar, click Export Preview ‘ Stylus Studio displays the Save As
dialog box. If you want, you can enter afile name and click Save to preserve the
generated HTML file. Otherwise, click Cancel.

Note Notice the tab at the bottom of the XSLT Preview window. It specifiesyour-quotes
[your-quotes.xsl]. After you create another scenario and apply the stylesheet in that
scenario, another tab with the name of that scenario will be displayed. You can click
the tab for the result you want to view and easily compare result documents from
different scenarios.
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Using the XSLT Mapper — Getting Started

é;;

The XSLT Mapper is available only in Stylus Studio XML Enterprise Suite and
Stylus Studio XML Professional Suite.

This section helps you get started using the XSLT Mapper to create stylesheets that
aggregate data and transform XML. The sample filesused in this section arein the Stylus
Studio examples\simpleMappings directory. If you follow the proceduresin this section,
you create the BooksToCatalog.xs1 stylesheet. A sample version of this styleshest,
sampleBooksToCatalog.xs1, iSaso in the examples\simpleMappings directory of your
Stylus Studio installation directory.

Each of the topicsin this section contains instructions for working with sample XML
documents that you can use to familiarize yourself with the XSLT Mapper. You should
perform the stepsin each topic before you move on to the next topic — after thefirst topic,
some steps depend on actions you performed in a previous topic.
This section covers the following topics:

“Opening the XSLT Mapper” on page 41
o “Mapping Nodesin Sample Files’ on page 44
o “Saving the Stylesheet and Previewing the Result” on page 47
« “Deleting Linksin Sample Files’ on page 48
« “Defining Additional Processing in Sample Files’ on page 48
In addition to the topics described in this section, the Stylus Sudio® 2009 User Guide
contains other sources of information on XSLT:
o Tolearn more about XSLT, see “Working with XSLT” on page 367.

o Toget started XSLT Editor features for stylesheets, see “Working with Stylesheets—
Getting Started” on page 30.

o Tolearn about the XSLT mapper in greater detail, see “ Creating XSLT Using the
XSLT Mapper” on page 495.

To get started, you will need to start Stylus Studio if you haven't already. See “ Starting
Stylus Studio” on page 8 if you need help with this step.

Opening the XSLT Mapper

This procedure describes how to open the XSLT Mapper and select the files you want to
use for the drag-and-drop operations that will define your XSLT stylesheet.
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0 To open the XSLT Mapper:

Tip

1.

From the Stylus Studio menu bar, select File > New > XSLT Stylesheet.
Stylus Studio displays the Scenario Properties dialog box.

Click the Cancel button to dismiss the dialog box.

Click the Mapper tab.

Stylus Studio displays XSLT editor with the Mapper tab selected. The source pane
beneath the mapper panes appears by default, allowing you to see how the mappings
of XML document elements are rendered as XSLT. The source paneisfully editable
and synchronized with the XSLT Mapper. Of course, you can always click the XSLT
Source tab for afull-screen view of your XSLT code.

4 Stylus Studio - [Untitled4.xsl *] =1
@ File Edit View Project Debug XSLT WYSIANYG SourceContral Tools Window Help x
P BB ?

49 Untitied..."

= Create Scenario... v ] E | | :T:

Add Source Document match=""" w Set Target Document

-
<?xml wversion=T1.0"7> P
<xsl:styleshest wversion="1.0" smlns:xsl="http://wmr.w3.org/1999/281

1

-

3

4  <xsl:template match="/"> r
= %
<

5

#5LT Source hMapper AF’arams.-"Dther }

MM

Figure 29. XSLT Editor Mapper Tab for a New Stylesheet

The Project window also appearsiif it was open the last time Stylus Studio was
closed. You can closeit.

Click the Add Source Document button at the top of the mapper’s | eft pane.
Stylus Studio displays the Open dialog box.
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For this example, navigate to the examples\simpleMappings directory in the Stylus

Studio installation directory.

Double-click books.xml.

Click the Set Target Document button at the top of the Mapper’s right pane.

Stylus Studio displays the Open diaog box.

For this example, navigate to the examples\simpleMappings directory in the Stylus

Studio installation directory.

Double-click catalog.xml.

Stylus Studio displays tree diagrams of these XML documents. The default XSLT

source code has not been altered at this point.

4 Stylus Studio - [Untitled4.xsl *] L OoX
| File Edit View Project Debug XSLT WYSIWYG SourceControl Tools Window Help x
= =i lee st ?
49 Untitied..."
T " Q o
Add Source Document match=""" | Set Target Document
= [# books.xml catalog.xm =]
& books Catalog W=
@ name Book aha &
[#-wkw bOOK
< ¥ < 4
-
1 <?xml wversion="1.0" ?=»
2 <xsl:styleshest versiorn="1.0" mmlns:xsl="http://wmr.w3.org/1999/%21
3 <xsl:template match="/"/>
4  </msl:styleshests
< b4
X5LT Source hMapper AF’arams.-"Dther }
UM

Figure 30. XSLT Mapper Tab with Source and Target Documents
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Mapping Nodes in Sample Files

0 To define links and examine the stylesheet Stylus Studio creates:

Tip

Tip

1.

In the Mapper tab, expand the tree for both books .xm1 and catalog.xm1.

You can display an entire tree using the asterisk key (*) on your keyboard's number
pad.

In books.xm1, place the pointer over the book repeating element.

Pressand hold theleft mouse button, and drag from book to the Book repeating element
in catalog.xml.
Stylus Studio draws aline as you drag.

Release the mouse button to create the link between book and Book.

Stylus Studio creates an xs1: for-each block that links the book and Book repeating
elements. (If you mouse over the block, xs1: for-each appearsin apop-up to indicate
the XSLT operation represented by thelink.)

If you prefer, you can render xs1: for-each asasimpleline. You might want to do this
to simplify the appearance of the mapper canvas. Select Tools > Options from the
menu, and then navigate to Module Settings > XSLT Editor > Mapper.

k| Unlilled...‘|
B hooks sml ~ () = El | T
Add Source Document match="" v Set Target Document
Al = books,xml catalog.xrml = |
=& books Catalog W&
? nama -gb___,—JJ Book k=
=i OOk ———— /—/OL[% Tite &
@ bookid suthors & -2
¥ pubdate Author o
i title Fublisher &
bt =& authors PubDate & Y,
3 > < >
2 <xsl:template match="/"> ~
4 < =
5 p <xsl:for-each select="hooks/hook"™= &
< : ' >
#5LT Source l:’\Mapper l({F’arams.fﬂlher }

Figure 31. xsl:for-each Block Displayed by the XSLT Mapper

Also notice that the complete xs1: for-each instruction has been added to the XSLT
source, which appearsin the XSLT source pane under the XSLT Mapper canvas. The
back-mapping pointer identifies the line of XSLT that was just added to styleshest.
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The template contains an xs1: for-each instruction that selects the book €lement,
which isthe node you selected in Step 2. The output from this template is an empty
Book element, which isthe node that was the target of the link. Stylus Studio created
the Catalog element automatically, to provide the document structure necessary to
support the Book element.

Tip By default, Stylus Studio creates an xs1:value-of instruction when you link one
element to another; Stylus Studio creates an xs1: for-each instruction if you link two
repeating elements. You can also create other types of instructions graphically,
including xs1:1if, xs1:choose, and xs1:apply-template.

5. Click the Params/Other tab.

In the Output method: field, display the drop-down list and select xml. (Even if the
setting for Output method isunspecified, Stylus Studio still generates XML.) Other
choices for the output method include text and HTML.

6. Click the Mapper tab.
The xs1:output instruction is added to the XSLT source:

<xs1:output method="xml"/>

7. Create another link from thetitle element to the Title el ement.

Note When you map, you always map from the source document to the destination
document.
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8. Click the XSLT Source tab to see the new instructionsin the template. (If you prefer,
you can simply adjust the splitter between the XSLT source pane and the XSLT
Mapper canvas.

#] Untitled...~ ‘
Sl e B |bocks.sml VO = B s =

match: /
|-<?x:ml version="1.0" 7> A
<xsl:stylesheet version="1.0" zmlns:xsl="http://wwmw. w3, org/1999/%8
<xsl:output method="xml"/ >
<xsl:template match="/">
< =
<xsl:for-each select="hooks/book">
< >
<Title=
<xsl:value-of select="title"/ />
10 </ Title>
11 - >
12 </xsl: for-each>
12 < = s

Mo~ m ot bW k=

o

< ' >
\XSLT Source AMapper th'arams.-"Dther }

Figure 32. Stylus Studio Builds XSLT Based on the Mapper Links

For each link you define, Stylus Studio addsinstructionsto the template that matches
theroot node. Inthe XSLT you have composed so far, the XSLT insertsaBook element
for each book element it finds in the source document. In the Book €lement, the
stylesheet selectsthe title elements. For each title dement, it insertsaTitle
eement. Finally, in each Tit1e element, the stylesheet extractsthe value of the current
context node, whichisthe title node.

Why does the stylesheet extract the value of the tit1e hodes but not the book nodes?
The title node has only atext node asits child. In this situation, the default is that
the XSLT Mapper insertsan xs1:value-of instruction.
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Saving the Stylesheet and Previewing the Result

0 To save the stylesheet and preview the result:

1.

2.

3.

Tip

Click save . Stylus Studio displaysthe Save As dialog box.
In the URL: field, type BooksToCatalog.xs1.

Click the save button.

This saves the stylesheet that Stylus Studio has generated. It does not matter that you
have not finished mapping all nodes.

In the upper left corner of the XSLT Mapper, click Preview Result B .

When you create a stylesheet using the XSLT Mapper, Stylus Studio automatically
creates a scenario for you, using the source document you specify as the source
document for the scenario. Scenarios and their value in the application devel opment
process are described earlier in this chapter. See “XSLT Scenarios’ on page 35.

Stylus Studio displays the result of processing books. xm1 with the stylesheet you
created in the XSLT Mapper in the Preview window.

Preview x
<7tuml version="1.0" 7= ~
- =Catalog=
- - <Book=
<Title=Java Web Services</Titlex
</Book=
B - zBook:=

«Title>Java Message Service</Title>
=/Book=

G

\ baoks.#ml [BaoksT aCatalog.=sl] ./

Figure 33. Result of Applying XSLT to books.xml

The result document uses the same schema as the target document, catalog.xml in
this example. Because not all nodes have been mapped yet, the result document does
not contain al nodes found in books .xm1 (author and subject nodes, for example).

You can confirm that the result document isincomplete by viewing books .xm1. Click
Open XML From Scenario D, which is at the top of the Mapper tab.
Stylus Studio displays the books.xm1 document in the Stylus Studio XML Editor.

Review the XML document, and then click the document tab for the
BooksToCatalog.xs! stylesheet to re-display the XSLT Editor.
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Deleting Links in Sample Files

00 To delete links:

1. Click the Mapper tab if it isnot already selected.

2. ClickthetitletoTitle link to select it.

Add Source Document match="/" Set Target Document
= biooks. xml catalog.xml = [
= & books Catalog W =
# narne ﬂﬁb__f Book =
- fa biook Title &
% bookid authors & @
@ pubdate Publisher &
3 title FubDate &
+-& authors shstract &
©-m subject Pages &

Figure 34. Click a Link to Select It

3. Pressthe Delete key, or
a. Right-click the selected link. This displays a shortcut menu.
b. Click Delete to delete the selected link.

Tip In addition to Delete, the shortcut menu displays the following options:

« Go To Source displaysthe line of XSLT code represented by the link you select
in the XML Editor.

o Carry Value allows you to create <xs1:value-of select="."/> statements. This
option is available for links representing xs1: for-each instructions only.

Defining Additional Processing in Sample Files

The stylesheet that the XSLT Mapper createsis not limited to the instructions that Stylus
Studio adds. You can edit the template as you would any template. Stylus Studio
automatically incorporates any changesyou maketo thetemplate and displaysthem inthe
Mapper tab, if it is appropriate to do so.

In addition, you can perform external processing by, for example, defining Javafunctions
and incorporating those functions in your XSLT stylesheet. Like standard supported
XSLT functions, user-defined Java functions can be created graphically in the XSLT
Mapper —just right click on the mapper canvas, select Java Functions from the shortcut
menu, and select any registered Java function you want to use.

See “Processing Source Nodes’ on page 522.
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Debugging Stylesheets — Getting Started

The Stylus Studio debugger alows you to follow XSLT processing and detect errorsin
your stylesheets. Stylus Studioincludes samplefilesthat you can experiment withto learn
how to use the debugger. To get you started, this section provides step-by-step instructions
for using the debugger with these samplefiles. You should perform the stepsin each topic
in the order of the topics.

For compl ete information about how to use the debugger, see“ Debugging Stylesheets’ on
page 539.

In addition, Stylus Studio allows you to observe and debug the interaction between your
Java code and XML data. See “Debugging Java Files’” on page 549.

This section includes the following topics:

o “Setting Up Stylus Studio to Debug Sample Files’ on page 49

o ‘“Inserting a Breakpoint in the Sample Stylesheet” on page 50

« “Gathering Debug Information About the Sample Files’ on page 52

To get started, you'll need to start Stylus Studio if you haven't already. See “ Starting
Stylus Studio” on page 8.

Setting Up Stylus Studio to Debug Sample Files

[0 To set up Stylus Studio to debug sample files:
1. Open the videosDebug.xs1 stylesheet, located in the examples\VideoCenter directory
where Stylus Studio was installed.

Alternative: If the Stylus Studio Project window is open, you can access this
stylesheet from the examples project.

Stylus Studio displays the videosDebug. xs1 stylesheet in the XSLT editor.

2. Inthe XSLT editor tool bar, click Preview Result B to run the predefined scenario
DebugVideosScenario. The source XML document is videos.xm1.

Stylus Studio® 2009 User Guide 49



Getting Started with Stylus Studio®

Stylus Studio applies the stylesheet and displays the results (a finished HTML page
that displays information about a single video) in the Preview window.

Stylus Studio - [videosDebug.xsl]

Frzd @EE 2@ B D & 7 4 dh i =B
§£| videosD e...|
oy — S

TR P | DebugvideosSoen.. v [ 3] Ts =

match: /
1 <?xml wversion="1.0" encoding="UTF-8"?> rs
2 <xsl:stylesheet version="1.0" xmlns:xsl="http:// wwmw.w3.org/1995/%
2
4 <xzl:param name="VideoName"/> 3
< >
\XSLT Source AMapper }\F'arams.-"Dther }

Processing complete [10 mz)

Preview X

Genre Format Price

A scientist drama  §iS $16.00

makes contact
. 8.99
with intelligent &z &2

Bl = »
\Debug\ﬁdeosScenano [ideosDebug.=sl] f’r

Ln 48 Col 1 UM
Figure 35. Preview of videosDebug.xsl

Inserting a Breakpoint in the Sample Stylesheet

Aswith any debugger, in the Stylus Studio X SLT debugger you insert a breakpoint where
you want to suspend processing and examine what is going on. You can do this using the
Debug menu or the debug set of toolsin the tool bar.

Tip Toolsinthetool bar arein grouped by function. These groups, likethe onefor debug tools
shown here, are dockable and can be moved anywhere you please.

& & "Mt ERER &
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0 To insert a breakpoint in the sample stylesheet:

1. Inthe XSLT Editor, click in line 202. Line numbers appear in the lower right corner
of the XSLT Editor window. Line 202 starts with

<xsT:template match="director">

Tip To display lines in Stylus Studio text editors, click Tool > Option > Editor General,
and select Show line numbers.

2. Inthe Stylus Studio tool bar, click Toggle Breakpoint & .
Alternative: If you prefer, select Debug > Toggle Breakpoint, or press F9.

Stylus Studio displaysared circleto theleft of thelinethat containsthe xs1: template
match="director" instruction. The XSLT processor will stop processing when it gets
to the instantiation of this template.

201

202. |<xsl :template match="director”sDirector: <xsl:value-of select="."/>
203

204 <xsl:template match="studio"=3tudio: <xsl:value-of select="parent::

£
\XSLT Source AMapper hParamsKDlher }

Figure 36. A Red Circle Shows Where Breakpoints Are Set

Do not do it, but to remove a breakpoint, you click in the line that has the breakpoint
and then click Toggle Breakpoint (or F9). The Toggle Breakpoint button and F9 key
operate astoggles.

3. PressF5 to start debugging.
Alternative: In the Stylus Studio tool bar, click Start Debugging .
The XSLT processor displaysayellow triangle to indicate where processing has been
suspended. Instead of thefinished HTML created when you first ran the scenario, the
Preview window displays just the HTML code because complete processing of the
XSLT was suspended before the finished HTML could be rendered.

201
2024y <xsl:template mateh="director"»Director: <xsl:value-of select="."/>
203

204 <xsl:template mateh="studio">Ztudio: <xsl:value-of select="parent::

<
\XSLT Source AMapper ;\F‘arams.-"Dther }'

Processing paused

Figure 37. Yellow Triangle Shows Where XSLT Processing Stopped

Do not do it, but to stop debugging, you can click Cancel in the lower right corner of
the X SLT editor window, or click Stop Debugging in the Stylus Studio tool bar.
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If you click Preview Result [ instead of pressing F5, Stylus Studio applies the
stylesheet without running the debugger. Pressing F5 always invokes the debugger. If
there are no breakpoints, and no errors, processing completes and Stylus Studio
displays the result in the Preview window.

Gathering Debug Information About the Sample Files

When XSLT processing is suspended at a breakpoint, Stylus Studio displaysthe
Variables, Call Stack, and Watch windows.

Tip

Warigbles

Mame

+- [Context]

Walue

$videoMame | Contact

Aresult[1]videos[1]/videa[9]/

X | | Call Stack b4
&j xzltemplate match="director”... in videosDebug.xzl (line 203)
@j wzltemplate match="videa"... in videozDebug.xsl (Ine 146]
@j szl template match="/".. in videosDebug. sl (line 80)

Watch X

Mame Walue

Figure 38. Variable, Call Stack, and Watch Windows Appear During Debugging

You can usetheinformation in thesewindowsto learn about potential and actual problems
encountered in your XSLT processing.

You can also control the display of these windows using the Debug menu, shown here, or
the tool bar.

=t Stop

[Debug| ¥5LT WSIWYG Sourcs
=| Start Debugging o)

i Breakpoints
M Toggle Breskpoint  F9
™ StepInto
¥ Step Over
{F Step Out

Watch Window

Ciri+B

F11

F10
Shift+F11
Shift+FS

@ Yarishle Window |

Call Stack Window
B output Window
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The Variables Window
The variables window displays alist of variables and their values when processing was

suspended.
Wariables b4
M ame W alue
$WideoM ame Contact
= [Context] Aresull][1]4videos[1)video[9]/director1]

<director: M/A

Figure 39. Variables Window

Asyou can see, the stylesheet defines the videoName parameter, which had no value when
processing was suspended. In addition, the Variables window shows you that when

processing was suspended, the processor was operating on thefirst di rector child element
of thefirst video child element of thefirst videos child element of thefirst result element.

The Call Stack Window

The Call Stack window displays a history of the steps the processor performed to reach
the point at which processing was suspended, including the names of the templates that
are currently instantiated, in most recent-to-oldest order.

Call Stack ®
@ #sltemplate match="director”... in videosDebug.xzl (line 203)

@ sl template match=""videa'"... in videozDebug.xzl (line 146]

@ ssltemplate match="/""... in videosDebug.xsl [ne 80)

Figure 40. Call Stack Window

In thisexample, the XSLT processor hasinstantiated the di rector template, which is part
of theinstantiation of the video template, which is part of theinstantiation of the template
that matches the root node.
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[0 To step out of debug Step out F, or press Shift+F11.

The processor compl etes the instantiation of the director template, which adds some
HTML to the Preview window. Theyellow triangle movesto show the new locationin the

XSLT source.
7 videosDe...‘ “ariables * | | Call Stack x
MHame Yalue Lad @ wzltemplate match=""videa"".. in videosDebug.xzl (line 207]
f DebugvideosScen... $ideoMame Contact @ wsltemplate match="/"... in videosDebug.xsl [line 80)
=l [Context] Aresult[1]/videos[1]/videol 9]
match: / e = <videor
144  <td width="153"> il (@id id1263000
145 <font gize="-Z"> <titles Contact
148 D <xsliapply-temp <gennex drama
147 <hr/= & <rating: PG
< i > <zurmany> | A scientist makes contact with i... wiatch X
\XSLT Source A TR }\ TP } :j::;ls) ?:;;ted astranorner Dr. Ellie Arr.. Marme Value
Processing paused Cancel <drectory | NAA v

Figure 41. Stepping Out Advances the Processor

Asyou can seein the Call Stack window, the processor is now two levels deep in the
template that matches the root node, instead of three levels deep as it was previoudly. The
value of the context node in the Variables window is /result[1]/videos[1]/video[9] (it
WaSs /result[1]/videos[1]/video[9]/di r'ector[l]).

The Watch Window

If your application contains alot of variables, the watch window allows you to focus on
the variables in which you are particularly interested.

“wiatch
M ame
= title

<title

alue
<titlex Contact< Aitley
Contact

Figure 42. Watch Window Lets You Track Variables

0O To enter a variable to watch:

1. Double-click the Name field.

2. Typethe name of the variable you want to watch and press Enter.
As processing continues, the Watch window displays the values of the variables you
specify.
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Ending Processing During a Debug Session

0 To end processing during a debug session:

1.

In the Preview window, click any line of text.

In the XSLT Source tab, Stylus Studio displays the blue back-mapping triangle that
indicates the line in the stylesheet that generated the output line you clicked.

In the lower right corner of the XSLT editor, click the Cancel button to end
processing.

] videosDe...|

f. DebugvideosScen... Pa I
match: / %
50 ’ <centers -
51 <img align="hottom" width="&00" sreo="ima
&2 <hr/=
53 <img align="hottom" width="&00" sro="ima
54 <hr/=
55 </aenter>
56 <center>
57 <table cell8pacing="0" width="600" horde w
< >
\XSLT Source AMapper th'arams.-"Dther }
Processing pauzed {  Cancel ]

Figure 43. Cancelling Processing During Debugging

Stylus Studio displays a notification message that indicates that processing has been
stopped and, optionally, allows you to jump to the location where processing ended.

Stylus Studio

9 ,  Processing has been cancelled
\-{/ URL: file:/ffc: fprogram files/stylus studiofexamples/VideoCenter videosDebug.xsl
Ling:146
Col: 9
Jump to location?

| ’ Mo I

Figure 44. You Can Jump to Where XSLT Processing Ended

Click Yes to jump to the location where processing ended.

The cursor appears on line 146 of the XSLT Source tab, which contains
<xsT:apply-templates select="director"/>.
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4. Inthe XSLT editor tool bar, click Open XML from Scenario ] .

Stylus Studio displaysthe XML source document that the stylesheet operateson. As
you can see, the first result element is the document element.

24| videos.xml |
Gwmut €| @
1 }<?xml version="1.0" encoding="UTF-§"?=< =
2 < =
2 < >
4 < >
5 < Faction< =
5 < Foomedy< >
T - >drama< =
= < =family< =
=} < =foreign< =
10 = Fhorror< =
14 < Fmusical< =
12 < =special< =
12 < >
14 < >
15 < G =
156 = FPE = v
< ¥
\Text ;{‘Tree I}‘Grid }‘Schema ;’[

Figure 45. Viewing the XML Source for an XSLT Transformation

This section demonstrated some of the major features of Stylus Studio’s debug tools,
including specialized windows for presenting call stack and variable information. For
complete information on using the XSLT debugger, see “Debugging Stylesheets’ on
page 539.

56 Stylus Studio® 2009 User Guide



Defining a DTD — Getting Started

Defining a DTD — Getting Started

This section provides a quick tour of the main features of the DTD Editor. It provides
instructions that you can follow to actually define asimple DTD. For complete
documentation about how to use the Stylus Studio DTD Editor, see “ Defining Document
Type Definitions” on page 651.

Process Overview

When you use Stylus Studio to define a DTD, the main steps you perform are:

1.

2
3.
4

Create anew DTD schemafile.
Define the e ements that contain the raw data.
Define the e ements that contain other elements.

In the container elements, specify the rules for the contained elements. That is,
specify whether a contained element is optional or required, whether there can be
more than one, and what order contained elements must bein.

This section provides step-by-step instructions for defining the bookstore.dtd schema
file. You should perform the steps in each topic in the order of the topics. This section
includes the following topics:

“Creating a Sample DTD” on page 57

“Defining Data Elementsin a Sample DTD” on page 58
“Defining the Container Element in a Sample DTD” on page 59
“Defining Structure Rulesin a Sample DTD” on page 59
“Examining the Tree of a Sample DTD” on page 61

To get started, you'll need to start Stylus Studio if you haven't already. See “ Starting
Stylus Studio” on page 8.

Creating a Sample DTD

O To create anew DTD schema file:

1.
2.

From the Stylus Studio menu bar, select File > New > DTD Schema.

Click save .

Stylus Studio displays the Save As dialog box.
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3. Navigate to the Stylus Studio examples directory.
4. Inthe URL: field, type bookstore.dtd.
5. Click the Save button.

Defining Data Elements in a Sample DTD

O

Inyour DTD, suppose you want a book element to be optional. Further, if abook €lement
is present, it must always have exactly one title element and it can have any number of
author elements. The title and author €elements contain only raw data.

To accomplish this, perform the following steps:

1. At the bottom of the DTD editor, click the Tree tab.

2. Click the DTD node at the top of the tree if it isnot already selected.

3. Click New Element Definition ¥® , which isthe top button in the tool bar on the | eft
side of the DTD editor window.

Stylus Studio displays an entry field for the element name.
4. Type title and press Enter.

Stylus Studio displays the new element, title, and the element’s propertiesin the
Properties window.

Stylus Studio - [bookstore.dtd *]

[# Eile Edit View Project Debug DTD SourceComtrol Tools Window Help

&= BB BN ?
Properties X huukslul...’|
Type Element
Name litle:
Content Empty & X <..g WS = ﬂv
Model =& DTD

.'E: title

¥
0|
i
&
Figure 46. New Element in the DTD Editor

5. Click New Modifier §j.

Stylus Studio displays an entry field for the element’s modifier.

6. Double-click Zero or More.

The new modifier is added to the element.
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7.
8.

Click Add #PCDATA “j.

To define the author element, repeat Step 2 through Step 7. In Step 4, type author
instead of title.

When you are done, the Stylus Studio desktop should resemble the following:

Properties X|| o ,‘
Type PCOATA T
¢ X & ws[f@] w2 ¢ £ &
= o DTD
=" title
= () Zero or More
# HPCDATR
= .'IZ: author
=-() Zero or More

Figure 47. Creating a DTD with Two Elements

Defining the Container Element in a Sample DTD

O To define the book element:

1.
2.
3.

Click the DTD node at the top of the tree.
Click New Element Definition =
Type book and press Enter.

Defining Structure Rules in a Sample DTD

0 To specify the rules for the structure of the book element:

1.

2.

3.

Click thebook nodeinthe DTD treeif it isnot already selected.
Click New Modifier %J.

In the drop-down list that appears, scroll down and double-click Sequence. This
indicates that the book element can include one or more elements.

Click New Reference to Element A" .

Type title in the entry field and press Enter.

Because the reference to the tit1e element appearsimmediately after the Sequence
modifier, the DTD editor assumesthat the default behavior iswhat iswanted. That is,
the book €lement must contain exactly one instance of the title element.
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O

6. Click the Ssequence modifier.
7. Click New Modifier {J.

8. Double-click One or More. (There can be one or more author €lements in each book
element.)

9. Click New Reference to Element A" .
10. Type author in the entry field and press Enter.

At this point, the definition of the book €lement is complete, and the tree diagram of
bookstore.dtd should ook like this:

Properties *x 0 =
Type FCOATA i Bookstor ‘
& X h WS Fo i
=& DTD
--®8 ricle
= () Zero or More
# #pCDATA
=-®% author
= () Zero or More

Figure 48. Early Steps of bookstore.dtd

However, you have not yet specified that you want the book €lement itself to be optional.
You need to do thisin the element that references the book element. For example, suppose
the bookstore element isthe root element in XML documents that use thisDTD. Further
suppose that you want the book €lement to be a child of the bookstore element.

You can define the bookstore element as follows:
1. Click the DTD node at the top of the tree.

2. Click New Element Definition % .

3. Typebookstore in the entry field and press Enter.
4. Click New Modifier %J.

o

In the drop-down list that Stylus Studio displays, double-click Optional.
6. Click New Reference to Element (21" .
7. Type book in the entry field and press Enter.

8. Click save
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Examining the Tree of a Sample DTD
Your DTD should now look like Figure 49.

Froperties x

Type Fef. To
Element
book.

Hame

bookstor.... |

g

x &
= & DTD
=" title
=] () Zero or More
# HPCDATL
=7, author

ws Food

=] () Zero or More
# HPCDATL
=] "E: hook
=] () Segquence
7 title
=] () One or More
E’}: author
=] "E: hookstore
=] () Optional

Figure 49. Finished bookstore.dtd

To complete this DTD, you could define magazine and newsTletter elements. In the
bookstore element definition, you could add references to the magazine and newsletter
elements. You could also expand the definition of the book €lement toincludeinformation
about the publisher, price, publication date, and number of pages.
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Defining an XML Schema Using the Diagram Tab —
Getting Started

This section provides a quick tour of the main features of the Diagram tab of the XML
Schema Editor and shows you how to define a simple XML Schema. For complete
documentation about how to usethe XML SchemaEditor, see* Creating an XML Schema
in Stylus Studio” on page 556.

Thetopicsin this section provide step-by-step instructions for defining the
bookstoreDiagram.xsd XML Schema document. You should perform the stepsin each
topic in the order of the topics.

This section includes the following topics:

“Introduction to the XML Schema Editor Diagram Tab” on page 63

“Editing Tools of the XML Schema Diagram Tab” on page 72

“Description of Sample XML Schema’ on page 77

“Defining a complexType in a Sample XML Schemain the Diagram View” on

page 77
“Defining Elements of the Sample complexType in the Diagram View” on page 85

To get started, you will need to start Stylus Studio if you have not already. See “ Starting
Stylus Studio” on page 8.

62

Stylus Studio® 2009 User Guide



Defining an XML Schema Using the Diagram Tab — Getting Started

Introduction to the XML Schema Editor Diagram Tab

The recommended way to define an XML Schemain Stylus Studio isto start with the
Diagram tab of the XML Schema Editor, which is shown in Figure 50.

€ Stylus Studio - [purchaseOrder._xsd *]

L File Edit Yiew Project Debug XMLSchema Diagram SourceControl Tools Window Help x
i i | [ e —|
T 1 Gl 1« & & = @
il r.-
Froperties x m pulchas...'|
Marne alue
1D = =] £ i M ] === |:
Hame comment T e
Type wad sting on browser ﬂ
Substitutio.... v
Default
Fized Value
Hillable False
Abstract Fal
Bloscz::i 5. e B I:"[EpurchaseOr(Ier T
Final Subs... .
nal suhs Type PurchaseOrderType XML Schema diagram pane
Properties
window
I |GE] Purchase OrderType B2 shipTo B5] USAddress & @= Iy
= Type | USAddress v Tyri
< | 3
it In Sync
= =
<xad: element name="purchaseOrder” type="PurchaseOrderType"/> ~
} <xad: element name="comment" type="xsd:string"/> Text
ext pane
<xsd: complexType name="FurchaseOrderType"> bl
< | =
\Diagram .({\ Tree hDocumentation ./
For Help, press F1 UM

Figure 50. Diagram Tab of the XML Schema Editor

When you use the Diagram tab to define an XML Schema, you can create XML Schema
nodes directly on the XML Schema diagram pane using tools on the tool bar or from the
XML Schema > Diagram and shortcut menus. You can also type in the text pane, which
appears under the Diagram tab. The text pane displays the XML Schema syntax Stylus
Studio creates for you as you work in the diagram pane.

Stylus Studio ensures that the XML Schemayou create isvalid. For example, any nodes
you define are created in the required order in the XML document that containsthe XML
Schema definition, regardless of the order in which you create them.
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The Diagram tab, shown in Figure 50, consists of three main areas:

“Diagram Pane” on page 64
o “Text Pane” on page 69
o “Definition Browser” on page 71

This section describes these areas and how to work with them.

Diagram Pane

Thediagram pane contains graphical representations of the elements, attributes, and other

nodes that make up your XML Schema.

v purchas...™ ‘

LR R w o[ g ek g

purchaseOrder. xsd

new query-JEv

E= r (F3purchaseOrder

Type PurchaseOrderType

@Purcllase()r(lerType =
=a

PurchaseOrder Type

[ [FEcomment
Type | xsd:string

MBshipTo

u EPurclmse()r(lerType =
= Type |USAddress

1t In Sync

\ Diagram ./\ Tree }\ Documentation l/

Figure 51. Schema Diagram Pane

Nodes

Each node displayed in the diagram pane is represented by its own symbol; toal tips,
which are displayed when you hover over anode in the diagram, identify the node'stype
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(element, attribute, sequence, and so on). The symbols used in the diagram are

summarized in Table 1.

Table 1. Symbols Used in the XML Schema Diagram

Symbol

Represents

schema (xsd: schema)

annotation (xsd:annotation)

documentation (xsd:documentation)

element (xsd:element)

attribute (xsd:attribute)

attributeGroup (xsd:attributeGroup)

simpleType (xsd:simpleType)

complexType (xsd: complexType)

EEREEREE

&

choice (xsd: choice)

)

sequence (xsd: sequence)

key (xsd:key)

key reference (xsd:keyref)

unique (xsd:unique)

group (xsd:group)

simpleContent (xsd:simpleContent)

complexContent (xsd: complexContent)

restriction (xsd: restriction)

extension (xsd:extension)

union (xsd:union)

D2 = 5= © & |==E

list (xsd:11st)
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Nodes can be expanded and coll apsed using the plusand minus symbols, respectively, that
appear on the right side of the node. In Figure 54 for example, the PurchaseOrderType
complexType has been expanded. The shipTo element has not.

Displaying Properties

To streamline the diagram, most nodes are displayed with their properties hidden by
default. Exceptionsinclude element, extension, and restriction nodes, for which the type
isdisplayed, as shown in the productName element in Figure 52.

o seieimg
Figure 52. Most Nodes Appear with Properties Hidden

You can change the display for classes of nodes (all elements, for example) using the
Diagram Properties dialog box, shown in Figure 53. (In addition, the Properties window
displays all the properties for any node you select.)

Schema Diagram Properties §|
Schema Detals | \wSDL Details

Categony/Property Inline wigibility in diagram ~
BEE Y crrooion L He
® gn Ay Hide

B =" Anpdttribute Hide

® P Applnfo Hide

[ = Abtrbute Hide

# @ AttibuteGroup Hide

& Ff ComplexContent Hide

2] Eﬂ ComplexT vpe Hide

# &% Documentation Hide
# B3 Element =
# T8 Ewtension -
® Lo Field Hide

® [H Group Hide

T, Key Hide

[ [Ah KeyRef Hide

el = Teas b
[ Hide a&ll ] [ Bestore Defaults ]

Figure 53. Schema Diagram Properties Dialog Box

For each node property, you can choose to

« Show the property

«  Show the property only if it is not empty
« Hidethe node

66

Stylus Studio® 2009 User Guide



Defining an XML Schema Using the Diagram Tab — Getting Started

If all of anode's properties have the same show/hide setting, that valueisdisplayed in the
Inline Visibility in Diagram field. If no valueisdisplayedintheinline Visibility in Diagram
field, it means that two or more properties have different show/hide settings.

0 To display the Diagram Properties dialog box:
o Select Diagram > Properties from the Stylus Studio menu
o Select Properties from the diagram shortcut menu
Tip You can also change schema diagram properties on the Diagram page of the Options

dialog box — Tools > Options > Module Settings > XML Schema Editor > Schema
Details.

0 To change node properties display:

1. Display the Diagram Properties dialog box, or the Schema Details page of the
Options dialog box.

2. Select the node whose properties display you want to change.

Tip To hide al properties, click the Hide All button. To restore defaults, click the Restore
Defaults button.

3. Click OK.

Background color
Background color is used as another visual cue for information about the XML Schema:

« Atan,orlight brown, color identifies global nodes—these are elements, types, and so
on, that are defined as children of the schema (xsd: schema). In Figure 54, the
purchaseOrder element is an example of a globally defined node.
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« Alight yellow background identifies local instances of globally defined types. In
Figure 54, the PurchaseOrderType complexTypeisalocal instance of that type.

4

IEE

I P18 purchaseOrder ‘@Pu[chase()[derType OEshipTo

Type PurchaseOrderType i Type USAddress
BiE billTo
Type USAddress

I:"[gReferem:e: comment @
Mgitems T‘ - Items i
Type ltems

Figure 54. Background Colors Show Global and Local Types

PurchaseOrderType

Displaying documentation

By default, text associated with documentation elements (xsd: documentation) is hidden.
You can expand documentation elements in the diagram by clicking the Show
Documenation ([£]) button, or by selecting Diagram > Show Documentation from the
Stylus Studio menu. When you do, the text associated with all documentation elements
defined in the XML Schema appears, as shown in Figure 55.

ww purchase. . ‘

e E ) r o J

==

purchaseCrder. xsd "

—

—
B @Purchase order schema for Example.com.
Copyright 2000 Example.com. Rll rights reserwved.
——\—u________________.———

D‘[gship'ro
Type Uilddress
H2hillTo
Type U3kiddress

Figure 55. Show Documentation with the Click of a Button

H

I D-[E purchaselrder PurchaseOrderType
Type PurchaseOrderType -

Moving around the diagram
There are several ways to move around the diagram pane:
« To move from node to node in the diagram, press the arrow keys.
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« You can use the scroll bars to explore the diagram; the zoom slider |ets you change
the magnification.

. Click Go to Definition ([#]) on the shortcut menu to display anew page that shows
just the type definition.

o Click Display Definition ( ) on the shortcut menu to jump to the placein the XML
Schema where the type is defined.

Text Pane

The text pane appears directly beneath the XML Schema diagram pane. It displays the
XML Schema code represented by the nodes you create in the diagram. The default font
is Courier New, but you can change it to whatever font you want by clicking the Change
Font button ([£) ).

Stylus Studio synchronizesthe diagram and text views of the XML Schema-—any changes
you make in the diagram are reflected in the text pane, and vice versa. Synchronization
information is displayed in the bar that separates the diagram and text panes. Current
statusis displayed on the right. When the two views are synchronized, Stylus Studio
displaysthisgraphic: [mmsmnc]. When Stylus Studio detects a change, such as achange to
the text, it displays a message and changes the status graphic, as shown in Figure 56.

bt pulchas..."
GmAYE & £ o ! )

purchaseOrder. xsd =
|—D'[Ezip =
Type  xsd decimal

BEname

Type | xsdstring

UBstreet ‘

Twne xsd:string

w
<

¥
Text has been modified. .. # Synchronizing
=

</xad: sequence> -~
<xsd: sequence>
<xsd: element name="name" type="xsd: string"/>
<xsd: element name="street

Figure 56. Synchronization Status is Monitored and Displayed
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Stylus Studio also flagsany XML Schemaerrorsin thetext pane—linesthat contain errors
areidentified with ared dot, and the type and location of the error isdisplayed in the status
area at the top of the text pane, as shown here:

@L—JE value (2,23)

1 <?xml version=T1.077=>
2@ saulns:xsd=http://www. w3, org/2001/EMLEchema ">

<xsd:annotations
<x=sd:documentation>
Purchase order schema for Example.com.
Copyright 2000 Example.com. A11 rights reserved.
</x=d:documentation>
</x=d: annotation>

Figure 57. Text Pane Highlights XML Schema Errors

LR R R 6 R 1

When you click the error message, Stylus Studio jumpsto that part of the XML Schema
containing the error. When you correct one error, information about the next error
detected by Stylus Studio (if any) is displayed in the status area.

You can use the splitter to resize the text paneto view more or less text, or you can hide
it entirely using the controls on the splitter’sright side.

H&[Estreet ‘

Twne xsd:string

Bt In Sync

="xsd:string"/>

Figure 58. Splitter Controls Change Size of Text and Diagram Panes

Stylus Studio supports back-mapping between the text pane and the XML Schema
diagram pane —if you click a node in the diagram, Stylus Studio scrolls the text pane to
display the line of XML Schemathat defines the node you clicked. A bluetriangleis
displayed to the left of the exact line of code.
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Definition Browser

The definition browser is a drop-down list that displays all the child nodes of the schema
node. It islocated at the top of the Diagram tab.

Estylus Studio - [purchaseOrder.xsd *] M=
b

we File Edit Miew Project Debug XMLSchema SourceControl Tools Window Help

sl D& % & 0

= purchase._. |

= | EE | 0O e EE X 7

(3] Items

E_T; PurichazelrderType
[3 UStddress

D‘[S comment

02 internationalPrice
02 purchaseOider

W SKU v

I
L type : USAC
B

< | ¥

Figure 59. Definition Browser

When you select anode from the definition browser, Stylus Studio displaysanew pagein
the XML Schema diagram pane that shows the definition of the node you select. In
addition, the definition browser displays information about that node.

o purchas. ™ |

Gt -

omrment, defined in purchaseOrder.xsd

M8 comment
Type  xsdistring

Figure 60. Information About the Selected Node

To return to the page you were viewing previously, press the back ([£=]) button.

Note When you display anode using the definition browser, the focus of the text pane does not
change. Clicking the node jumps you to that part of the XML Schemawhere the nodeis
defined.
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Editing Tools of the XML Schema Diagram Tab

Many of the operations you perform in the Diagram tab can be performed in anumber of
ways. This section briefly describes menu and tool bar use, and introduces additional
features for defining XML Schema.

This section covers the following topics:

« “Menusand Tool Bars’ on page 72

« “In-place Editing” on page 73

« “Drag-and-Drop” on page 73

o “QuickEdit” on page 74

. “Refactoring” on page 75

Menus and Tool Bars

The complete set of available operations is defined by the menu system. The tool bar
provides a subset of frequently performed operations. The top-level menu (XMLSchema
> Diagram), the shortcut menus, and the tool bar are context sensitive — only operations
that are permitted given the current context are available. For example, if you want to add
an element to a sequence, you can

o Select XML Schema > Diagram > Add > Element from the main menu

« Select Add > Element from the sequence shortcut menu

o Click the Add button on the tool bar and select Element from the drop-down list
it displays

Each of these actions lets you add a new node, in this case, an element, to your XML
Schema definition.

72 Stylus Studio® 2009 User Guide



Defining an XML Schema Using the Diagram Tab — Getting Started

In-place Editing

In-place editing allows you to change node names and properties directly in the diagram.
For example, say you want to change the vaue of the Mixed property of the
PurchaseOrderType complexType. Just double-click the property. Stylus Studio opens the
property for editing, as shown in Figure 61.

[35] PurchaseOrderType

D

Mame PurchaseCrderType
Abstract True

Mined

Blocked Substitutions

Final Substitutions
-

True

Figure 61. In-Place Editing

Similarly, if you double-click a node name, Stylus Studio places the property in edit
mode, allowing you to type a new name.

Tip Todisplay all of anode's propertiesin the diagram, see “Displaying Properties’ on
page 66.

Drag-and-Drop

An alternative to using the menu and the tool bar isto use drag-and-drop, which letsyou
add an existing node to another node' s definition. For example, say you wanted to add an
existing element t0 a sequence. You can do this by dragging the element icon to the
sequence icon, as shown in Figure 62.

-@

Figure 62. Using Drag-and-Drop to Define a Node

Use drag-and-drop any time you want to define a node using a node already defined in
your XML Schema.

Tip When you drag and drop, you remove the element from its current context. If you want
to make a copy an element, press and hold the CTRL key when you perform the drag
operation.

Typical targets of drag-and-drop operations include the following nodes

Stylus Studio® 2009 User Guide 73



Getting Started with Stylus Studio®

Tip

e schema

e sequence
e choice

e all

. Tist

e annotation
e restriction
e union

Typical sources for drag-and-drop operations include the following nodes
e simpleType

e element

e annotation

Any node you drag to the schema node is created as a child of the schema node.

QuickEdit

QuickEditisafeature of the Diagram tab that streamlines common editing operations. For
example, you can use QuickEdit to

o Change a sequence to achoice Or toanall
o Specify arestriction for asimpleType
o Create sequence, choice, any, and a11 element definitions

For example, the following structure was created by selecting QuickEdit > Add Elements
Choice from the comp1exType’'s shortcut menu.

[FEziems b G5B
Figure 63. QuickEdit Creates Complex Definitions With a Click

QuickEdit appears on the top-level and shortcut menus in those contextsin which it is
available, and it is also available on the tool bar by pressing the QuickEdit button [/].
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Refactoring

Refactoring is a process that allows you to copy globally defined nodes from one XML
Schema and paste them in anew XML Schema. The difference between refactoring and
asimple copy isthat refactoring includes both the node you select and all its
dependencies. Consider the following example: here is how the purchaseOrder node
appearswhen it is copied from purchaseOrder.xsd and pasted into anew XML Schema

document;

i copyPlJo...| o
AL AN o 3
copyPConly. xsd

= B2 purchaseOrder é‘a

Type PurchaseOrderType

| |1

1t In Sync

<?xml wersion="1.0"7%>
<xsd: schema smlns: xsd="http: //www. w3, org/2001/EMLIchemna ">
} <xad:element name="purchaseQrder-0" type="PurchaseOrderType”/>

</xad: schema>

\ Diagram A Tree I}\ Documentation rn'r

Figure 64. Simple Copy/Paste of a Node
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Asyou can see, the copy action copies only the selected node to the clipboard. When the
same node is copied using refactoring and pasted into another XML Schema document,
the node, and all its dependencies copied as well.

xin lefaclolP...| xin
Gomatay g g | oe %= e O ) alX|D (4
refactorP O xsd =|
L ~
HSpurchaseOrder E5jPurchaseOrderType
Type PurchaseOrderType .
= arderDate Type : wsd:date

BZhillTo

Type USAddress

PurchaseOrderType O

< ¥
B In Sync
= =
<xsd:restriction base="xsd:string"> ~
<xsd:pattern wvalue="\d{3}-[a-2]{2} "/~
</xsd:restriction®
meeesimpleType>
’ <xzd:element name="purchaseorder” type="PurchaseCrderType"/>
</ x=d: schema> b
< ¥

Diiagram ATree }‘Documentation /{

Figure 65. Refactoring Copy/Paste of a Node

Not all of thediagram or text are displayed in thisillustration, but it isclear that more than
just the purchase0rder node was copied to the clipboard. For example, the
purchaseOrder’'Stype, PurchaseOrderType complexType has been copied, aswell as
PurchaseOrderType's € ement and sequence nodes, such as shipTo, bi11To, and items.

If you wereto scroll up either the text pane or the diagram pane, you would also see, for
example, the complete definitions for other global complexTypes such as sku and
USAddress.

0 To refactor a node:
1. Right-click the node you want to refactor.
2. Select Refactoring > Copy from the node's shortcut menu.

Note If the node is not globally defined, refactoring is not available.

The node and all its dependencies are copied to the clipboard.

76 Stylus Studio® 2009 User Guide



Defining an XML Schema Using the Diagram Tab — Getting Started

3.

To paste the node in the target XML Schema document, select Refactoring > Paste
from the shortcut menu.

Description of Sample XML Schema

Suppose you want to define an XML Schemathat defines book, magazine, and newsletter
elements. The type of each of these elementsis PubTlicationType. The XML Schema
definesthe PublicationType complexType. An element that isaPublicationType hasthe
following description:

The genre attribute specifiesthe style of the publication. That is, whether it isabook,
magazine, or newsletter.

Thereisalways exactly one title element.

The subtitle element is optional.

There must be at least one author element and there can be more. Each author
€lement contains one first-name element and one 1ast-name element.

Of the following three elements, exactly one must always be present:
O  ISBNnumber

O  PUBnumber

0O LOCnumber

The elements must be in the order specified in thislist.

The following topicsin this section describe how to define this XML Schema using the
Diagram tab of the XML Schema Editor.

Defining a complexType in a Sample XML Schema in the Diagram

View

The steps for defining the Pub14cationType complexType described in “ Description of
Sample XML Schema’ on page 77 are presented in the following topics:

“Defining the Name of a Sample complexType in the Diagram View” on page 78
“Adding an Attribute to a Sample complexType in the Diagram View” on page 79
“Adding Elementsto a Sample complexType in the Diagram View” on page 80
“Adding Optional Elements to a Sample complexType in the Diagram View” on
page 81

“Adding an Element That Contains Subel ements to a complexType in the Diagram
View” on page 81
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1.

3.

“Choosing the Element to Include in a Sample complexType in the Diagram View”

on page 83

Defining the Name of a Sample complexType in the Diagram View

0 To define acomplexType in a sample XML Schema:

From the Stylus Studio menu bar, select File > New > XML Schema.

Stylus Studio displays the XML Schema Editor. Maximize the XML Schema Editor
window. If the Project window is visible, you can closeit.

At the bottom of the XML Schema editor, click the Diagram tab.

Stylus Studio displays the Diagram view for the new schema.

Stylus Studio - [Untitled1.xsd *] EX
s File Edit Wiew Project Debug ¥MLSchema Diagram SourceConfrol Tools Window Help x
| Al e e
2 o mRAR - 0
Ag e
ﬁ (1 b= ool
A €
Properties || '3 Unlilled,,,’|
Mame Walue
1D Cpomga R g f. o 2 4w
Default Atti._. g & &
Default Ele.... oa R —
Default Bloc...
Default Fina... ﬂ
Target Mam...
Yersion
Mamespace wad
it In Sync
= =
<%l wersion="1.0"7>
Pp<xsd: schema saulns: xsd="http://wwwr. w3, org/Z001/EMLEchena "
</xad: schema>
< >
\ Diagram A Tree .h Documentation l/

For Help, press F1 UM

Figure 66. The XMLSchema Editor Diagram Tab

Right-click the schema node in the XML Schema diagram pane and select Add >
ComplexType from the shortcut menu.
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Alternatives. Thisactionisalso available from the XMLSchema > Grid Editing menu.

Stylus Studio displays a representation for the new node in the diagram. The
complexType properties appear in the Properties window. The new complexType has
adefault name of ComplexType-0.

alobetic X L Unitled...”|

Mame alue

D asm|o|e s § 2
Mame ComplexType-0

Abstract Falze Untitledl.xsd

Mized False

Blocked

Substitutions CEmp eI gEE=

Final

Substitutions

Figure 67. New complexType

4. TypePublicationType in the Name property in the Properties window and press
Enter.

Stylus Studio updates the diagram and the XML Schemain the text pane.

5. Click save .

6. Inthe Save As dialog box, in the URL field, type bookstoreDiagram.xsd, and click
Save. You can save it in the examples directory of the Stylus Studio installation
directory or in adirectory of your choice.

Adding an Attribute to a Sample complexType in the Diagram View

[0 To add the genre attribute to the PubTlicationType complexType:
1. Right-click the publicationType node.

2. Inthe shortcut menu that appears, select Add > Attribute.
Stylus Studio displays a node for the new attribute (untitled).

E PublicationType
’
—untitled

Figure 68. Adding an Attribute in the Diagram Tab

3. IntheProperties window, type genre asthe name of the new attribute and press Enter.

4. Inthe Properties window, click the Type field.
Stylus Studio displays a drop-down list of built-in types.
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Tip

5.

6.

Scroll down to xsd:string and click it, or type xsd: string and press Enter.
The diagram should now look like the one shown in Figure 69.

Figure 69. The Finished genre Attribute

E PublicationType
o

I = genre type @ xsdistring

You can toggle the display of attributes by clicking the small triangle at the bottom of
the complexType node.

Click save 4.

Adding Elements to a Sample complexType in the Diagram View

The elements belonging to this complexType must occur in a specific order. Before
defining the first element, you need to create a sequence node to define this requirement
in the XML Schema.

O

To add the title element to the PublicationType complexType:

1.
2.

8.

Right-click the Pub1icationType node.

In the shortcut menu that appears, select Add > Sequence.

The sequence node is added to bookstoreDiagram.xsd. The sequence modifier
indicates that if an instance document contains the sequence node’s child elements
(the elements you will add next), they must be in the order in which they are defined.

Type title and press Enter.
[5+]
Right-click the sequence node .

In the shortcut menu that appears, select Add > Element.
A child element is added to the Pub1icationType node.

In the Properties window, click the Name field and enter title.

In the Properties window, click the Type field.
Stylus Studio displays a drop-down list of built-in types.

Scroll down to xsd:string and click it, or type xsd: string and press Enter.

According to the XML Schema requirements described earlier, the title element can
occur only once. By default, the default value for theMin Occur. (minimum occurrences)
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and Max Occur. (Maximum occurrences) propertiesis 1. You want exactly oneinstance of
the title element in PublicationType, SO yOu can accept these defaults.

Adding Optional Elements to a Sample complexType in the Diagram View

[0 To add the optional subtitle element to the PublicationType complexType:
. . [+
1. Right-click the sequence node .

2. Inthe shortcut menu that appears, select Add > Element.

Below the title element, Stylus Studio displays arectangle for the new element
definition.

3. Renamethe new element subtitle.
4. Givethe new element adatatype of xsd:string.

5. Give the new element a minimum occurrences value of 0.
You can accept the default of 1 for the Max Occur. property.

6. Click Save .

At this point, the XML Schema diagram should look like Figure 70:

= EPu.blic:atiDnType = @: I:"[Et:,it.le
. type : xad:string
I = genre type : xsdistring
D'[gsubr.itle

type @ xadistring

Figure 70. PublicationType complexType

Adding an Element That Contains Subelements to a complexType in the
Diagram View

The sample schema requirements (see “ Description of Sample XML Schema” on

page 77) state that the PublicationType complexType must include at least one author
element. Further, an author element must include a first-name e ement and a 1ast-name
element.

Each element that can contain one or more subelementsis acomplexType. Consequently,
to add the author element to the Pub11cationType complexType, you must first define the
AuthorType complexType. You can then add an element that is of AuthorType to the
PublicationType complexType.
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[0 To define the AuthorType complexType:

1.

Right-click the schema node in the XML Schema diagram pane and select Add >
Complex Type from the shortcut menu.

Alternatives. Thisactionisalso availablefrom the XMLSchema > Grid Editing menu.

Stylus Studio displays a representation for the new node in the diagram. The
complexType properties appear in the Properties window.

Type AuthorType in the Name property in the Properties window and press Enter.
Stylus Studio updates the diagram and the XML Schemain the text pane.

Right-click the AuthorType node in the diagram.

In the shortcut menu that appears, select Add > Sequence.
Stylus Studio displays the sequence node .

Right-click the sequence node.

In the shortcut menu that appears, select Add > Element.

Type first-name in the Name property in the Properties window and press Enter.
Change the Type property to xsd:string and press Enter.

Repeat Step 5 through Step 8 to add a new element to the sequence, using 1ast-name
as the name of the new element.

[0 Now you can add the author element to the PublicationType complexType:

1.

2.

Right-click the sequence node belonging to the Pub1icationType node.

In the shortcut menu that appears, select Add > Element.

Stylus Studio displays a representation for the new node in the diagram. The
complexType properties appear in the Properties window.

Type author in the Name property in the Properties window and press Enter.
Stylus Studio updates the diagram and the XML Schemain the text pane.

Click the Type field in the Properties window. Stylus Studio displays a drop-down

list of built-in types plus any types you have defined, such as the AuthorType you
defined in the previous procedure.
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5. Select AuthorType from the drop-down list.

Tip A plus sign appears on the right side of the author element. You can click the plus
sign to display the definition of the AuthorType complexType, which was just added
to the author €lement.

6. Click the Max Occur. field.
7. Inthe drop-down list that appears, click unbounded.

Tip When you give an element an unbounded maximum number of occurrences, Stylus
Studio renders the node using two outlines, to indicate that multiple occurrences of
this element are allowed.

8. Click save .

At this point, the XML Schema diagram should look like Figure 71:

type @ x=sd:string

D'[g subtitle
type : ®sd:string

mgauthor

Type : AuthorType%

D‘[gfirst,—name
type @ x=sd:string

D-[g last-name
type @ xsd:string

Figure 71. author Element with AuthorType complexType

Choosing the Element to Include in a Sample complexType in the
Diagram View

In the sample XML Schema, you want PublicationType €lementsto contain an
ISBNnumber, PUBnumber, Or LOCnumber €lement.

0 To specify this:
1. Right-click the sequence node belonging to the PublicationType node.

2. Inthe shortcut menu that appears, select Add > Sqeuence.

Stylus Studio displays arepresentation for the new sequence node in the diagram.
Sequence properties appear in the Properties window.
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We added the sequence node in error — the specification requires that this node be a
choice node. The QuickEdit feature makes it easy to correct errors such asthis.

3. Right-click the new sequence node. In the shortcut menu that appears, select
QuickEdit > Switch to Choice.

Stylus Studio changes the sequence node to the choice node ().
4. Right-click the new choice node.
5. Inthe shortcut menu that appears, select Add > Element.
6. Inthe Properties window, change the Name to ISBNnumber and press Enter.
7. Inthe Properties window, change the Type xsd:int and press Enter.

8. Repeat Step 4 through Step 7 twice: once to add the puBnumber €lement, and once to
add the LoCnumber element.

9. Click save .
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Thedefinition of the PubTicationType complexTypeisnow complete and should look like

Figure 72:

s bookstor. .. |

el a X ]

= ‘PubllcationType I:"[gt:,it,le
Y type @ xadistring
I = genre type : xsd:string I
_D'[gsubcicle
type @ xad:string

D'[Eaut,hor
type @ AuthorType

AuthorType = D‘[Efirs:—name

type @ xsdistring

ﬁglast—name
type : xsdistring

@ U8 ISENnunber

type : xsd:inc

D‘[ELOCnumber
type @ x=sd:int

file:///c:/Program Files/3tvylus Studio XML Professional Edition/examples/bookstoreliagram.xsd

ﬁgfirst—nsme
type @ Hodistring

@ AuthorType 5 @

D-[g last-narme
type @ x=sd:string

AuthorType, used

Figure 72. PublicationType complexType Fully Defined

Defining Elements of the Sample complexType in the Diagram

View

In the final step of defining bookstoreDiagram.xsd, you define elements that are of the
PublicationType complexTypes you defined earlier — book, magazine, and newsletter

e ements.

[0 To define the book, magazine, and newsletter elements in the sample XML Schema:

1. Right-click the schema node in the diagram.

2. Inthe shortcut menu that appears, select Add > Element.

Stylus Studio displays anode for the new element inthe XML Schemadiagram pane.
The properties for the new element appear in the Properties window.
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3. Type book as the name of the new element and press Enter.

4. Inthe Properties window, click the Data Type field. Stylus Studio displays adrop-
down list of built-in types plus any types you have defined.

5. Click PublicationType.

6. Repeat Step 1 through Step 5 twice: once to add the magazine element, and once to
add the newsTletter element.

7. Click save [H&.
The bookstoreDiagram.xsd document is now complete.

8. Select XMLSchema > Validate Document from the menu to validatethe XML Schema
document you created.

The validation message appears in the Output window, as shown in Figure 73.

Stylus Studio - [bookstoreDiagram.xsd *]

sn File Edit Wiew Project Debug XMLSchema SourceControl Tools Window Help X
a5 ") T e P e R e e
s+l B0 5N 560 #
Properties ) L hookslol...’|
Marne Walue
1D | B == 8 F a X T
Hame hemsletter
Type PublicationTwpe |£ile:///c:/Program Files/S3tylus Studio XML Professional Edltian.f’ﬂ
Substitutio.. &
Millable Falze E‘[E magazine
Abstract Falge . : Publ i
ype : icationType
Blocked Su...
Final Substi__.
- v
3 In Sync
-
<xad:element name="book" type="PublicationType"/> A
<xsd:element name="magazine" type="PublicationType" _
' <xsd:element name="newsletter” type="PublicationTyE
< | >
\Tree l}‘D\agram ADocumentationl/
Output X
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The ZEML document bookstoreliagram.xsd is wvalid
For Help, press F1 UM

Figure 73. Validation of bookstoreDiagram.xsd
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Opening Files in Stylus Studio

This section describes the types of files Stylus Studio recognizes, how to add new file

types to Stylus Studio, and how to open files using the Stylus Studio File Explorer and
other methods. This section covers the following topics.

o “Types of Files Recognized by Stylus Studio” on page 87
« “Using the File Explorer” on page 89

« “Dragging and Dropping Filesin the Stylus Studio” on page 92

o “Other Ways to Open Filesin Stylus Studio” on page 93
« “Adding File Typesto Stylus Studio” on page 94

Tip You can set an option so that when you open Stylus Studio, Stylus Studio automatically

opens any files that were open the last time you closed Stylus Studio. See “Options -

Application Settings” on page 1268.

Types of Files Recognized by Stylus Studio

Stylus Studio recognizes over ten types of files by default. Each file is associated with a
Stylus Studio module, or editor, appropriate for its type, as shown in the following table.

Table 2. File Extensions and Associated Modules

File Name Extension

Stylus Studio Module

.conv

Custom XML Conversion Editor

Ldff XML Diff Viewer

.dtd DTD Schema Editor
.java Java Debugger
.pipeline XML Pipline

.prij Project framework
.report XML Publisher

.sef EDI to XML Conversion

.WSCC, .WSC

Web Service Call Composer

.wsdl

Web Service Description Language
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Table 2. File Extensions and Associated Modules

File Name Extension Stylus Studio Module
.xm1 XML Editor

.xquery XQuery Editor

.xsd XML Schema Editor
.xs1, .xslt XSLT Stylesheet Editor

You can add your own file typesto thislist, specify the module you want them opened in,
and, optionally, specify Stylus Studio as the default application for viewing and editing
files of that type. See “Adding File Types to Stylus Studio” on page 94.

Opening Unknown File Types

When you try to open afile of atypethat isnot recognized by Stylus Studio, Stylus Studio
displays the Choose Module for dialog box, which allows you to specify the module or
editor you want to use to open thefile.

Choose Module for ".txt" BI

Choose a module to open the
unknown file extension

.
wieb Service Cal ~

L Dift

ML Schema

HQuery File

®ELT: Mapper

HSLT: Teut Editar

HELT: WS G b

] Always uze this module for this file tipe

Figure 74. Choose Module Dialog Box

When you respond to this dialog box, you can optionally indicate whether you want all
files of that type to be associated with the Stylus Studio module you select in the future.
File types you associate with a Stylus Studio module are added to the File Types page of
the Options dialog box. You can remove or change the module association at any time.
See “Adding File Typesto Stylus Studio” on page 94 for more information.

Opening Files Stored on Third-Party File Systems

Stylus Studio provides access XML documents stored on third-party file systems like
Raining Data™ TigerLogi c® XML DataM anagement Server (TigerLogic XDMS).
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See “Integrating with Third-Party File Systems” on page 1113 for more information.

Modifications to Open Files

If afilethat is openin Stylus Studio is modified (changed, and saved) outside Stylus
Studio, Stylus Studio alerts you that the file has been changed and gives you the chance
to reload it.

Using the File Explorer

The Stylus Studio File Explorer is a dockable window that provides easy access to any
file system accessible from the computer on which you are running Stylus Studio. You
can use the File Explorer to quickly add files to Stylus Studio and open filesin Stylus
Studio, as well as to perform typical file management tasks (like renaming and deleting
files, for example).

Stylus Studio - [sampleYideo.xsl]

wr File Edit Wiew Project Debug XSLT SourceControl Tools Window Help x
sl P& 0 & = b=

wir sample¥i... | File Explorer

B ShF M [videoScenaiol v 31 B [%a] [F]
=

My Computer
WebDaY
¥ g
F

ecure WWebDa
TP

Web Service
Relational DB
#ML Converters
Berkeley DB *ML

<?xml version="1.0" encoding=Tutf-877> A
<l-- This stylesheet 13 the result of p=

[N T |I|
L L
&
E

=

RN
vt lidinisea

<xsl:styleshest version="1.0" zmlns:xsl

<xsl:output method="html"™ encoding="UTF
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Figure 75. Stylus Studio File Explorer

By default, the File Explorer window appears on the right side of the Stylus Studio
window, but you can drag it anywhere on your desktop. You can close/open the File
Explorer window from the View menu.

Stylus Studio® 2009 User Guide 89



Getting Started with Stylus Studio®

How to Use the File Explorer to Open Files

There are several ways to open files using the File Explorer:
« Double-click thefile
« Right-click thefile and select Open or Open With from the shortcut menu

Tip Open With allows you to select the module you want to use to open the file.

« Dragand drop thefile. See “Dragging and Dropping Files in the Stylus Studio” on
page 92.

When you open afile by double-clicking or using the Open shortcut menu, Stylus Studio
opens the file in the modul e associated with the file type (the XML Editor for .xm1 files,
for example). If thefiletypeisnot currently registered with Stylus Studio, you can register
the file at thistime using the Choose Module for dialog box. See “Types of Files
Recognized by Stylus Studio” on page 87 for more information about file type/module
associationsin Stylus Studio.

Other Features of the File Explorer

Thetool bar in the File Explorer window has several features that can help you navigate
the file systems associated with your computer and work with individual documents.

File Explarer x
=% & v bt [#

Figure 76. File Explorer Tool Bar
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These features are summarized in the following table.

Table 3. File Explorer Tools

Tool

Description

(] New Folder

Creates anew folder asachild of the folder with current focus. The
default folder nameis New Folder.

Read Document
Structure

Displays the structure of XML documentsin tree form. You can
drag exposed nodes onto the document tab area to open the
document associated with that node. If you drag a node into an
existing XQuery or XSLT document, Stylus Studio creates the
document function with the X Path expression for that node. For
example, if you drag the tit1e element from books.xm1 into an
XQuery document, Stylus Studio builds the following function:

doc("file:///c:/Program Files/Stylus Studio 2009 XML
Enterprise Suite/examples/simpleMappings/
books.xm1") /books/book/title

Refresh

Refreshes the File Explorer window.

Reset Filters

Resets the File Explorer filter from its current content to the
wildcard (*.*).

(=] Stylus File Types

Changesthe File Explorer filter to display only file types associated
with Stylus Studio: .xml, .xsd, .dtd, .java, .conv, and others.

Working with the File Explorer Filter

By default, the File Explorer window uses awildcard filter to display all file types (*.*).

File Explarer

i

X

Figure 77. File Explorer Filter

You can

« Typeyour ownfilter (*.txt, for example). If you want to use multiplefilters, separate
them with asemicolon (*.txt; *.htm1, for example).

« Usethe Stylus File Types [£] button to change the filter to display only file types
associated with Stylus Studio (.xm1, .xsd, .dtd, .java, .conv, and others)

Stylus Studio remembers the filters you create and adds them to the drop-down list.
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Dragging and Dropping Files in the Stylus Studio

You can open afilein Stylus Studio by dragging the file from the File Explorer (or other
file system browsers, like Windows Explorer) and dropping it inside Stylus Studio. How
Stylus Studio behaves depends on where you drop the file, as summarized in Table 4.

Table 4. How Stylus Studio Handles Dragged-and-Dropped Files

If You Drop the File Here

Stylus Studio Does This

On the document editor area
(when no documents are open)

Opens the document editor associated with the type of file
you selected. See “ Types of Files Recognized by Stylus
Studio” on page 87. If the file type is not currently
registered with Stylus Studio, you can register thefile at
thistime using the Choose Module for dialog box. See
“Opening Unknown File Types’ on page 88.

On the document editor tab area

Opens the document editor associated with the type of file
you selected. See “ Types of Files Recognized by Stylus
Studio” on page 87. If the file type is not currently
registered with Stylus Studio, you can register thefile at
thistime using the Choose Module for dialog box. See
“Opening Unknown File Types’ on page 88.

In an active document

Addsthefile's URL to the end of the document.

On another filein the File
Explorer

Performs the operation associated with the target file and
opens the resulting document in its own editor. For
example, you might usethis operation to convert atext file
to XML by dropping the . txt file on aconverter file
(.conv).

Inaproject in the Project
window

Addsthefileto the project. If thefile typeisnot currently
registered with Stylus Studio, you can register thefile at
this time using the Choose Module for dialog box. See
“Opening Unknown File Types’ on page 88.
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Other Ways to Open Files in Stylus Studio

In addition to the File Explorer and drag-and-drop, you can also open filesin Stylus
Studio from the following places:

« TheOpen dialog box (displayed when you select File > Open from the menu, for
example). By default, Stylus Studio opens the file in the editor associated with files
of thetype you select (see“ Types of Files Recognized by Stylus Studio” on page 87).
If you want, you can choose a different editor — you might want to open an XSLT
stylesheet inthe XML Editor, for example—when opening filesfrom the Open dialog
box.

To specify a different module, click the down arrow to the right of the Open button
and select the module you want to use from the drop-down list as shown in Figure 78.

=

Open EJE|

I\.ﬂ Look i | [ quates
< your-quotes. kml

E your-quates. xsl

4y Camputer

D

‘webDaY

TigerLogic XDMS AL

Files of bype: | Stylus Studio Documerts [* java;”.conv;” pipeline, + Custam #ML Corversion

Java

Project Files [] Open using $ML Converter weh Service Call Composer

%ML Editar k

%ML Pipeline
#ML Publisher
KOuery

®SLT Editor

Figure 78. Choose the Module to Use When Opening a File

« Project window — either double-click thefile, or select Open or Open With from the
file's shortcut menu.

« Other file system browsers (like Windows Explorer, for example) —for files
recognized by Stylus Studio, just double-click the file. See “ Opening Unknown File
Types’ on page 88.

Stylus Studio® 2009 User Guide 93



Getting Started with Stylus Studio®

Adding File Types to Stylus Studio

You use the procedure described in this section to associate afile type (. txt, for example)
with a specific Stylus Studio module or editor. Once you do this, any time you open afile
of that type from within Stylus Studio (using the File Explorer, for example), that fileis

opened in the editor you specify.

You can optionally specify that you want to use Stylus Studio asthe default editor for files
of thistype, regardless of where thefileis opened (from a file browser like Total

Commander, for example).

Note

or environment.

0 To add a file type to Stylus Studio:

1.

You do not need to specify the usual extensions, such as xm1, xs1, and java. Use the
procedure described in this section for file name extensions peculiar to your application

From the Stylus Studio menu bar, select Tools > Options.
Stylus Studio displays the Options dialog box.

Under General, click File Types.
TheFile Types page appears.

Options

I General
Application Settings
Editor General
Editar Format
B ackmapping
Spell Checking

Java Virtual Maching
Custom Tools
Cugtorn File Systerns
Customn Document Wizards
Customn Validation Engines
Custom #ML Converters
I Module Settings
[ DBtaxML
Default Connection
£ Java
Debugger
Jawva Compiler
External Jy't
£ ML Diff
Engine
Fresentation

L

b

File type/Stylus Studio module associations:

X

Type

 $SSSSYSSLD

.cony
i

dtd

java
P
rdbwrnl
WECC
sl
&g
_ROUEry
.xsd
.zl
Lzl

Module

Carvert to =ML
ML Diff

DTD Schema
Java Text Editor

DB to ML Data Souce
‘web Service Call

ML Document

#Huery File

#Huery File

#ML Schema

#5LT: Mapper

#5LT: Mapper

Open with Stylus Studio
false
falze
tiue
false
tiue
falze
falze
tiue
falze
tiue
tiue
tiue
tiue
false

Figure 79. Associating File Types with Stylus Studio Editors
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3. Toadd anew file type/module association, click the Add button.

Alternative: Double-click the Type field.

4. Typethe new extension, including the period, and press Enter.
Stylus Studio adds the file type and selects a default module in the Module field.
5. Optionally, select adifferent module using the drop-down list in the Module field.

6. If youwant to always use Stylus Studio to open files of thistype, changethe valuein
the Open with Stylus Studio field to True.

7. To add ancther file type, repeat Step 3 through Step 6.

8. When you are done, click OK.

Deleting File Types

0 To delete afile type:
1. Click thefile type you want to delete.
2. Click the Delete | %] button,
3. Click OK.

Working with Projects

A projectin Stylus Studio isagroup of filesrelated to agiven XML application. A project
might include XML, XML Schema, and XQuery files, aswell as OASIS catalogs, for
example. A project can contain subprojects, and subproj ects can contain subprojects. The
Stylus Studio project framework allows you to name projects (project files are saved with
a .prj extension), and it provides severa tools for managing the projects you create.

Projects are simply a convenience for organizing files — afile does not have to belong to
aproject in order for you to edit it in Stylus Studio. For example, Stylus Studio includes
all sample application filesin the examples project. You can find the examples.prj filein
the examples directory of your Stylus Studio installation directory.

This section discusses the following topics:

. “Displaying the Project Window” on page 96

« “Creating Projects and Subprojects’ on page 98

« “Saving Projects’ on page 98
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o “Opening Projects’ on page 98

« “Adding Filesto Projects’ on page 99

« “Copying Projects’ on page 100

« “Rearranging the Filesin a Project” on page 101
« “Removing Filesfrom Projects’ on page 101

« “Closing and Deleting Projects’ on page 101

o “Setting aProject Classpath” on page 102

« “Using Stylus Studio with Source Control Applications’ on page 104

Displaying the Project Window

When you open Stylus Studio for thefirst time, Stylus Studio displaysthe Project window

with the examples project. (The File Explorer window is displayed on the right.)

€l Stylus Studio

Eile Edit Yiew Project Debug SourceControl Toals ‘Window Help

| @ ©
& =
'I.:'-r_mec:t File Explarer X

= examples A
=23 query T |
i books.xml

an bookstare.sml
L mikedcatalog sml
2-£3 VideoCenter
- [2 movies. html

wideos. sl
i samplelideo.xsl
e vidensDebug ss!
i sampledyiden. xsl
=53 HEuery
- za  Multiplication table.=querny

e PARTS-O1 xquery
lia MS-GV.nquery
- aa R-QZxquery

e #“MP-O4xquery

=

'E My Computer

{b *ML Converters
ﬁ Berkeley DE HhL

o i

wiebDal
* Secure WebDay
FTP
‘wieb Service
Fielational DB

For Help, press F1
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Figure 80. Project Window with Default Project DIsplayed

There are several ways to toggle the display of the Project window. You might want to

close the Project window in order to gain more space in the editor you are working with,

for example.
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0 To toggle Project window display:
o From the Stylus Studio menu, select View > Project Window.
« Inthe Stylus Studio tool bar, click Toggle Project Window [+].

Tip TheProject window is dockable — you can move it anywhere on your desktop.

0 To hide Project window:

Click the X in the upper right corner of the Project window.

Tip When you hide the Project window, any open files remain open.

Displaying Path Names
You can control whether the Project window displays absolute or relative path names for
filesin projects. The default display isrelative names.
0 To toggle the way path names appear:
1. Display the Project window.
2. Inthe Project window, right-click to display the pop-up menu.
3. Click Show Full URL Info.

Other Documents

Stylus Studio displays documents that are not associated with a project in the Other
Documents folder, which appears after the last folder or document in the currently
displayed project. In addition, when you remove afile from a project, it is placed in the
Other Documents folder.

Project X
= Ei‘ MyPraject *
@ profilel.xsl
bookstoreDiagram. xsd
book store. did
0 ocuments

er Docu
TimeS ervice wedl
@ readme. hirn
wideos.xml

@ wzdlToDoc. xslt

Figure 81. Other Documents Folder

You can add these documents to a project at any time. See “Adding Filesto Projects’ on
page 99.
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Creating Projects and Subprojects

O

O

You can create projects and organize any project into multiple levels of subprojects. You
can add files to projects and save the project under a name you specify.

To create a project, select Project > New Project from the menu:

Stylus Studio displays the new project in the Project window. The Project window
displays information for only one project at atime.

To create a subproject:

1. Right-click the project name, and click New Project Folder in the pop-up menu.
Stylus Studio displays a default subproject folder name (NewFolderi, for example).

2. Typeanew subproject name.
3. PressEnter.

There are several waysto add filesto your projects and subprojects. See “Adding Filesto
Projects’ on page 99.

Saving Projects

O

To save a project, select Project > Save Project.

Thefirst time you save a project, Stylus Studio prompts you to specify a name for your
project. Stylus Studio appends .prj to the name you specify. It does not matter whether
or not you specify the .prj extension. Stylus Studio does not allow a project to have any
other file name extension.

When you save aproject, referencesto the files part of the project are saved relative to the
path of the project file. This allows you to move or share projects easily.

Opening Projects

You can have only one project open at onetime. If you have a project open and you open
a second project, Stylus Studio closes thefirst project and then opens the second project.

If the Project window is not visible when you open a project, Stylus Studio automatically
displays the Project window.
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0 To open a project:
1. From the Stylus Studio menu bar, select Project > Open Project.

2. Navigate to and select your project file. For example, you can open examples.prj in
the examples directory of your Stylus Studio installation directory. The examples
project contains the files for all Stylus Studio sample applications.

3. Click the Open button.

Recently Opened Projects

Projects that were recently opened are displayed at the bottom of the Project drop-down
menu. Click the project you want to open.

|Er0ject| Debug SourceContral Tools W
Mew Project
Mewe Project Wizard. ..
Cpen Project...
Save Project
Save Project As...

) &dd File...
4dd Base Catalog
Add User-defined Catalog...

Remove Iem From Project

1 test.prij
| 2examplesprj |

Figure 82. Recently Opened Projects Are Listed on the Project Menu

Adding Files to Projects

The easiest way to add afile to a Stylus Studio project isto drag the file from the File
Explorer or ancther file browser (like Total Commander, for example) into the desired
project folder. You can drag-and-drop multiple files at atime.

If thefile type is unknown to Stylus Studio, the Choose Module for dialog box appears,
which allowsyou to associate thefile with a Stylus Studio module or editor. See* Opening
Unknown File Types’ on page 88 for more information.
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Other Ways to Add Files to Projects

The following procedures describe other ways to add files to a project. Note that these
procedures vary based on whether or not the file is already open in Stylus Studio.

When Files are Open in Stylus Studio

0 To add an open file to a project:

1.
2.

Open the project to which you want to add thefile.

Click thewindow (the Web Service Call Composer, for example) that containsthefile
you want to add.

In the Stylus Studio tool bar, click Add Document to Project 3.
Alternative: Select Project > Add Document from the Stylus Studio menu bar.

When Files are Closed

0 To add a closed file to a project:

1.

2.

Open the project to which you want to add the file.

In the Stylus Studio tool bar, click Add File to Project [ .
Alternative: Select Project > Add File from the Stylus Studio menu bar.
The Open dialog box appears.

Navigate to the file you want to add and click the Open button.

Copying Projects

0 To copy a project:

1.
2.

Open the project you want to copy.

From the Stylus Studio menu bar, select Project > Save Project As.
The Save As dialog box appears.

Navigate to the location for the project copy.
In the URL: field, type the name of the new project.
Click the Save button.
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Rearranging the Files in a Project

The order in which files are displayed in the Project window has no effect on the project.
You might want to place related files near each other, or place more frequently used
project files toward the top of the project tree.

0 To rearrange files in a project:

1. If the Project window is not visible, click Toggle Project Window [& in the Stylus
Studio tool bar.

2. Inthe Project window, click the file you want to move.

3. Dragittoitsnew location.

Removing Files from Projects

When you remove afile from aproject, it is added to the Other Documents folder in the
Project window.

0 Toremove afile from a project:

1. If the Project window isnot visible, click Toggle Project Window [#] in the Stylus
Studio tool bar.

2. Inthe Project window, click the path for the file you want to remove.

3. From the Stylus Studio menu bar, select Project > Remove File from Project.
Alternative: Pressthe Delete key.

Closing and Deleting Projects

Closing

0 To close a project, open another project or create a new project.

Tip Toggling or closing the Project window does not close the project.
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Deleting

0 To delete a project, remove its .prj file from the file system.

Setting a Project Classpath

You can set a classpath at the project level. When Stylus Studio compiles or runs Java
code, it always checks the project for alocally defined classpath.

Specifying Multiple Classpaths

You use the Project Classpath dialog box to specify one or more classpathsfor a project.
If multiple classpaths have been defined, Stylus Studio searches them in the order in
which they arelisted in the Project Classpath dialog box. You can use the up and down
arrows at the top of this dialog box to change the classpath order.

Project Classpath

Locations:

Figure 83. Use Arrow Buttons to Change the Order of Classpaths

How to Set a Project Classpath

0 To set aclasspath for a project:
1. Open the Project Window if it is not aready displayed.

2. Right-click the project node.
The project shortcut menu appears.
Alternative: Select Project > Set Classpath from the Stylus Studio menu.

3. Select Set Project Classpath.
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The Project Classpath dialog box appears.

Project Classpath

Locations:

Figure 84. Project Classpath Dialog Box

4, Click the browse folders (| #:]) button.

A new entry field appearsin the Locations list box. Two buttons appear to the right
of the entry field.

5. Toadd aJAR file to the classpath, click the browse jar files button ([E3]).
Stylus Studio displays the Browse for Jar Files dialog box.

Browse for JAR files

Look in: |@bin v| €] _1" 5
Y () Catalogs | &l wsdid.jar
'g 2} =) Configuration Files @xalanhlp‘jar
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@ hiib

Desktap IFlugins
ICtrang

- @ axis-zll. jar
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My Documents u]s ar X
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. s

Figure 85. Browse for Jar Files Dialog Box

To add afolder to the classpath, click the browse folders button ( g).
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6.

Stylus Studio displays the Browse for Folder dialog box.

Browse for Folder @@

Select Rational ClearCase Yisw Folder

isk (2

D Drrive (D)

carp on 'ntdata’ (G

dfoster an 'ntdata\corpiusers' (H:)

wiew on view' (J:)

depts on 'ntdata’ (M:)

groups on 'nkdata’ (M)

3rd-party on 'peppino.bedford. progress
-

%H. H. H.H H. H. é—

pps on ‘ntdata’ (P:) N
< *

Figure 86. Browse for Folder Dialog Box

When you have located the JAR file or folder you want to add to the classpath, click
OK.

Optionally, add other JAR files or folders to the classpath by repeating Step 5 and
Step 6.

Using Stylus Studio with Source Control Applications

Stylus Studio supports the Microsoft Source Code Control Interface, allowing you to use
Stylus Studio with any source code control system that supports the same interface used
by Microsoft Visual Studio or Microsoft Visual Studio .NET.

Stylus Studio’s source control support allows you to

Add afile to source control

Remove afile from source control

Get the latest version of a source-controlled file
Check out afile

Check in afile

Un-check out afile

Show the source control history of afile

Show differences between versions of afile
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In this section

This section covers the following topics:

“Tested Source Control Applications’ on page 105

“Prerequisites’ on page 105

“Using Stylus Studio with Microsoft Visual SourceSafe” on page 106
“Using Stylus Studio with ClearCase” on page 108

“Using Stylus Studio with Zeus CVS’ on page 111

“Specifying Advanced Source Control Properties’ on page 112

Tested Source Control Applications

Integration with the following source control applications has been tested:

Microsoft Visual SourceSafe
Clearcase/Attache
CVS

Prerequisites

To use Stylus Studio’s source control features, you must have already installed the client
software for your source control application, as shown in Table 5.

Table 5. Working with Source Control Clients

When Data Is In You Need to Install

SourceSafe repository SourceSafe client or SourceOffSite
ClearCase Attache client

CVsS Zeus-CV S product

In addition, files must belong to a Stylus Studio project before you can use them with a
source control application.

Recursive Selection

When you build aproject using filesfrom asource control application, Stylus Studio gives
you the option of recursively importing all projects that are subordinate to the project
folder you select. This option, Recursively import all subprojects, appears on the Build
Project from SCC dialog box, which appears when you start the New Project Wizard.
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Selecting the Recursively import all subprojects option has the effect of selecting al the
siblings of the selected file or directory, aswell as any descendants of the selected item
anditssiblings. Stylus Studio createsa project that containsall filesthat Stylus Studio can
open (for example, .xm1, xs1t, and . xsd files) and that arein the directory hierarchy of the
file or directory you select.

For example, suppose you check Recursively import all subprojects, and you select
c:\work\myproject\documentation.xml. Stylus Studio creates a project that contains all
Stylus Studio-editable filesin c:\work\myproject and its subdirectories.

If you do not check Recursively import all subprojects, only the file you select is added
to the new Stylus Studio project you create. You cannot select a directory if you do not
select this option.

Using Stylus Studio with Microsoft Visual SourceSafe

0 To use Stylus Studio to operate on files that are under SourceSafe source control:

1. From the Stylus Studio menu bar, select Project > New Project Wizard.
The Project Wizards dialog box appears.

Project Wizards X

Available project wizards:

[ Cancel |

Praject from
SCC

Figure 87. Project Wizards Dialog Box
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2. Click Project from SCC, and click the OK button.
The Build Project From SCC dialog box appears.

Build Project From SCC X

Provider to uge: |{REE[REESS

[ Becursively impaort all subprojects
Figure 88. Build Project From SCC Dialog Box

3. Select Microsoft Visual Sourcesafe from the Provider to use drop-down list.

4. If you want to use Stylus Studio to access more than onefile in adirectory hierarchy,
click the check box for Recursively import all subprojects. See “Recursive
Selection” on page 105 if you need help with this step.

Depending on your installation, you might need to specify other properties. See
“ Specifying Advanced Source Control Properties’ on page 112.

5. Click the OK button.
The Visual SourceSafe Login dialog box appears:

Visual SourceSafe Login @I

Usemame: ‘ |

Pazsword ‘ |

IO Er o byl Studio on MT Stulus Browse...

Figure 89. Visual SourceSafe Login Dialog Box

6. Specify the username and password; optionally, use the Browse... button to access a
database other than the default database displayed in the Database field.

7. Click OK.
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The Create Local Project from SourceSafe dialog box appears.

Create local project from SourceSafe @

Create a new project in the folder: m

Sources afe project to download:

:
=@l

ncumentation
haredComponents
truzza

truzza Yersions

Figure 90. Create Local Project from SourceSafe Dialog Box

Select the folder in which you want to create the new project.

Click OK.

Theproject iscreated in Stylus Studio. A message displays the names of any filesthat
were not added to the project because their extensions are not associated with a Stylus
Studio editor.

Using Stylus Studio with ClearCase

0 To use Stylus Studio to operate on files that are under ClearCase source control:

1.

Note

2.

Use Attacheto copy the files you want to work on from a ClearCase view to thelocal
file system.

If you move these files from this directory after you create the project, you must
specify the new directory that containsthefilesin the Local Project Path field of the
Source Control Properties dialog box. To access this dialog box, select
SourceControl > Source Control Properties from the Stylus Studio menu bar.

From the Stylus Studio menu bar, select Project > New Project Wizard.
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The Project Wizards dialog box appears.

X

Project Wizards

Available project wizards:

[ Cancel |

Froject from
SCC

Figure 91. Project Wizards Dialog Box

3. Click Project from SCC, and click the OK button.
The Build Project From SCC dialog box appears.

Build Project From SCC X

Provider to uze: | {REEIREE

[] Becursively impart all subprojects
Figure 92. Build Project From SCC Dialog Box

4, Select Clearcase from the Provider to use drop-down list.

5. If you want to use Stylus Studio to access more than onefilein adirectory hierarchy,
click the check box for Recursively import all subprojects. See “Recursive
Selection” on page 105 if you need help with this step.

Depending on your installation, you might need to specify other properties. See
“ Specifying Advanced Source Control Properties’ on page 112.

6. Click the OK button.
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The Browse for Folder dialog box appears.

Browse for Folder @@

Select Rational ClearCase Yisw Folder

Y Compute ~
+ 2 Local Disk (C:)

+- iy CD Drive (D1}
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+- 58, view on view' (1)

+- 52 depts on ‘ndata’ (M:)

+- 5% groups on 'ntdata’ (N2}

+ _ﬁ 3rd-party on 'peppino.bedford. progress

+)- 5% apps on ‘ntdata’ (P:) B
< >

Figure 93. Browse for Folder Dialog Box

7. Navigate to and select thefile or directory you want to operate on, or one of thefiles
or directoriesin the topmost level of the directory hierarchy that you want to access,
and click the OK button.

Stylus Studio creates a new project that contains the file you selected, or all files that
are editable by Stylus Studio and that were in the directory hierarchy of thefile you
selected. The default name of the project is Projectn. To rename the project, select
Project > Save Project As from the Stylus Studio menu bar.

Adding Files After the Project is Created

After you create the project, you can add additional ClearCasefilesto it. If thefileis
already in ClearCase, it must be asibling of the original file you selected, or it must be a
descendant of one of its siblings. If the file you want to add is not in the directory
hierarchy of the original file, you must create a new Stylus Studio project and specify a
directory in the source control hierarchy that contains all the files you want to be in your
Stylus Studio project.

If youwant to add afilethat isnot already in ClearCase, open thefilein Stylus Studio and

then click Add To Source Control = in the Stylus Studio tool bar.
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Using Stylus Studio with Zeus CVS

Stylus Studio supports the latest version of the Zeus CV S Provider, and with some
additional configuration needed in the SourceControl > Properties dialog box.

0 To use Stylus Studio to operate on files that are under Zeus CVS source control:

1.

From the Stylus Studio menu bar, select Project > New Project Wizard.
The Project Wizards dialog box appears.

Click Project from SCC, and click the OK button.
The Build Project From SCC dialog box appears.

Select Zeus SCC-CVS from the Provider to use drop-down list.

Click the check box for Recursively import all subprojects.

Click Advanced. Several new fields appear.

IntheUser Name field, typethe user name you want to useto loginto the CV S server.

In the Project Name field, type the name of amodulein the source control hierarchy.
This should be the name of adirectory that contains al files that you want to openin
Stylus Studio.

Inthe Auxiliary Path field, type the contents of the CvSROOT environment variabl e that
you use to access the CV S server.

For example, suppose you are required to enter the following commandsin a DOS
console or UNIX shell:

cvs.exe -d:pserver:user@server.company.com:/cvsroot/projectname login
Password: %%

cvs.exe -d:pserver:user@server.company.com:/cvsroot/projectname co module

The value you should enter in the Auxiliary Path field would be:
:pserver:user@server. company.com:/cvsroot/projectname

In the Working Dir field, type the name of alocal directory.
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10. Click the OK button.

Stylus Studio downloads the selected files and places them in the directory you
specified in the Working Dir field. If you move these files from this directory, you
must specify the new directory that contains the filesin the Local Project Path field
of the Source Control Properties dialog box. To open this dialog box, select
SourceControl > Source Control Properties from the Stylus Studio menu bar.

All filesthat can be opened in Stylus Studio are now in the new Stylus Studio project. The
default name of the project isProjectn. To renamethe project, select File > Project > Save
Project As from the Stylus Studio menu bar.

Note

The cvs. exe file must be in your PATH environment variable.

Specifying Advanced Source Control Properties

The Advanced button in the Build Project From SCC dialog box displays several
additional fields.

Build Project From SCC X

Provider to uge: |{REE[REESS
[ Becursively impart all subprojects '
User Mame:

Project Mame:

Augiliary Path:

Warking Dir; E]

Figure 94. Advanced Source Control Settings

User Name is the name of the source control user. Stylus Studio uses this nameto
establish a connection with the source control server.

Project Name is the name of the source control repository you want to access. The
syntax of the project name depends on the source control provider you want to
connect with. For example, SourceSafe uses $/Name/Name, ClearCase uses the name
of the view, and CV S uses the name of the module. Some source control providers
change this description to something more suitable to their model. For example,
ClearCase changesiit to ClearCase Attache.
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o Auxiliary Path contains source control provider-specific information. Thisfield
allowsyou to enter any other information required to find your source control server.
For example, if you are using SourceSafe, you would specify the directory of the
SourceSafe client here. If you are using CV'S, you would specify the contents of the
CVSROOT environment variable.

« Working Dir isthelocal directory into which you copied thefiles under source control
that you want to access. It isthelocal counterpart for the source control repository.
For example, suppose you copied the contents of the SourceSafe repository
$/Company/OneProject to the local directory c:\work\myproject. Your local files
would map to the source control hierarchy as shown in Table 6:

Table 6. Local/Repository File Mappings

Local File Repository File
c:\work\myproject\documentation.xml $/Company/OneProject/documentation.xml
c:\work\myproject\subdir\root. java $/Company/OneProject/subdir/root.java
c:\work\anotherproject\root.java $/Company/anotherproject/root. java

Customizing Tool Bars
Stylus Studio allows you to customize the appearance, location, and content of tool bars,
and even to create tool bars of your own. This section covers the following topics:
“Tool Bar Groups’ on page 113
« “Showing/Hiding Tool Bar Groups’ on page 114
« “Changing Tool Bar Appearance’ on page 115

Tool Bar Groups

Tool bars are organized by functional group within Stylus Studio (Default, Edit, Source
Control, and so on). Customizations available for these groups include

« Show/hide

o Look, feel, and size

« Group position

Tip Tool bars are docking windows — you can drag them anywhere on your desktop.
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You control all these customizations from the Toolbars tab of the Customize diaog box.

Customize E|
Toolbars

Toolbars:

[PREEE M| [] Show Taoltips New...
Reset

ik 0

[ 0K H Cancel ][ Help ]

Figure 95. Toolbars Tab of Customize Dialog Box

O To display the Customize dialog box, select Tools > Customize from the menu.

Showing/Hiding Tool Bar Groups
Tool bar groups are displayed by default. Use this procedure to hide/re-display them.

Tip Consider maximizing Stylus Studio on your desktop in order to view as much of the tool
bar as possible when making changes.
0 To hide/show a toolbar group:
1. Display the Customize dialog box (Tools > Customize).

2. Inthe Toolbars group box, deselect the check box of the group you want to hide.
Thetool bar is removed from the Stylus Studio window.

3. Tore-display ahidden tool bar group, follow Step 1 and Step 2 and resel ect the check
box,
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Changing Tool Bar Appearance

Changes you can make to the tool bar’s appearance include

«  Whether or not to show tooltips when the mouse pointer is placed over atool bar
button

«  Whether tool bar buttons are rendered in a size larger than the default

Note Appearance settings affect all tool bars. You cannot control the appearance of individual
tool bar groups.

0 To modify toolbar appearance:
1. Display the Customize dialog box (Tools > Customize).

2. Click show Tooltips to toggle the display of tooltips when the pointer is placed over
atool bar button.

3. Click Large Buttons to toggle the size of the tool bar buttons.
4. Optionally, click the Reset button to restore default settings.
5. Click the OK button.

Specifying Stylus Studio Options

Stylus Studio allows you to set avariety of options for Stylus Studio modules, and it
provides the ability to define custom tools to run different editors and processors. This
section covers the following topics:

o “Setting Module Options’ on page 115
o “Registering Custom Tools’ on page 117

Setting Module Options
Stylus Studio allows you to set a variety of options for the Stylus Studio modul es.

0 To change module options:
1. From the Stylus Studio menu bar, select Tools > Options.

2. Inthe Options dialog box that appears, expand Module Settings to display alist of
choices.
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XML Diff

You usethe Engine and Presentation pages to define settings used by the XML Diff tool.
See “Diffing Folders and XML Documents’ on page 174 for more information.

XML Editor

Click XML Settings to specify the following:

« Refreshinterval for Sense:X

o Number of errors after which you want Stylus Studio to stop validation, and whether
or not you want Stylus Studio to display a message when validation is complete

Click custom Validation Engines to specify an alternate validation engine. See“ Custom
XML Validation Engines’ on page 1120 for more information.

XSLT Editor

Module settings for the XSLT Editor let you specify external XSLT processors, settings
used by the Mapper tab, and general editor behavior.

Click External XSLT to specify default values for external XSLT processors. Note that
Stylus Studio’s back-mapping and debugging features are not supported for all XSLT
processors. The XSLT processors that support back-mapping and debugging are
identified on the Processor tab of the Scenario Properties dialog box.

In ascenario, you can specify that you want to use an external XSLT processor. If you use
aparticular XSLT processor frequently, specify default values here. Then, in the scenario
properties, you just need to specify which external XSLT processor you want to use. If
you specify default values and you then specify different valuesin ascenario’s properties,
the scenario properties overridethe defaults. You can specify thefollowing external XSLT
options:

« Default custom processor command line

« Default additional path for custom processor

« Default additional classpath for custom processor
Click Mapper to specify how xs1: for-each instructions should be rendered on the M apper

canvas, and to specify element creation for unlinked nodes. See “Mapping Source and
Target Document Nodes” on page 514 for more information on using the XSLT Mapper.
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Click XSLT Settings to specify the following:

«  Whether Stylus Studio displaysthe Scenario Properties dialog box when you create
anew stylesheet

« Whether Stylus Studio saves scenario meta information in stylesheets
o  Whether Stylus Studio detects infinite loops

o Maximum recursion level

o Allocated stack size

Java
To modify Java settings, see “ Configuring Java Components’ on page 131.

Registering Custom Tools

Stylus Studio allows you to register custom tools to run alternative editors, processors,
Preprocessors, or postprocessors. For example, you can register a custom tool that
configures Internet Explorer to display the document you are working on.

After you register a custom tool, Stylus Studio adds an entry to its Tools menu — select
Tools and then your tool. The order in which the tool names appear in the Custom Tools
options pageisthe order in which the tool names appear in the Stylus Studio Tools menu.

You can register custom tools from within Stylus Studio or from the command line.

Using Stylus Studio

0 To register a custom tool in Stylus Studio:

1. From the Stylus Studio menu bar, select Tools > Options.
Stylus Studio displays the Options dialog box.

2. Click Custom Tools to display the Custom Tools page.
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Stylus Studio displays an entry field for the tool name.

Ed

Options

55 General ~ ools 0
Application Settings
Editar General %
Editar Sensei
Editor Format
B ack-mapping
Spell Checking
File Types
Java Virtual Machine Command:
Components
#ML Conwverters ForJava
#ML Converters For MET Initial directaory:
DataDirect XEuerny
g Custom Tools
Custorn Document Wizards
Cugstorn ¥ alidation Engines [ Prompt for arguments [ Use Output ‘window
I Module Settings
£ EDI to ML []5ave Al documents before execution
ED| Yiewer Settings
£ Java

Debugger

Arguments:

X
Ed
#
-
[
[l
Iz

Fath:

79 ‘Web Service Call Composer

Lo g

Figure 96. Defining a Custom Tool

4. Enter the name as you want it to appear in the Stylus Studio Tools menu.

5. Inthe Command field, specify or select the absolute path for the command that runs
your tool. Thismust be a .exe, .bat, or .cmd file.

6. IntheArguments field, specify any arguments your tool requires. You can click k_
to display adrop-down list that includesFile Path, File Dir, File Name, File Extension,
and Classpath.

7. Inthenitial Directory field, type the absolute path for the directory that contains any
files or directories needed by your custom tool.

8. Inthe Path fidd, type any paths that need to be defined and that are not already
defined in your PATH environment variable.

9. If youwant Stylus Studio to prompt for arguments before it runs your tool, click
Prompt for Arguments.

10. If you want Stylus Studio to display output from your custom tool in its Output
Window, select Use Output Window.
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11. If you want Stylus Studio to save al open documents before running thistool, select
Save All documents before execution.

12. Click the OK button.

Using the Command Line

0 To register a custom tool using the command line:

The format for the command lineis:

struzzo /newCustomTool "Tool n:=Tooln; Args= value; Command=value;
Description=value; Initial Directory=value; Path=value; PromptArgs=value;
RedirectOutput=value; DoSaveAll=value"

Example:

struzzo /newCustomTool "Tool 0:=Tool 0;Description=Avalon Uploader;
Command=AVRPTLDR.exe;Args= ${FilePath}"

Arguments for the newCustomTool function are described in the following table:

Table 7. Properties for Registering Custom Tools

Name

Description

Tool n:

Thefull syntax for this property is Tool n:=Tool n, where n is some
number. The number, n, specifies the order in the Tools menuin
which the custom tool you are registering appears. You might use 0
for the first tool you register, 1 for the second, and so on. Valid
values are numbers starting with O.

Thefirst part (Tools n:=) is used to create a key in the Windows
registry. The second part (Tools n) is used as a prefix for other
entriesin theregistry key that correspond to thistool. The two
values should always be the same (Tools 1:=Tools 1, for example).

Args

Command line arguments for the tool you are registering.

Command

The absolute path for the command that runsyour tool. Thismust be
a.exe, .bat, or .cmdfile.

Description

The tool name as you want it to appear on the Stylus Studio Tools
menu.
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Table 7. Properties for Registering Custom Tools

Name Description

Initial Directory The working directory for the tool. Thisisthe absolute path for the
directory that contains any files or directories needed by your
custom tool.

Path Any pathsthat need to be defined and that are not already defined in

your PATH environment variable.

PromptArgs Whether you want Stylus Studio to display the Parameters dialog
box each timethistool isrun. Valid values are 0 (do not display the
Parameters dialog box) and 1 (display the Parameters dialog
box).

RedirectOutput Whether you want the output directed to the Stylus Studio Output
window. Valid values are 0 (do not redirect) and 1 (redirect).

DoSaveAll Whether you want Stylus Studio to save all open documents before
running thistool. Valid values are 0 (do not save) and 1 (save al).

Defining Keyboard Shortcuts

You can define akeyboard shortcut for many of the tasks you perform with Stylus Studio.
If you find that you repeatedly perform the same action, define a shortcut to speed your
work. You can use a keyboard shortcut right after you defineit.

How to Define a Keyboard Shortcut

0 To define a keyboard shortcut for a Stylus Studio task:

1. From the Stylus Studio menu bar, select Tools > Keyboard.
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The Shortcut Keys dialog box appears.

Shortcut Keys

Select a macro:

Block_ContextDelete
Block_ContextExpand
Block_ContextGo to 35LT Source
Block_ContextGoto to Function Defi
Block_Context Properties

DBtokL: Cancel Query

DBtoixML: Database Schema
DBtoixML: Execute

DBtoixML:Load Database Schema
DebugAttach To Yk
Debug:Breakpaints

Debug:Call Stack 'wWindow

[rezcription

Azgigned shortcuts:

Create Shortcut

Bemove

|
0K

T

Figure 97. Defining Shortcut Keys

2. IntheSelect a macro: field, select the macro for which you want to define a shortcut.

Tip When you select a macro, Stylus Studio displays a description of what that macro

does.
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3.

Click Create Shortcut.
The Assign Shortcut dialog box appears.

Assign Shortcut

Fress new shortcut key:

Cancel
Nore

Figure 98. Assigning a Shortcut Key

Pressthe key or keysthat you want to be the shortcut. For example, Ctrl+E, F7, Alt+P.
The Assign Shortcut dialog box displays a message indicating whether or not that
key combination is currently in use.

If the shortcut key is not already in use, click the OK button. Otherwise, try another
shortcut key.

Stylus Studio closes the Assign Shortcut dialog box.

Click OK inthe Shortcut Keys dialog box.

Deleting a Keyboard Shortcut

> w

To delete a shortcut:

From the Stylus Studio menu bar, select Tools > Keyboard. The Shortcut Keys dialog
box appears.

In the Select a macro: field, select the macro you want to delete a shortcut for.
In the Assigned shortcuts field, click the shortcut you want to remove.

Click Remove.

Click OK inthe Shortcut Keys dialog box.
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Using Stylus Studio from the Command Line

Stylus Studio provides several command line utilities that allow you to perform Stylus
Studio operations, such as starting Stylus Studio and executing an X Query. Command line
utilities are provided as a convenience for use during development and testing.

Available command line utilities, and where to find more information on them, are
described in the following table.

Table 8. Stylus Studio Command Line Utilities

Utility Name Description Where to Find More Information

struzzo Invokes Stylus Studio “Invoking Stylus Studio from the Command
Line” on page 123

StylusDiff Diffstwo XML documents | “Running the Diff Tool from the Command
Line” on page 202

StylusValidator | Validates XML “Validating XML from the Command Line”
on page 126

StyTusXql Executes an XQuery “Executing an X Query from the Command

Line” on page 125

StylusXsTt Applies a stylesheet “Applying a Stylesheet from the Command
Line” on page 124

You can also execute DataDirect XML Converters™ (componentst that |et you convert
non-XML like EDI and CSV to XML, and vice versa) from the command line. To learn
more about the DataDirect XML Converters™ for Javaand .NET, see the DataDirect
XML Converters™ documentation at http://www.xmlconverters.com/doc/.

Command Line Executables Location

The executables for Stylus Studio command line utilities are located in the \bin directory
where you installed Stylus Studio.

Invoking Stylus Studio from the Command Line

You use the Struzzo utility to invoke Stylus Studio from the command line and open a
particular file. Stylus Studio recognizes the file extension and opens the file in the editor
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associated with that filetype. If Stylus Studio isalready running, the sameinstanceisused
to open the file specified in the file parameter.

You can optionally usethe styTesheet or XQuery parameter to create a scenario with the
stylesheet or XQuery you specify.

The struzzo utility takes the following format:
Struzzo file [stylesheet or XQuery]

Table 9 describes the parameters for the Struzzo command.

Table 9. Struzzo Command Line Parameters

Parameter Description

file The path of the document you want to open in Stylus Studio. This document
is used as the source document in a scenario when you provide the
stylesheet or XQuery parameter.

[stylesheet or | The path of the stylesheet or XQuery you want to use to create a scenario.
XQuery]

Applying a Stylesheet from the Command Line

You use the Stylusxs1t utility to apply a stylesheet from the command line. The
StyTusXs1t utility uses Stylus Studio’s built-in XSLT and X Path processors, which
support XSLT 1.0 and XPath 1.0, respectively. The built-in processors are designed to aid
testing and debugging and have not been optimized for performance.

One way you might want to use the StylusXs1t command-line utility isto chain
stylesheets. That is, you can create a batch file in which Stylus Studio consecutively
applies multiple stylesheets to the same XML source document. Stylus Studio creates
temporary files to specify the result of one transformation as the source for the next
transformation.

The stylusxs1t utility takes the following format:

StylusXslt [-out <output file>] [-param name=value] [-fop] [-print] -in <input
XML file> <XSLT stylesheet>
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Table 10 describes the parameters for the Stylusxql command.

Table 10. StylusXslt Command Line Parameters

Parameter

Description

[-out <output
file>]

File to which the XSLT result will be written. The default is stdout.

[-param
name=value]

The name-value pair of a parameter in the stylesheet specified in the
stylesheet parameter.

[-fop] I nvokesthe A pache Formatting Objects Processor (FOP) to post-processthe
XSLT result.
[-print] Sends the result of the transformation to the default printer.

[-in <input

The path of the XML document to which you want to apply the stylesheet

file>] specified inthe XSLT styTesheet parameter.
<XSLT The path of the XSLT you want to apply to the document specified in the
stylesheet>

-in parameter.

Executing an XQuery from the Command Line
{"‘5 XQuery support is available only in Stylus Studio XML Enterprise Suite and

Stylus Studio XML Professional Suite.

You use the StylusXq1 utility to execute an X Query from the command line. The
StyTlusxql utility uses the Stylus Studio’s built-in XQuery and X Path processors. The
built-in processors are designed to aid testing and debugging and have not been optimized
for performance. If you want to choose a particular processor, specify the processor inthe
XSLT scenario and run the scenario from within Stylus Studio.

The stylusxql utility takes the following format:

StylusXql [-in <source>] [-out<output file>] [-param name+value] [-i] [-debug
host[:port]] <XQuery file>
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Table 11 describes the parameters for the Stylusxql command. All parameters are

required.

Table 11. StylusXql Command Line Parameters

Parameter

Description

-in <source>

The path of the XML document to be used to set the current context for the
XQuery.

-out <output
file>

File to which you want the XQuery result to be written. The default is
stdout.

-param
name=value

The name-expression pair of avariable in the X Query specified in the
XQuery file parameter.

-

Indents the XQuery result.

-debug
host[:port]

Debugs the query using the debug server specified by the host and,
optionally, port parameters.

XQuery file

The path of the XQuery you want to execute against the file specified in the
-in <source> parameter.

Validating XML from the Command Line

You use the Stylusvalidator Utility to validate XML from the command line.
StylusValidator usesthe built-in Stylus Studio XML validator. All output from this
utility goesto stdout.

The stylusvalidator utility takes the following format:

StylusValidator [-q] [-noval] [-schema] fiTlename

Table 12 describes the parameters for the StyTusxql command.

Table 12. StylusValidator Command Line Parameters

Parameter

Description

[-al

Quiet mode — errors are not printed to stdout.

[-noval]

Checks only for well-formedness. Does not check for errors.
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Table 12. StylusValidator Command Line Parameters

Parameter Description

[-schema file] |Validatesthe XML document against the XML Schemaspecifiedinthe file
parameter.

filename The path of the XML document you want to validate.

Managing Stylus Studio Performance

Stylus Studio uses the TEMP directory to store temporary files such asthetrandation in
UNICODE of the current XML or XSLT document. File systems are usually quite fast
when handling files that are in the range of afew hundred megabytes. Stylus Studio
performance should be smooth and quick when the TEMP windows environment variable
points to alocation where

o Thereisaminimum of 1 gigabyte of free space.
o Thehost disk isreasonably fast.
Stylus Studio is regularly tested against files that are up to 120 MB. How well your

installation of Stylus Studio can create, open, and manipulate such large files, or even
larger files, depends on

« Available physical memory
« Dimension of the pagefile
« Current load of the machine

Troubleshooting Performance

Table 13, Performance Symptoms, summarizes performance symptoms you might
experience and where to find information on addressing them.

Table 13. Performance Symptoms

Symptom See

XML editing is slow “Changing the Schema Refresh Interval” on page 128
“Checking for Modified Files’ on page 128
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Table 13. Performance Symptoms

Symptom

See

Errors or crashes during XSLT
processing

“Changing the Recursion Level or Allocated Stack Size”
on page 130

Stylus Studio is slow to start

“Automatically Opening the Last Open Files’ on page 130

Changing the Schema Refresh Interval

Asyou edit an XML document, Stylus Studio displays a pop-up menu that lists the
elements and element attributes you can create. Stylus Studio retrieves this information
from the document’s schema. The frequency with which Stylus Studio retrievesthis
information can affect XML editing performance. The default refresh interval is 10

seconds.

If XML editing performance is slow, increase the refresh interval that Stylus Studio uses
to refresh the schema information.

0 To change the refresh interval:

1. From the Stylus Studio menu bar, select Tools > Options.
The Options dialog box appears.

2. Click Module Settings > XML Editor > XML Settings.
The XML Settings page of the Options dialog box appears.

3. IntheRefresh interval field, type alarger number. For information about how Stylus
Studio uses thisinterval, see “Options - Module Settings - XML Editor - XML

Settings’ on page 1301.

Tip If the schema used by your document is almost never modified, you can safely
increase the interval to as much as 10,000 seconds.

4. Click oK.

Checking for Modified Files

When you are working with files that Stylus Studio must open through network
connections that might be slow, you might not want Stylus Studio to automatically check
for modified files. Turning off this option can improve XML editing performance.
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0 To turn off checking for modified files:

1. From the Stylus Studio menu bar, select Tools > Options.
The Options dialog box appears.

2. Click Application Settings if it is not already selected.
The Application Settings page of the Options dialog box appears.

3. If the Automatically check for externally modified files is selected, deselect it. For
information about how Stylus Studio uses this setting see “ Options - Application
Settings’ on page 1268.

Alternatively, you can select Disable check on hidden files, which allows Stylus
Studio to skip thesefiles. Hidden files arefiles that are in the Stylus Studio project or
the Other Documents folder but are not currently open in Stylus Studio.

4. Click OK.
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Changing the Recursion Level or Allocated Stack Size

If you are getting errors or crashes when you use the internal Stylus Studio XSLT
processor, there are two options you can change to fix this.

The Maximum recursion level isthe number of levels Stylus Studio allows you to
recurse on a template invocation.

TheAllocated stack size isthe amount of memory allocated to the XSLT processing
thread stack.

0 To change the recursion level or the allocated stack size:

1.

From the Stylus Studio menu bar, select Tools > Options.
The Options dialog box appears.

Click Module Settings > XSLT Editor > XSLT Settings.
The XSLT Settings page of the Options dialog box appears.

Adjust the Maximum recursion level and the Allocated stack size as needed. For
information about how Stylus Studio uses these settings see “ Options - Module
Settings - XSLT Editor - XSLT Settings” on page 1313.

Click OK.

Automatically Opening the Last Open Files

When you start Stylus Studio, it automatically opens any filesthat were open thelast time
you closed it. Thisfeature can affect performance if many files were open when you last
closed Stylus Studio.

If Stylus Studio istaking along time to start, you can do one of the following:

Close most or all files before you shut down Stylus Studio.

Turn off the option that automatically opens the files that were open the last time you
closed Stylus Studio.

0 To prevent Stylus Studio from automatically opening documents:

1.

From the Stylus Studio menu bar, select Tools > Options.
The Options dialog box appears.

Click Application Settings if it isnot already selected.
The Application Settings page of the Options dialog box appears.
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3. If Openlast documents automatically when Stylus Studio starts isselected, deselect
it. For information about how Stylus Studio uses this settings see “ Options -
Application Settings’ on page 1268.

4. Click oK.

Configuring Java Components

Several modulesin Stylus Studio are written using Java, and therefore require either Java
runtime or Java compiler components to be installed on your computer. These Java
components, the Java Runtime Environment (JRE) and the Java Devel opment Kit (JDK),
are available from Sun Microsystems and are installed separately from Stylus Studio.

You can install these components either before or after you install Stylus Studio. When
you start Stylus Studio, it attemptsto identify thelocation of the Javaruntimelibrariesand
compiler automatically.

This section identifies the Stylus Studio modules that require Java runtime and Java
compiler components, where you can downl oad these Java components, and how to force
Stylus Studio to detect new or changed Java components.

This section covers the following topics:

o “Stylus Studio Modules That Require Java’ on page 131

« “Verifying the Current Java Virtual Machine” on page 132

« “Downloading Java Components’ on page 132

o “Modifying Java Component Settings’ on page 133

Stylus Studio Modules That Require Java
The following modules in Stylus Studio require that Java runtime and/or Java compiler
components are installed on the machine on which you have installed Stylus Studio:
o Saxon XSLT and XQuery engines
o Built-n Java XSLT processor
« FOP
o Web Service Call Composer Axisclient
« DataDirect XML Converters accessed via URL
« SenseX inthe Java editor
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Rather than trying to determine in advance which Stylus Studio modules you might use

in your XML application development, consider installing the JDK or JRE on your
machine.

Settings for Java Debugging
See “Debugging Java Files’ on page 549 for more information on this topic.

Verifying the Current Java Virtual Machine

TheJavaVirtua Machine (JV M) interprets runtime commands and compiler instructions;
it is part of the Javainstallation. You can check to see the current version of the VM
installation by selecting Help > About from the Stylus Studio menu:

Framework version:  Buid 733

Madule versions: dbgmgr.dll: Build 733 ~
debugger.dil: Build 733
flat.dll: Build 733
pipeline.dl: Build 733
prezentation.dll: Build 733
zqwml.dl: Build 733 b,

Java Virtual Machine: ¥1.4.2_06-b03 Java HotSpat(TH] Client M Sun Microsystems Inc.

debug mode port: 3000

Figure 99. Verifying the Current JVM Installation

The Java Virtual Machine field displays information about the VM installed on your
machine.

Downloading Java Components

Java runtime and compiler components are available for download from Sun
Microsystems; they are packaged in the Java 2 Platform Standard Edition (J2SE).

Either of the following versions is compatible with Stylus Studio 2009:
o J2SE 1.4.2 (download it here: http://www.java.sun.com/j2se/1.4.2/download.htm1)
o J2SE 5.0 (download it here: http://www.java.sun.com/j2se/1.5.0/download. jsp)
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Modifying Java Component Settings

Propertiesfor VM and JDK components are displayed on the Java Virtual Machine page
of the Options dialog box, shown in Figure 100. When you start Stylus Studio, it
automatically detectsthe JavaVirtual Machine (JVM) and compiler componentsinstalled
on your machine and sets the properties for these components accordingly.

Options E|
=] Ge”z'a' R o Enable Jy
pplication Settings
Editor General JRE Yersion: 1:41.03 bt
Editor Format Parameters: +#debug +<noagent <unjdwp:iansport=dt_socket zerver=y s
B ack-mapping
S.pall Checking DK
- Rl 1.41_03 v
2 Java Virtual Machine JDK Version: =
Trterrew Javac Parameters: il
Custom File Systems
Customn Document Wizards
Extemal J'/b
Custom ¥ alidation Engines R ; em? }
I3 Module Settings b
3 Java Debugging Parameters: | -debug *$hoagent +runjdwp:tiansport=dt_socket server=y,s
Debugger
£ Web Service Call Composer Display console window when possible
Proxy Settings
£ =ML Diift
Engine
Fresentation
£ %ML Editor
#ML Settings
et

Figure 100. Reset Java Properties in the Options Dialog Box

Once these properties have values, Stylus Studio uses them until you either

« Usethe auto detect feature to change them. You might want use auto detect if you
have been using Stylus Studio with the J22SE 1.4.2 and later install the J2SE 5.0, for
example.

« Change them manually. You can manually specify that Stylus Studio use a different
jvm.dIl or javac.exe, for example.

How Auto Detect Works

Theauto detect feature prompts Stylus Studio to fetch the settingsfrom the registry setting
Qurrent Versi onunder thekey HKEY_LOCAL_MACH NE\ SOFTWARE\ JavaSof t \ Java Runt i ne
Envi ronnent to find the version, and then adds the version number to that same location
to get the settings.
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Note that if you manually change your settingsto use another local version of the JDK, it
may fail toload properly unlessyou also point the Qur rent Ver si on setting to match. This
is because the VM itself might try to load DLLsfrom the location of the current version
instead of the location you specify.

About JVM Parameters

Asarule, you should never change the default valuesin the Parameter fieldsfor the Jvm
or the External JVM. This option exists to accommodate unusual configurations. In such
situations, Stylus Studio Technical Support might instruct you to change this value.

About JDK Parameters

The -g parameter instructs the compiler to add debugging information to the generated
.class filg; it is set by defaullt.

How to Modify Java Component Properties

0 To modify Java component properties:

1. Start Stylus Studio if it is not already running, and select Tools > Options from the
menu.

The Options dialog box appears.
2. Select General > Application Settings > Java Virtual Machine.

3. If youwant Stylus Studio to update Java component propertiesto the latest installed
version on you machine, click the Auto detect button.

Otherwise, make the changes manually.
4. Click OK.

5. If you made changesto any VM properties, you need to restart Stylus Studio for
those changes to take effect.
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Stylus Studio makesit easy to create, edit, and query XML documents. Depending on the
structure of the datain your XML document, you can chooseto work with raw XML text,
aDOM tree diagram, or agrid representation. Any changes you make in one view are

immediately visible in every other view. You can easily create an XML Schemaor DTD
based on the content of your XML document if it isnot already associated with aschema.

Watch it! You can view a video demonstration of this feature by clicking the
television icon or by clicking this link: watch the XML Editor video.

You can see other Stylus Studio video demonstrations here:
http://www.stylusstudio.com/xml_videos.html.

This section covers the following topics:

o “Creating XML Documents’ on page 136

« “Using Document Wizardsto Create XML” on page 137
» “Updating XML Documents” on page 139

o “Using the Text Editor” on page 141

o “Updating DOM Tree Structures’ on page 155

« “Using the Grid Tab” on page 159

. “Diffing Folders and XML Documents’ on page 174

o “Using Schemaswith XML Documents’ on page 205

« “Converting XML to Its Canonical Form” on page 208
o “Querying XML Documents Using XPath” on page 208
o “Printing XML Documents’ on page 208

o “Saving XML Documents’ on page 209
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Creating XML Documents

You can create XML documentsin Stylus Studio manually, using the XML Editor, or
automatically, using document wizards, the Stylus Studio Custom XML Conversions
module, DataDirect XML Converters, and other features.

Using the XML Editor

To create an XML document using the XML Editor, select File > New > XML Document
from the Stylus Studio menu.

Stylus Studio displays a new, untitled document in the XML Editor. The document
contains only the XML declaration:

<?xml version="1.0"7>

The XML Editor provides several viewsof an XML document, each onitsown tab —Text,
Tree, Grid, and Schema. See* Updating an XML Document —Getting Started” on page 10
for an overview of these XML editing tools. See “Updating XML Documents” on

page 139 for more detailed information.

Other Ways to Create XML

You can also create XML using

« Document wizardsthat convert HTML, DTD, and XML Schemato XML. See“Using
Document Wizards to Create XML” on page 137, later in this section.

« DataDirect XML Converters, which convert CSV, fixed-width, EDI, and other flat file
formatsto XML. See“How XML Convertersare Used in Stylus Studio” on page 212.

« Custom XML conversions that you build using Stylus Studio’s Custom XML
Conversion module. See “Custom XML Conversions’ on page 219.

@i‘? DataDirect XML Converters and the Stylus Studio Custom XML Conversions
module are available only in Stylus Studio XML Enterprise Suite.
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Using Document Wizards to Create XML

Stylus Studio provides several document wizards that automatically create XML
documents from XML Schema, DTD, and HTML. This section describes how to work
with these document wizards; it covers the following topics.

o “How to Use a Document Wizard” on page 137

o “Creating XML from XML Schema’ on page 137
o “Creating XML from DTD” on page 138

o “Creating XML from HTML” on page 138

How to Use a Document Wizard
Most document wizards operate in the same general fashion:
1. Select the document wizard you want to use.

2. Specify the file from which you want to create an XML document (an HTML file or
an XML Schema, for example).

3. Specify additional settings that will affect the resulting XML document (the root
node, for example).

4. Runthewizard.
Converted files are opened as new, untitted XML documentsin the XML Editor.

All document wizards are listed in the Document Wizards dialog box. Select File >
Document Wizards to display this dialog box.

Creating XML from XML Schema

When you usethe XML Schemato XML document wizard, you specify the XML Schema
from which you want to create an XML document, aswell asits root node, and whether
or not you want to generate commentsin the XML.

Note If the XML Schema containsan element defined using abuilt-in type, theinstance of that
element inthe XML document is created using the minimum value of the range specified
for that type. For example, if the XML Schema contains a <part> element defined as
type="xs:integer”, the <part> element in the resulting XML document appears as
<part>-9223372036854775808</part>.
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Creating XML from DTD

Inadditionto XML Schema, you can useaDTD to create an XML file. When you use the
DTD to XML document wizard, you specify the DTD from which you want to create an
XML document in the DTD File field. Next, specify the element that you want to be the
root element in the new XML document, and whether or not you want expand each
element only once (thisresultsin asmaller XML document file).

Creating XML from HTML

You can create an XML document from an HTML file using the HTML to XML
document wizard. Simply specify the HTML file you want converted to XML and runthe
document wizard.

Tip Stylus Studio also has a document wizard that convertsHTML to XSLT. See“Creating a
Stylesheet from HTML" on page 404.
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Updating XML Documents

{;**'5 The XML editor Grid tab is available only in Stylus Studio XML Enterprise Suite
and Stylus Studio XML Professional Suite.

Stylus Studio provides Text, Tree, and Grid views for updating any XML document you
open. The view you choose for editing depends on how structured your datais and your
personal preferences. This section describes how to choose an XML document view to
work with and other features related to editing XML.

This section discusses the following topics:
« “Choosing aView” on page 139
o “Saving Your Work” on page 140
« “Ensuring Well-Formedness’ on page 140
« “Reverting to Saved Version” on page 140
“Updating Java Server Pages as XML Documents’ on page 141

Choosing a View

You can add and modify the data and structure of an XML document in any view. When
you switch to a different view, any changes you made appear in the new view. To move
from view to view, click the Text, Tree, or Grid tab at the bottom of the document you are
working with.

To add contents to an empty XML document, consider the structure of the data you plan
to add. The Grid view ismost useful for creating very structured data that includes
multiple instances of the same elements. The Tree view makes it easy to add many
different elements. In order to useit, however, the XML must be well-formed.

Each view of the document allows you to query the contents of the document. See
“Querying XML Documents Using XPath” on page 208.

Watch it! You can view a video demonstration of the Grid tab by clicking the
television icon or by clicking this link: watch the XML Grid Editor video.

A complete list of the videos demonstrating Stylus Studio’s featuresis here:
http://www.stylusstudio.com/xml_videos.html.
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For More Information

To learn more about a specific XML view, see one of the following sections:
o “Using the Text Editor” on page 141

“Updating DOM Tree Structures’ on page 155
o “Using the Grid Tab” on page 159

Saving Your Work

The procedure for saving your work is the same regardless of which view you use to edit
XML —make sureyour work isin the active window, and then select File > Save from the
Stylus Studio menu bar, or click Save in the Stylus Studio tool bar.

Ensuring Well-Formedness

0 To ensure that your XML document is well formed, click the Tree tab at the bottom
of the XML editor window.

If the document iswell formed, Stylus Studio displays the tree representation. If the
document is not well formed, Stylus Studio displays a message that indicates the reason
the document is not well formed and the location of the error or omission. Correct the
document, and click the Tree tab.

If you are already viewing the Tree representation of your document, the document iswell
formed. When you edit the Tree view, the XML that Stylus Studio generatesis aways
well formed.

Reverting to Saved Version

You might make some changesto an XM L document and then decide that you do not want
to save them. In the Stylus Studio tool bar, click Reload [&]. Stylus Studio displays a
message that warns you that you will lose any changes, and prompts you to confirm that
you want to reload the version of the document that is in the file system. After you
confirm, Stylus Studio displays the last saved version of the document.
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Updating Java Server Pages as XML Documents

0 To open a .jspfile as an XML document:
1. Inthe File Explorer, navigate to the JSP file you want to open.
2. Rignht click the file name, and select Open With from the shortcut menu.
3. Click XML Editor.

Using the Text Editor

You use the Text tab of the XML editor to edit XML text. The Text tab provides the usual
tools you expect to find in atext editor. These tools are described in this section.

@ Stylus Studio - [books.xml] =13

wa File Edit VWiew Project Debug XML SourceConfrol Tools \Window Help X

EAE 1 - B 0 @ = 0 -« & o7
&) 7

wa  books xml |

oo malRr £ £ 2 4 KType a new querys v|

f7:ml version="1.0"2=

-~
<books name="My books"= q
<hook bookid="1" pubdate="03/01/2002">
<titlerJava Webh Services</titlex ==
B <authors>
<authorsDavid &A. Chappel</authors
<author>Tyler Jewell</authors
</authors»>
<subjectrWeb Hervices</subjects
</hook>
c] <hook bookid="2" pubdate="01/01/2000"=[_]
] <hook hookid="3" pubdate="03/01/2002">
I <title*Professional ebXML Foundations</titlex
] <authors>
<authorsColleen Evans</authors
<author=David A. Chappel</suthors

| £

\Text ATree lh[ilit:l .h Schema l/

Ln1Col 1 Char 60 {0x003C) MU

Figure 101. Text Tab in the XML Editor

This section covers the following topics:
“Text Editing Features’ on page 142
“Use of Colorsin the Text Tab” on page 147
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« “Using the Spell Checker” on page 149
“Moving Around in XML Documents’ on page 153

Text Editing Features

This section describes some of the more common text editing tools and featuresin Stylus
Studio.

Simple Text Editing

Select the text you want to edit and then do any of the following:

« Click the right mouse button to display a pop-up menu of edit commands.

« Click the appropriate button in the Stylus Studio tool bar.

« Pressthe standard control keys to copy, cut, paste, undo, or redo.

You can select aportion of text and move it to anew location by dragging it. You can drag

text from one document to another. You can drag text from documents outside Stylus
Studio to adocument in Stylus Studio.

Code Folding

Code folding is the ability to collapse three or more lines of code in XML -based editors.
For example, this code segment:

<aut hor >

<first-nane>Joe</first-name>

<l ast - nane>Bob</ | ast - nane>

<awar d>Trenton Literary Revi ew Honorabl e Menti on</ awar d>
</ aut hor >

when collapsed, appears asthis:

<aut hor >

Codefolding allows you to ssimplify the visual presentation of XML -based code; folding
does not affect the underlying code.

In editors in which code folding is supported, Stylus Studio displays atree control in the
gutter to the left of editing canvas; thisis the same area of the editor used to display line
numbers, debugging symbols, and back mapping symbols. By default, all codeis

displayed.
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What You Can Fold

In XML-based editors, you can fold
o Internal DTD

« Comments

. CDATA

o XML elements

In the XQuery Source editor, you can fold

o Comments

o Expressions delimited by curly braces ({ and } )
o XML elements

How to Fold Code

0 To unfold a segment of code, click the [-] symbol associated with that code.

When you fold code, Stylus Studio displays aboxed ellipsis symbol at the end of theline
of code you have folded, as shown here:

E< name="My bhooks"=>
= < bookid="1" pubdate="03/01/Z00Z">
< =Java Web Services< =
®
= Wuthorss
= = <Lauthor:=David 4, Chappel</authors>
= < hookid="] <author>Tyler Jewell</author>
i < o Tay S Buthors>
= < =
< =David &. Chappel< =
= =

<« =Java Message Jervice (JM3)< >

Figure 102. Example of Folded Code

If you place the pointer in the élipsis symbol, Stylus Studio displaysatool tip that shows
you the collapsed code. The amount of code that appears in the tool tip depends on the
areaon your desktop you have given the Stylus Studio application.

Tip You can unfold afolded segment by double-clicking the tool tip.

Sense:X Speeds Editing

Asyou type, Sense:X prompts you with the possible tags that you can insert at a given
location based on the XML Schema associated with the document you are editing. As
S0on as you type atag's open bracket, Stylus Studio displays a scrollable list of the
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elementsthat are allowed at that location of the document. As shown in Figure 103, there
are two entries for book, for example:

et ol
=%yl version="1.0"?>
E'ﬂ:uuks name="My hooks" xmlns:xsi="http://www, w3, org/2001/ZML3chema- instance”

<hook bookid="1" pubdate="03/01/2002">
=title>Java Web Services</title>
<authors>
<author»David &. Chappel</author>
<author=Tyler Jewell</author>
</authora>
<subjectrWel Services</subdect>

<6hnnk>

e book 2" pubdate="01/01/2000">
ﬂ}:aak o Meaoage Serviess/oiles

& o -- By
U4 1 [opATA r=David A. Chappel</author>

B
? . .
< ava Message Service (JM3)</subject>

=] <hook bhookid="3" pubdate="03/01/2002">

Figure 103. Choose Element Name or Element Fragment

If you choose the first book item (*=r-ax ), Stylus Studio completes the <book tag for you.
If you choose the second book item (=Fx-cx ), Stylus Studio completes the entire XML
fragment for you, including al attributes and default values described in the associated
XML Schema, as shown in Figure 104:

<hook bookid="-9" pubdate="undefined”>
<titlerstring</title>
<authors>
<author>string</author>
</authaors>
<subject class="-9"/>
</hook>

Figure 104. Complete XML Fragment Inserted Using Sense:X

Use the arrow key to move the selection, and press Enter to insert the value you want.

Indent

Note

Indent XML tags to show the hierarchy relationships. Click Indent XML Tags «4. Stylus
Studio indents all text in the active XML document window.

After you click the Indent XML Tags button, you cannot automatically undo or redo any
changes you have been making. After you make more changes, you can press Ctrl+Z and
Ctrl+Y to automatically undo and redo those changes until you click Indent XML tags
again.
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Line Wrap

Stylus Studio automatically wraps lines whose length exceeds 16k characters. You can
turn off this feature by selecting Disable from the Line wrap field on the Editor General
page of the Options dialog box (Tools > Options).

You can override line wrap settings by selecting Edit > Wrap Lines from the Stylus Studio
menu or by clicking the wrap lines button on the tool bar([Z]).

When line wrapping is on, Stylus Studio wraps lines to fit in the available window; the
place at which the line wraps moves as the width of the window changes. Green arrows,
as shown in Figure 105, indentify lines that have wrapped.

<
<

=

< bookid="9" pubdate="11/12/1999">
= =Instant UNIX< =
< =
= =Andrew Evans< =
< =Neil Matthew< =
< =Richard Stones< >

»In what many are calling the UNIX masterpiece of the decade,

Evans

G

Matthew,

and #tones have come up with a hook that 1s as lyrical as it is technic

1lly astute and thorough.
= =

=

=ENU/ Linux<

=

<

=

Figure 105. Green Arrows Identify Lines That Have Wrapped

Spell Checking

By default, Stylus Studio spell checkstext as you type using an internal spell checker.
Words the spell checker believes are misspelled (or repeated) are underlined with a
squiggly line, as shown in Figure 106.

= bookid="5" pubdate="11/10/2000">
< *Beginnerfapos; s Guide to Access 2.0< =
>
< uthor Team< >
< sminollofminello. com< >
< =
< class="1"xAccess< =
< =

Figure 106. Typographical Errors Are Highlighted by the Spell Checker

For more information, see “Using the Spell Checker” on page 149.
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Font

Com

Tip

You can change the font of the text display in Stylus Studio. This change affects only the
Stylus Studio display. Beyond personal preference, you might choose to change the font
for localization purposes— the avail able fonts are the fonts that can display the characters
in your XML file. For example, in a Japanese file, only two or three font names appear.
Click Font Change [£-] to display alist of fonts.

ments

Select the text that you want to be acomment. In the Stylus Studio tool bar, click
Comment/Uncomment Selection [=]. To remove comment tags, select the commented
text, and click Comment/Uncomment Selection.

To select an entire ling, click the gray areato the left of the line you want to select.

Bookmarks

You can set bookmarks in the XML display. Bookmarks allow you to jump to important
linesin your file. See “Using Bookmarks® on page 544.

Search/Replace

Search for and replace text you specify. Click Find or Replace in the tool bar.
You can also enable Find by pressing Ctrl + F.

Find X
Find what: | b Find Mext
[ Match whale word only Diirection Mark Al
[ Match caze Clp
[] Reqular expression @ Down

[ Search only inside:

Figure 107. Find Dialog Box

When you enable Find, Stylus Studio displays the word in which the cursor islocated —
whether the cursor iswithintheword or immediately adjacent toit —inthe Find what field
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of the Find dialog box. Similarly, any text you have selected —whole, partial, or multiple
words —is displayed in the Find what field.

Tip You can scroll through alist of the other words you have searched for by clicking the
down arrow when the Find what field is active.

Note that in addition to specifying case, you can also indicate whether or not you want to
useregular expressionsinthe Find what field and Replace with field. Thisallowsyou, for
example, to search for aline and replace it with multiple lines, as shown in the following

example.
Replace @
Find what: <onex<fones w Find Mest
Replace with: <0ne><a"0ne®wo>text<a’two> w RBeplace

Replace In Feplace Al

) Whle file Cancel

Figure 108. Replacing Text Using Regular Expressions

See “ Sample Regular Expressions’ on page 256 for examples of regular expressions and
to learn about other sources of information.

Use of Colors in the Text Tab

Stylus Studio text editors use colors to distinguish the types of datain XML documents.
The default colors for the XML Editor are described in the Table 14.

Table 14. Text Colors in Stylus Studio

Color Type of Data

White Document background

Royal blue Markup

Black XML declaration and text node contents
Pale blue Schema definition
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Table 14. Text Colors in Stylus Studio

Color Type of Data

Purple Element names defined in the DTD
Red Attribute names

Dark blue Attribute values

Orange Element names not defined in the DTD

How to Change Colors

You can set colors for the text editors associated with different document types (XML,
XQuery, XSLT, and so on) individually.

0 To change colors:
1. Select Tools > Options to display the Options dialog box.
2. Click Editor Format.
3. Select the editor type from the Editor drop-down list.
4. Setthefont, size, and color for different document categories as desired.
5. Click OK to close the Options dialog box.
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Using the Spell Checker

You can use the Stylus Studio Spell Checker with all of Stylus Studio’stext-based editors
(like editors for XQuery and XSLT, for example) to both actively and passively check
your documents for typographical errors such as misspellings and repeated words.

< bookid="5" pubdate="11/10/2000">
< rBeginner&apos; s Guide =
< > Spelling X
< faek: puthor Team
< la@minollo.
< =
< class="l"rAccess< Peplace with: |Row
: ;oakid="6" pubdate="il/1z,|  FereenalDictonay
< rBeginning Java Z<
< >
< *Iwvor Horton<
< >
Zeub ectogavas .
< =
< bookid="7" pubdates="02/07/
< *Beginning ATL COM Pro
< >
< >Richard Grimes<
< rGeorge Reilly<
< FAlex 8tockton< =

Figure 109. Stylus Studio’s Spell Checker

Default Spell Checking

The Spell Checker ison by default for most editors. This means that when you open a
document in a Stylus Studio text editor, and as you type in that document, Stylus Studio
checks the document for typographical errors. Words that the Spell Checker identifies as
possibly containing atypographical error are underlined with ared “squiggle’, like the
word Worx shown in Figure 106.

Tip You can right-click aword with a squiggle and select Spell Checker Suggestions for to
display alist of suggestions for the word identified by the Spell Checker.

Manual Spell Checking

At any time, you can manually spell check a document by selecting Tools > Check
Spelling from the Stylus Studio menu. When you do this, Stylus Studio starts the Spell
Checker, which reads through the current document. When it finds a possible
typographical error, Stylus Studio displays the Spelling dialog box, as shown in
Figure 109.

Using the Spelling dialog box, you can
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« Ignore the current occurrence of the word the Spell Checker has selected
« Ignoreal occurrences of the word

« Replace the current occurence of the word

o Replace all occurrences of the word

« Add new wordsto the dictionary

. Edit exigting dictionary content

Specifying Spell Checker Settings
You specify Spell Checker settings using the Spell Checking page of the Options diaog

box.
Options X
= Genzral oot St A5 Diefault Language: | English [United States) v
pplication Settings
Editor General Skip Ignare
Ed‘tir Format [] Capitalized words [e.g. "ltaly") [ICase
ackmappin
& \_Zhliiw:l [ Mized-case wards [e.g. "Datalirect"’) Accents
File Types N [ Uppercase words (e.q. "USDA")
Java Virtual Machine []'wWards with embedded digits [e.q. '"w3C")
Euslum PIJUISS E-mail and URIs [e.q. v stylusstudio.com''|
Caztzz Dl:c:ui:;z:n\ifizards Words with |0 o fewer characters
Customn Validation Engines [ Bepeated words
= dCIUStSDn:t_XML Converters Suggestion Mods Keyboard Layout
odule Settings : ;
3 DBteiL () Abridged [for quick checks] @) Standard
Default Connection O Expanded O Matural (5pit)
3 Java @ Standard ) Dwarak
Crebugger ) Unabridged (for mast alternatives)
Jawva Compiler
External Jy't
£ ML Dift
Engine
R F'iels..entatwon r

Figure 110. Options for the Spell Checker

Spell Checker settings include

« Wordsto skip based on certain characteristics — you might decide to skip e-mail
addresses and URLSs, for example. Skipped words are not considered by the Spell
Checker.

o Characteristics in words that you wish to ignore — you might not care about case or
accents marks for spelling purposes. In this case, two words that share the same
spelling, except for the characteristic you specify, are considered to be equivalent
(méme and meme (accent), or BMW and brmw (case), for example).
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« Thetypeof dictionary you want the Spell Checker to use when providing alternatives
to thetypographical errorsit locates. Settings range from Abriged to Unabridged and
show the fewest to the most aternatives, respectively. The Abridged setting resultsin
fewer aternative suggestions for misspelled words than Standard (the default) or
Unabridged, for example, but it requires less time to spell check a given document.

« Thelayout of the keyboard you are using. The Spell Checker usesthisinformation to
offer meaningful suggestions to words you might have mistyped.

How to Spell Check a Document

0 To spell check document:

1. Select Tools > Check Spelling from the menu.

Stylus Studio starts checking the document for typographical errors. If it findsa
typographical error, it displays the Spelling dialog box.

If You Want To Then

Replacethe misspelled word withtheword | Click Replace. Click Replace All to
suggested by the Spell Checker replace all occurrences of that word.

You can also replace the misspelled word
with another word selected from the
Alternatives list box, or with aword you
typein the Replace with field.

Ignore the misspelled word Click Ignore. Click Ignore All to ignore
al occurrences of that word.

Add the misspelled word to the personal Click Add.

dictionary

Edit the personal dictionary Click Edit. See “Using the Personal
Dictionary” on page 152 for more
information.

2. Once you select an action, the Spell Checker continues checking the document.

When you have addressed al identified errorsin the document (either by replacing,
correcting, or ignoring them), the Spell Checker stops.
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Using the Personal Dictionary

The Stylus Studio Spell Checker comeswith itsown dictionary. You can create apersonal
dictionary and fill it with your own entries. Personal dictionaries are used in conjuction
with the Spell Checker dictionary across all Stylus Studio editors.

To add entriesto the personal dictionary, you can

« Typeentriesindividually

o Import lists formatted as . txt files

o Automatically add entries while you check the document

The personal dictionary is stored in the c:\Documents and Settings\username\
Application Data\Stylus Studio directory.

Warning Do not modify thefilesin this directory by hand. Use the Personal Dictionary Editor
dialog box to make any changes to the personal dictionary.
0 To add a word to the personal dictionary:

1. Start the Spell Checker and display the Personal Dictionary Editor dialog box (click
Edit on the Spelling dialog box).

2. Enter aword in the New Word field.

3. Click the Add button.
The word appears in the Words in Personal Dictionary list box.

4. Click the Close button.

Tip You can also add any word identified as a misspelling to the personal dictionary by
pressing the Add button on the Spelling dialog box.
0 To import lists into the personal dictionary:
Note Listsyouimport into the personal dictionary must be unformatted . txt files, with each

entry on its own line. Do not use tab- or comma-separated files.

1. Start the Spell Checker and display the Personal Dictionary Editor dialog box (click
Edit on the Spelling dialog box).

2. Click the Import button.
The Open dialog box appears.

3. Sdlect the . txt file you want to import into the personal dictionary and click Open.
Thewordsin thelist you import appear in the Words in Personal Dictionary list box.
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4. Click the Close button.

0 To export the personal dictionary to a .txt file:

1. Start the Spell Checker and display the Personal Dictionary Editor dialog box (click
Edit on the Spelling dialog box).

2. Click the Export button.
The Save As dialog box appears.

3. Navigate to the directory in which you want to save the copy of the personal
dictionary.

4. Enter anamein the File name field.

5. Click Save.
The contents of the personal dictionary is saved to the text file.

6. Click the Close button.

Moving Around in XML Documents

Stylus Studio provides several tools for easily moving around in an XML document.

Line Numbers

To go to aparticular line, click Go to a specified location & in the Stylus Studio tool
bar. Stylus Studio displaysthe Go To diaog box. Type the number of theline you want to
go to and click OK. The cursor moves to the line you specified.

Stylus Studio displays line numbers and column numbersin the lower right corner of the
Stylus Studio window. If you want, you can set a Stylus Studio option that displaysline
numbers to the left of each line in the editor you are using.

To do this, from the Stylus Studio menu bar, select Tools > Options. Inthe Options page
that appears, click Editor General. In the Editor field, select the editor in which you want
to display line numbers. Select the Show Line Numbers check box.
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Bookmarks

To quickly focus on a particular line, insert abookmark for that line. You can insert any
number of bookmarks. You can insert bookmarks in any document that you can open in
Stylus Studio.

To insert a bookmark, click in the line that you want to have a bookmark. Then click
Toggle Bookmark in the Stylus Studio tool bar. Stylus Studio inserts a turquoise box
with rounded corners to the left of the line that has the bookmark. To move from
bookmark to bookmark, click Next Bookmark IE or Previous Bookmark |#¥g. See
“Using Bookmarks’ on page 544.

Tags

To move to the closing tag for an element, click in the tag name for the element. In the
Stylus Studio tool bar, click Go to Matching Tag *%; . Stylus Studio moves the cursor to
the closing tag for the element you clicked.

Find

In any view of an XML document, and in the XSLT Source view of a stylesheet, you can
click Find in the Stylus Studio tool bar. In the Find dialog box that appears, specify
the string you want to search for and click Find Next. Stylus Studio highlights the first
occurrence of the string you entered. In the Text view, you can specify that you want
Stylus Studio to highlight all instances.

Depending on which view you are examining, Stylus Studio allows you to specify

constraints on the search. The congtraints you can specify include the following:

« Match whole word only

« Maich case

o Find aregular expression

« Searchinside only element tags, only element values, only attribute names, and/or
only attribute values

To learn more about regular expression syntax, visit
http://www.boost.org/1ibs/regex/doc/syntax.html.
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Updating DOM Tree Structures

To update the DOM tree for an XML document, click the Tree tab at the bottom of the

window that contains the document.

Stylus Studio - [books.xml]

Eile Edit “iew Project Debug XML DTD ¥MLSchema SourceConfrol Tools \Window Help x
& & = B % dth ¥
books.xml |
B s @X L AR v
Tag A
‘_t= EE Y rooks
b @ name My books
@ =-®% book
LY % bookid 1
e # pubdate 03/01/2002
é,? "8 ritle Java Web Services
5 =-*® suthors
.T= author Dawvid A. Chappel
"% author Tyler Jewell
"[: subject eb Services
=™ nook
% hookid 2
# pubdate 01/01/2000
" ritle Java Meszage Jervice
=-*® authors
'[: author David A. Chappel
"8 subject Java Message Service (JM3)
=-*® hook v
;‘Text }\Tree AGrid hSchemal/
UM

Figure 111. Tree Tab in XML Editor

Whileyou are editing, if the display doesnot appear to correctly represent the current tree,
click Reload Document in the main tool bar. If you want to perform a certain action
and Stylus Studio has grayed out the button for that action, try clicking Refresh first.

To save your file, select File > Save from the Stylus Studio menu bar or click Save in the

Stylus Studio tool bar.

This section discusses the following topics:

« “Displaying All Nodesin the Tree View” on page 156
« “Adding aNodein the Tree View” on page 156

« “Deleting aNodein the Tree View” on page 157

« “Moving aNodeinthe Tree View” on page 157

« “Changing the Name or Value of aNodein the Tree View” on page 157

Stylus Studio® 2009 User Guide

155



Editing and Querying XML

“Obtaining the XPath for aNode” on page 158

Displaying All Nodes in the Tree View

To expand atree so that you can see all the nodesin thetree, click the root node and then
pressthe asterisk (*) key in the numeric key pad. To expand any particular node, click that
node and press = in the numeric key pad.

The default tree view of your document does not include nodes that contain only blank
spaces, linefeeds, or tabs. To toggl e between the default view and aview that does display
all nodes, click White Space w5 inthe Stylus Studio tool bar. Thisview is most helpful
when you are operating on the DOM and need to know the exact structure of the tree.

Adding a Node in the Tree View

O

Along the | eft side of the window that contains your DOM tree, there are buttons that
represent the types of nodes you can add to your document. The procedure for adding a
nodeis similar for all types of nodes.

To add an element:

1. Click the element that you want to be the parent of the new element, or click an
element that you want to be a sibling of the new element.

2. Toadd achild element, click New Element ¥:® . To add asibling element, hold down
the Shift key and click New Element.

Alternative: To add a child element, press Ctrl+E. To add a sibling element, press
Ctrl+Shift+E.

If your XML document specifiesaDTD, Stylus Studio displaysalist of the elements
that you can add at that location. If your document isassociated withan XML Schema
or does not specify aDTD, Stylus Studio prompts you to specify the name of the new
element.

3. Double-click the element you want to add, or type the name of the new element and
press Enter. If you added a child node, Stylus Studio addsit asthe last child.

4. If the new element contains data, type a value for the new element and press Enter.

156
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Deleting a Node in the Tree View

Along the | eft side of the window that contains your DOM tree, there are buttons that
represent the types of nodes you can add to your document. The procedure for deleting a
nodeis similar for all types of nodes.

0 To delete anode:
1. Click the node you want to delete.
2. Click Delete Node ¥ .

Moving a Node in the Tree View

Along the | eft side of the window that contains your DOM tree, there are buttons that

represent the types of nodes you can add to your document. The procedure for moving a
nodeis similar for all types of nodes.

0 To move a node:
1. Click the node you want to move.

2. Click the up and down arrows at the top of the document window to move the node
up or down the tree.

Alternative: Drag the node to its new location.

Changing the Name or Value of a Node in the Tree View

Along the | eft side of the window that contains your DOM tree, there are buttons that

represent the types of nodes you can add to your document. The procedure for renaming
anodeissimilar for all types of nodes.

0 To rename a node:
1. Click the node you want to rename.

2. Click Change Name < . If your document specifiesaDTD, Stylus Studio displays
alist of the possible names. If your document does not specify aDTD, Stylus Studio
opens an edit field.

3. Double-click the new name, or type the new name and press Enter.
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0 To change the value of a node:
To change the value of a node:
1. Click the node whose value you want to change.

2. Click Change Value 3# . Stylus Studio displays an update field.
3. Typethe new value and press Enter.

Obtaining the XPath for a Node

[0 To obtain the XPath expression that returns a particular node:
1. Inthe XML editor, click the Tree tab.

2. Right-click the node for which you want the X Path expression.
3. Inthe shortcut menu that appears, click Copy XPath Query to Clipboard.
4. Press Ctrl+V to paste the X Path expression where you want it.
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Using the Grid Tab

£

firgs "':d

and Stylus Studio XML Professional Suite.

The XML Editor Grid tab is available only in Stylus Studio XML Enterprise Suite

The Grid view of an XML document is useful for structured data— it is a convenient way

to view and work with documents that contain multiple instances of the same type of
element.

Stylus Studio - [books.xml *] =1
Z File Edit Wiew Project Debug XML DTD XMLSchema SourceControl Tools Window Help x
HrEE AR # B o2& 2 #h &
books.xml x|
ES R H = ¥, <Type a new querys v|
"% Tag Hame @ name
= bhooks My books o
<books>
"% Tag Hame ¢ hookid @ pubdate " title " subject
book 1 03/01/2002 Java Weh Zervices Web Services
hook 2 01/01/z2000 Java Message Jervice Java Message Service (O
book 3 03/01/2002 Professional ebXML Foundat ebXML
Bl book 01/03/1997 Beginning Visual C++ 6 Dat|Database

<book><authors:

®® Tag Hame Text # 1
suthor John Connell
i author Minollo
-
\ Text. }\ Tres hGrid f{‘ Schema l/

For Help, press F1

HUM

Figure 112. Grid View of books.xml

This section describes the features of the Grid tab and how to useit to edit XML

documents. This section covers the following topics:

« “Layout of the Grid Tab” on page 160
« “Features of the Grid Tab” on page 160
« “Moving Around the Grid Tab” on page 164

“Working with Rows’ on page 166
“Working with Columns” on page 168
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o “Working with Tables’ on page 170

Watch it! You can view a video demonstration of this feature by clicking the
television icon or by clicking this link: watch the XML Grid Editor video.

A complete list of the videos demonstrating Stylus Studio’s featuresis here:
http://www.stylusstudio.com/xml_videos.html.

Layout of the Grid Tab

The Grid tab consists of atool bar and adisplay area. Thetool bar has buttonsto perform
actions and operations on both the grid itself and on the underlying XML document
represented in the grid. An example of theformer isthe ability to show the child el ements
of the document’sroot element; they are hidden by default. An example of the latter isthe
ability to add anew instance of an element or to change avalue. These operations are also
accessible from the XML > Grid Editing menu, as well as from the grid shortcut menu
(right-click on the grid).

Thetool bar also includesaquery field, which allows you to enter an X Path expression to
guery the XML document. Results are displayed in the Query Output window, which
appears when you run the query if it is not already displayed. See “Querying XML
Documents Using XPath” on page 208 for more information on this feature.

The display area shows the XML document, both its structure and content, rendered in a
tabular, or grid format.

Features of the Grid Tab

This section describes the features of the Grid tab. It covers the following topics:
. “Expanding and Collapsing Nodes’ on page 161

o “Collapsing Empty Nodes’ on page 161

« “Renaming Nodes’ on page 163

o “Resizing Columns’ on page 163

« “Showing Row Tag Names’ on page 164
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Expanding and Collapsing Nodes

When you first display a document in the Grid tab, the document is collapsed so that it
showsjust theroot element (hereit is <books>) and its name attribute (My books), asshown
in Figure 113.

booksz.xml |

Figure 113. Default Display — Document Elements Are Collapsed

A plus sign displayed to the left of the node name indi cates that this node has child nodes.
You can click the plus sign to display a subgrid that displays the child nodes, as shownin

Figure 114.
books /book
4 bookid @ pubdate " title " subject
1 03/01/2002 Jawva Web Zervices Tebh Services
2 01/01/2000 Java Message Service Java Message Service (JHI)
3 03/01/2002 Professional ebXML Foundations eh XML
4 01/03/1997 Beginning Visual C++ 6 Database Progr Datshase
5 11/10/2000 EBeginner's Guide to Access 2.0
& 11/12/1999 Beginning Java 2 Java
7 02/07/1998 EBeginning ATL COM Programming C++
a 10/01/1295 XML Applications EML
9 11/12/1999 Instant TNIZ GNU/Linux

Figure 114. Click Plus Signs to Expand Collapsed Tables

You can continue to drill down in thisfashion to view all values.

0 To expand a node, click the plus sign ().

Collapsing Empty Nodes

Some nodesin adocument are simply containers—they have no content of their own. An
example of acontainer node is the <authors> element in books . xm1. The <authors>
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element issimply acontainer for one or more <authors> €lements, as shown in this excerpt
of books.xm1:

<aut hor s>
<aut hor>David A Chappel </ aut hor >
<aut hor >Tyl er Jewel | </ aut hor >

</ aut hor s>

To streamline the display, Stylus Studio hides the tables that represent container nodes.
Information about container nodes is displayed in the child node’s header. Figure 115
shows the default display for the author element. Notice that the header,
book/authors/author, contains information about the container node, authors.

i name

[ My books

books /book

 pubdate " title

. book/aut hors/authorpp

Dawvid A. Chappel
Tyler Jewell

Figure 115. Table Headers Show Full Path

If you want, however, you can display the tables associated with container nodes, as
shown in Figure 116.

@

[ My books

books /book

9 bookid i pubdate ||| ™" title
03/01/2002 Jawva Web Zervices

= book fauthor ’

Text

Dawvid A. Chappel

Tyler Jewell

Figure 116. Container Nodes Are Hidden by Default
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Thetable associated with the authors node now appearsin the grid; it isempty (it hasno
rows) because it isacontainer. The elementsit contains are displayed in their own table,
authors/author.

0 To display container nodes, click Simplified View ().

Thisaction isalso availablefrom the XML > Grid Editing menu and from the grid shortcut
menu.

Renaming Nodes
You can rename container nodes directly in the grid.

0 To rename a node:

1. Double-click the header that represents the node you want to rename.
The node name is selected.

2. Type the name you want to use for the node.

3. PressEnter (or click elsewherein the grid or grid background).

Resizing Columns

When you expand a node, Stylus Studio displays it in uniform columns. You can resize
columns to any width you prefer by dragging the handle on the right side of the column
header, as shown in Figure 117.

i name

[ My books

books /book

00 P e
hookid ubdat

03/01/2002

2 01/01/z000

Figure 117. Resize Columns by Dragging the Right Handle

0 To resize a column, drag the handle on the right side of the column header.
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Showing Row Tag Names

Inthegrid view of astructured XML document, each child element of anode corresponds
to arow in atable. For example, the <books> node of books.xm1 contains nine child
elements; each row isan instance of the <book> element. To preserve space in thegrid, the
tag names of child elements are not displayed as a separate column in the table. Rather,
as shown in Figure 114, thisinformation is displayed in the table header itself.

If you want, you can display the tag name for child elementsin their own columns, as
shown in Figure 118.

@ bookid % pubdate A title
03/01/2002 Jawva Web Zervices
01/01/2000 Java Message Service
03/01/2002 Professional ebXML Foundations
01/03/1997 Beginning Visual C++ & Database Progy
11/10/2000 EBeginner's Guide to Aecess 2.0
11/12/1999 EBeginning Java 2
02/07/1998 Beginning ATL COM Programming
10/01/19295 XML Applications
11/12/1999 Instant UNIZ

HHEHEBKHRBH
- 5
wom - ok W N e

®H

Figure 118. Displaying the Root’s Child Element

0 To toggle the display of child element names, click Toggle Row Tag Name ().

This action is also available from the XML > Grid Editing menu.

Moving Around the Grid Tab

You can move around the grid using the mouse (click where you want to go) and the
keyboard. Keyboard navigation is presented in the following table.

Table 15. Keyboard Navigation in the Grid

Key Action

Up/Down arrow keys Moves the row highlight in the direction of the arrow key you press.

Left/Right arrow keys Moves the focus from one cell to the next, in the direction of the
arrow key you press.

Page Up Moves the row highlight to the root node’s attribute.

164
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Table 15. Keyboard Navigation in the Grid

Key Action
Page Down Moves the row highlight to the last row in the document.
Tab Moves the focus forward to the next cell in the row; movesto the

first cell of the next row when you hit the last cell in arow.

Shift + Tab Moves the focus backward to the previous cell in the row; movesto
the last cell of the previous row when you hit thefirst cell in arow.

Selecting Items in the Grid

When you select acell in atable:

« Therow is selected; you can perform row-oriented actions like changing the row’s
order in the table. You can also select arow by clicking the plus sign to the left side
of the row.

« Thecolumn is selected; you can perform column-oriented actions like adding a new
column or renaming an existing one.

o Thecdl getsfocus.
Tip Pressing Enter places a selected cell in Edit mode.

How Grid Changes Affect the XML Document

When you make a change to the document structure or content on the Grid tab, those
changes are reflected immediately in the underlying XML document. You can see your
changes affect the document on the Text tab.

Consider the following excerpt from books. xm1.

<aut hor s>
<aut hor >Davi d A. Chappel </ aut hor >
<aut hor >Tyl er Jewel | </ aut hor >

</ aut hor s>
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If you move the rows in the authors table, for example, as shown in Figure 119,

book/authors/author

Tyler Jewell
David A. Chappel

Figure 119. Moving a Row Affects XML

the underlying XML changes accordingly:

<aut hor s>
<aut hor >Tyl er Jewel | </ aut hor >
<aut hor >Davi d A. Chappel </ aut hor >
</ aut hor s>

Types of Changes that Affect the Document

The following changes, all of which can be made using Grid tab, affect the underlying
XML document:

« Adding, deleting, reordering rows

« Adding, deleting, reordering, and renaming columns

« Adding, deleting, reordering, and sorting tables

« Changing element and attribute values

« Renaming container e ements

Changesyou make affect the current instance only. For example, in the example shownin

Figure 119, only that instance of the nested table is affected. If you add a column to
books/book, however, every instance of books/book gets that new column.

Working with Rows

Stylus Studio provides several features to help you work with table rows in the Grid tab.
Changes you make to tablesin the Grid tab, such as adding a new row or modifying a
value, arereflected in the underlying XML document.

This section covers the following topics:

« “Reordering Rows’ on page 167

« “Adding and Deleting Rows’ on page 167

166

Stylus Studio® 2009 User Guide



Using the Grid Tab

Reordering Rows
You can move rows up and down within the same table. Changes you make to row order
affect the e ement order in the underlying XML document.
0 To move arow:
1. Select the row you want to move.

2. Click the Move Up (Ji=) or Move Down ([=]) button to move the row to the desired
location in the table. These actions are also available from the XML > Grid Editing
menu and from the grid shortcut menu.

Adding and Deleting Rows

You can add and delete rows in atable. Changes you make to the table in this way affect
the number of instances of the element in the table. When you add a row, you can insert
it in the table above or below the currently selected row.

Tip You can move rows up and down within atable.

0 To add a row:
1. Select the row next to which you want to insert a new row.

2. Click thelnsert Row Before ([*=) or Insert Row After (=) button to add the new row
to the table. These actions are also available from the XML > Grid Editing menu and
from the grid shortcut menu.

The row is added to the table.

0 To delete arow:
1. Select the row you want to delete.

2. Click Delete (). This action is also available from the XML > Grid Editing menu
and from the grid shortcut menu.

The row is deleted from the table.
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Working with Columns

Stylus Studio provides several features to help you work with table columnsin the Grid
tab. Changes you make to tablesin the Grid tab, such as adding a new column or
reordering existing columns, are reflected in the underlying XML document.

This section covers the following topics:

« “Selecting a Column” on page 168

« “Adding Columns’ on page 168

o “Deleting Columns’ on page 169

« “Reordering Columns’ on page 169

« “Renaming Columns’ on page 170

« “Changing aValue’ on page 170

Selecting a Column

Column operations can be performed when you select any cell in a column. When acell
(and, therefore, its column) is selected, it is highlighted with ayellow outline. As shown
in Figure 120, the <tit1e> column is selected —the cell containing Java Message Service
isthe one that is highlighted.

| books /book
@ bhookid @ pubdate " title "% subject

03/01/2002 Java Teb Services Web Services
01/01/2000 E: Java Message Jervice ([JM]

03/01/2002 Professional ebXML Found: ebXML

H|H
-

=
w

Figure 120. Selected Cells are Highlighted in Yellow

0 To select a column, click any cell in the column you wish to select.

Adding Columns

You can add two types of columnsto tablesin the Grid tab — attribute columns and element
columns. The procedure for adding both types of columnsis the same. When you add a
column, itisinserted immediately after thelast column of itstype. You can move columns
after you create them.

168
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0 To add a column:
1. Select the row in which you want to add a column.

2. Click Add Attribute Column ([]) or Add Element Column ([Z]). These actions are
also available from the XML > Grid Editing menu and from the grid shortcut menu.

The column is added to the table.

3. If you want, move the column to a new location in the row. See “ Reordering
Columns” on page 169.

Deleting Columns

O To delete a column:

1. Select acell inthe column you want to delete.
A yellow border appears around the cell you select.

2. Click Delete Column (). Thisactionis also available from the XML > Grid Editing
menu and from the grid shortcut menu.

The column is deleted from the table.

Reordering Columns

You can reorder columnsin the grid by dragging them to the position you desire.

0 To reorder a column:
1. Place the pointer on the left handle in the column header.

2. Press and hold mouse button one.
The cursor changes shape, as shown here.

"= subject

{hb SGervices

Jawa Message Service

ehXHL

Figure 121. Moving a Column

3. Drag the column to the location in the row you want.

4. Release the mouse button.
The column is placed in the new location within the row.

Stylus Studio® 2009 User Guide 169



Editing and Querying XML

Renaming Columns

You can rename columnsin the grid. This has the effect of renaming the corresponding
attribute or element name in the underlying XML document.

Note You cannot rename the root element from the Grid tab.

00 To rename a column:

1. Select acedll inthe column you want to rename.
A yellow border appears around the cell you select.

2. Click Rename Column ([F]). Thisactionisalso available from the XML > Grid Editing
menu and from the column shortcut menu.

The column is renamed.

Changing a Value
You can change element and attribute val ues.

0 To change avalue:

1. Double-click the cell whose value you want to change.
The cell field becomes editable, as shown here.

" title
Java Web Services‘

Figure 122. Changing a Value

2. Edit the vaue as required.
3. PressEnter.

Working with Tables

Stylus Studio provides several features to help you work with tables in the Grid tab.
Changes you make to tables in the Grid tab, such as adding anested table, arereflected in
the underlying XML document.
This section covers the following topics:
« “Adding aNested Table” on page 171
« “Moving aNested Table” on page 172

“Deleting a Table’ on page 172
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o “Sorting aTable” on page 173
» “Copying a Table as Tab-Delimited Text” on page 173

Adding a Nested Table

You add nested tables to adocument in the Grid tab using the Add Nested Table dialog
box, shown in Figure 123. This dialog box allows you to specify the path to the root for
the new table, arow e ement name, and the number of rows.

Add Nested Table X
Path ta the root :
! '

Fiow element name:

Mumber of rows: |2

S
-

Figure 123. Add Table Dialog Box

A nested tableis created as a child of the current element. The nested table shown in
Figure 124, myTable, was created as a child of the <book> element.

i name

[ My books

@ bookid i pubdate " title " subject
=1 03/01/2002 Java Web Services Teh Services

book /authors /author
[E] Text

Dawid L. Chappel
Tyler Jewell

book/myTable
[E] Text
row 1

rov 2

Figure 124. Default Nested Table

Nested tables are created with two default rows, which use the element name you provide
in the Row Element Name field of the Add Nested Table dialog box. Rows get a default
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text value of Row n text, where nisan incrementing value starting with 1. You specify the
number of rows using the Number of rows field.

0 To add a nested table:

1.

2.

Select the element to which you want to add a nested table.

Click Add Nested Table ([FF). This action is also available from the XML > Grid
Editing menu and from the grid shortcut menu.

The Add Nested Table dialog box appears.

Optionally, specify the path to the root. If you leave thisfield blank, the nested table
is created as a child of the current element.

Enter arow element name.
Optionally, change the number of default rows.

Click OK.
The nested table is added to the document and appears in the grid.

Moving a Nested Table

You can change the order of nested tables within arow.

0 To move a nested table:

1.
2.

Select the heading of the nested table you want to move.

Click the Move Up ([f=) or Move Down ([=]) button to move the table to the desired
location. These actions are also avail able from the XML > Grid Editing menu and from
the grid shortcut menu.

Deleting a Table

O

To delete a table:

1.

2.

Select the heading of the table you want to delete.

Click Delete (). This action is also available from the XML > Grid Editing menu
and from the grid shortcut menu.

The table is deleted from the document.

172

Stylus Studio® 2009 User Guide



Using the Grid Tab

Sorting a Table
You can sort tables on any column in ascending or descending order.

0 To sort atable:
1. Select acel inthe column on which you want to sort the table.

2. ClicktheSort Ascending ([£]]) or Sort Descending ([Z]]) button to sort the table rows
in ascending or descending order, respectively. These actions are also available from
the XML > Grid Editing menu and from the grid shortcut menu.

Tip You can also display sort options by right-clicking the column heading.

The table rows are sorted based on the order you select.

Copying a Table as Tab-Delimited Text

You can copy atab-delimited text version of atable to the clipboard. This makes it
possible to paste document contents from the grid into spreadsheets and other editors that
can manage tab-delimited files. Figure 125 shows books/book in books .xm1 pasted into
Microsoft Excel, for example.

£ Microsoft Excel - Book1

@ File Edit “iew Insert Format Tools Data  Window Help Adobe POF
PEESIESRY LA -F v - @x-4HBE0D 2 ari
= = # g2 o
TIEE.

A1 > # bookid

A B © o]

1 [bookid __lpubdate title subject
2 1 3/1/2002 | Java Yeb Services WWeb Services
3 2 1/1/2000 Java Message Service Java Message Service (JMS)
4 3 3172002 Professional ebXML Foundations ebihL
5] 4 1/31957 Beginning “isual C++6 Database Programming  Database
B 5 1141072000 Beginner's Guide to Access 20
7 <] 114121999 Beginning Java 2 Java
g 7 2f711998 Beginning ATL COM Pragramming C++
9 3 10141999 XML Applications ML
10 9 1141241999 Instant UNEX GMUALinux

Figure 125. Pasting a Table into a Spreadsheet

Note that when you usethisfeature, the entiretableis copied — column headings (element
and attribute names) are not distinguished from cell contents (element and attribute
values) in the spreadsheet.
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0 To copy atab-delimited table to the clipboard:

1
2.

Select the heading of the table you want to copy.

Select XML > Grid Editing > Copy as Tab-Delimited from themenu. Thisactionisalso
available from the grid shortcut menu.

Diffing Folders and XML Documents

@i‘? XML differencning is available only in Stylus Studio XML Enterprise Suite and
Stylus Studio XML Professional Suite.

During application development, it can be useful to be ableto compare two or more XML
documents, or to compare the contents of two folders, in order to identify the type and
number of differences between them. The process of comparing one document (or folder)
with another isreferred to as diffing. Stylus Studio provides utilitiesfor diffing foldersand
documents.

@ Watch it! You can view a video demonstration of this feature by clicking the
television icon or by clicking this link: watch the XML Diff video.

A complete list of the videos demonstrating Stylus Studio’s featuresis here:
http://www.stylusstudio.com/xml_videos.html.

This section covers the following topics:

“Overview” on page 175

“Diffing Folders’ on page 180

“The XML Diff Viewer” on page 184

“Diffing aPair of XML Documents’ on page 191

“Diffing Multiple Documents’ on page 193

“Modifying Default Diff Settings’ on page 198

“Running the Diff Tool from the Command Line” on page 202
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Diffing Folders and XML Documents

Overview

Stylus Studio’s Diff tool lets you easily compare two or more versions of the same
document in the XML Diff Viewer (as shown in Figure 126), or the contents of two
folders (as shown in Figure 130).

4 Stylus Studio - [authors.dff] =109
E? File Edit “iew Project Debug XML Diff SourceControl Tools Window Help x
B2 aulhols.dﬂ|
B ':°|;_'=: T !-ll o|<? EntlEE] f.
] v |@ |file:.l’.fl\vv:.ftes‘ting.idiff_target.xml ||§||
=-*® surhors =-®% suthors A
=3 row Source document %3 row Target document
"Eﬂ <unchanged: "Eﬂ <unchanged:>
= au_lname = au_lname
Y Hennings o White
"E: <unchanged: "E: <unchanged:>
- = ™ city "# <unchanged:
- Menlo Fark =8 row
.'[: <unchanged: "[: <unchanged:>
=-®8 row +* =8 city
"Eﬂ <unchanged: Oakland
®® cunchanged:> ,CUI_'"S and symhols Ll = *" state
indicate the type of * en
difference detected
4 =" zip
+ 24618 7
\ Split Wiew - Tree f{‘ Split Wiew - Text }‘ Merged View .'f
For Help, press F1 UM

Figure 126. Example of Diffed Documents in the XML Diff Viewer

Customizable color-coding lets you quickly determine how one document differs from
another — green, for example, identifies objects (such as elements and attributes) that are
present in the target document, but which do not exist in the source document. When you
hover the pointer over symbols displayed in the side bars of the source and target
document windows, Stylus Studio displays atool tip that indicates the specific nature of
the change.

This section covers the following topics:

« “Sourcesand Targets’ on page 176

« “TheDiff Configuration File” on page 176

o “What Diffs Are Calculated?’ on page 176

o “Tuning the Diffing Algorithm” on page 177

o “When Doesthe Diff Run?’ on page 178
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o “Running the Diff Manually” on page 179
“Symbols and Background Colors’ on page 179

Sources and Targets

Tip

The

When you use Stylus Studio to diff documents (or folders), you select a source and a
target. Stylus Studio considersthe source document or folder to bethe baseline, or current
standard; the target document or folder is assumed to be some other version (it might be
older or newer, for example) of the source. The Stylus Studio Diff tool illustrates how this
other version, the target, differs from the source (or sources) you have selected.

You can open source and target documentsin the XML Editor from the XML Diff Viewer
—right click on the XML Diff Viewer background and select the document you want to
edit from the short-cut menu of source and target documents displayed by Stylus Studio.
Thisfeature is context-sensitive—if you right-click on anode that has been removed, the
target document will not be listed, for example.

Diff Configuration File

You can save the information associated with a given XML diff session in a diff
configuration file. Diff configuration files make it easy to perform a diff on the same set
of XML documents over time. Examples of the information saved with the diff
configuration file include the URL s of the source and target documents, and any settings
made on the XML Diff menu or tool bar. Diff configuration files are created with a .dff
extension.

Changes made to the source and target documents are detected by Stylus Studio the next
time you open the diff configuration file, allowing you to diff the files at that time.
(Whether or not the diff is run automatically when you open the diff configuration file
depends on Autorun Diff settings on the Engine page of the Options dialog box. See
“When Does the Diff Run?’ on page 178 for more information.)

What Diffs Are Calculated?

This section describes how Stylus Studio diffs XML documents and folders.

Documents — The Stylus Studio Diff engine compares source and target documentsin
their entirety. If you want, you can use the Engine page of the Options dialog box to
exclude certain items from the diff calculation. These itemsinclude:

o« Comments
o« Text

176

Stylus Studio® 2009 User Guide



Diffing Folders and XML Documents

. Entities
o Attributes
« Processing instructions

You can also specify whether or not you want Stylus Studio to:

« Use URIsto compare namespaces

« Expand entity references

« Ignore text formatting characters (new lines, carriage returns, and tabs)

See“Modifying Default Diff Settings’ on page 198 to learn how to set these and other diff
options.

Folders — Options for diffing XML documents do not affect how Stylus Studio diffs
folders. When diffing folders, Stylus Studio compares one folder’s contents with another.
See “Diffing Folders’ on page 180for more information on this topic.

Tuning the Diffing Algorithm

The purpose of any diffing tool is to identify the list of logical operations required to
change the source document into the target document. Examples of logical operations
include additions, revisions, and deletions. Even diffs between simple XML documents
canyield along list, sometimes with redundant operations. Ideally, the list of operations
should be reduced to make it as economical as possible; that is, the list should be ableto
answer the question, What are the fewest number of changes required to turn the source
into the target?

Calculating such alist can be time-consuming and resource intensive, and these costs
might not be worth the benefits to a given user. For this reason, Stylus Studio provides
settings that |et you tune the diffing algorithm used by the XML Diff engine. Tuning
settings are displayed in the Performance group box on the Engine page of the Options
dialog box.

Performance

(®) Autodetect () Optimize change descripion () Optimize calculation time

Optimize for large documents with few changes

Figure 127. Performance Settings Let You Tune the Diffing Algorithm
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You can

« Select atuning that optimizes the a gorithm to provide the most economical set of
changes possible (Optimize change description). As described earlier, this
calculation, though it yields the best results, can be costly in terms of time and
processing resources.

« Select atuning that optimizes the algorithm to provide the set of changesin the
shortest time possible (Optimize calculation time).

o Let Stylus Studio decide (Autodetect). By default, Stylus Studio triesto provide the
most economical set of changes possible, but if it determines that processing
resources are limited or that the calculation will take too much time, it revertsto the
algorithm tuning that is optimized for speed.

Handling Large Documents

The Optimize for large documents with few changes setting helps speed the diffing of
large (greater than 1M B) documents. This setting can be used in conjunction with any of
the algorithm tuning settings and is on by default.

When Does the Diff Run?

Stylus Studio runs the diff automatically, as soon as you specify the target document or
folder. Whether or not subsequent changes cause Stylus Studio to automatically
recalculate the diff is determined by the Autorun Diff settings on the Engine page of the
Options dialog box. Changesthat can make a diff recal culation necessary include adding
new source and target documents, changing the underlying source and target documents
themselves, or to changes to certain Engine settings.

Options That Affect When the Diff Runs

These settings, on the Engine page of the Options dialog box, determine when and
whether Stylus Studio automatically recal culates the diff.

« On changes — Certain types of changes to the diff configuration file require Stylus
Studio to recalculate the diff. These changesinclude:

= Adding anew source document

= Changing the target document

= Changing the Use URI to compare namespaces Setting
» Changing the Expand entity references setting
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If the On changes setting ison, Stylus Studio automatically runsthe diff when any of
these changes occurs.

« Iffiles modified —If you make and save changesto asource or target document, Stylus
Studio automatically runs the diff if this setting ison.

Note These settings do not affect the diffing of folders.

See “Moadifying Default Diff Settings” on page 198to |earn more about setting these and
other Diff options.

Running the Diff Manually

You can run the diff manually by clicking the Calculate diff button (| b ). Stylus Studio
activates this button when it detects the need to recalculate the diff, and the On changes
or If files modified settings are off. These settings, as described in “When Does the Diff
Run?’ on page 178, cause Stylus Studio to run the diff automatically.

You can also run the diff from the command line. See “Running the Diff Tool from the
Command Line” on page 202.

Symbols and Background Colors

Stylus Studio uses symbols and background colors to alert you to differences in diffed
documents and folders. The following table summarizes the symbols and default
background colors, and the types of changes they represent.

Table 16. Default Colors Used for Diffing Files and Folders

Symbol Background Color | Identifies

Light green Added items; appears in the target document and
identifies an item that is present in the target but
absent from the source

|E| Light red Removed items; appears in the source document and
identifies an item that is present in the source but
absent from the target.

Light yellow Changed items; can appear in both source and target
documents.

|:| Light gray Collapsed item containing changes (such as an added,

changed, or removed node).

Stylus Studio® 2009 User Guide 179



Editing and Querying XML

Tip

You can change the background colors on the Presentation page of the Options dialog
box.

Combined Symbols

Asdescribed in Table 16, Default Colors Used for Diffing Files and Folders,, Stylus
Studio displays aturquoise block (| 1) when anode that you have collapsed contains
changes. Sometimes, the nodeitself haschanges. In thiscase, Stylus Studio combinestwo
symbols — one indicating the change of a child within the collapsed node, and one to the
node itself. Consider the following illustration:

|E + 8 cicy
Figure 128. Sample of a Collapsed Node with Changes

Here, the city node displays a combined symbol — the turquoise box indicates that a
change exists within the collapsed node; the minus sign indicatesthat the city nodeisnot
present in the source document. Expanding the city node makes the scope and nature of
the changes explicit:

- - "R ity
— Menlo Park

Figure 129. Expanded Node with Changes

Hover the mouse point over these symbols to display tool tips that describe the nature of
the change.

Additional Symbols for Diffing Multiple Sources

Stylus Studio uses other symbolsin the target document window when you diff multiple
source documents. See “ Symbols Used in the Target Document Window” on page 194.

Diffing Folders

Stylus Studio alows you to diff two folders. As shown in Figure 130, the Diff Folders
dialog box displays the contents of each folder; symbols and colors, described in
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“Symbols and Background Colors’ on page 179, identify the types of changesin the
respective folders.

Diff Folders X
Source falder: Target folder:
|fi|e:#z’c “Program FileshStylus Studio®<MLdIF [ |fi|e:f’x’c:\DeveIop><ML =
=7 file: ¢ /Program Files/Stylus Studio =ML =7 flesd e /D evelop<ML
[0 authors. dff [ authors.df
B [ authars_rew.sml 0 [ authors_mods. sl
N [ authars_old.xml N [ authors_cld.aml
[ diff_source.xml ] [ boakstore.ded
j diff_sourcel sl =" D bookstorelliagram.xsd
[ diff_sourceZ. uml [ diff_source.sml
j diff_target. xml D diff_sourcel .xml
- [ doc.sml [ diff_source2.sml
- [ doc2.sml [ diff_target sml
- [0 docs_ diff dff
- [ report.sml
<> Splitter
< ¥
Show fils of type: Filter for file type
A1l Files () o

| DifFiles |
Figure 130. The Diff Folders Dialog Box After a Diff

This section covers the following topics:

« “Features’ on page 181

« “How to Diff Folders’ on page 182

« “How to Diff Documents from the Diff Folders Dialog Box” on page 184

Features
The Diff Folders dialog box has several features that make it easy to diff folders and the
XML documents they contain:

« A gsplitter letsyou change the width of the source and target folder windows. Thiscan
be especialy useful if you are working with afolder that has nested directories.

o Afiletypefilter limitsthe display to fileswith a .xm1 extension; if you choose, you
can display (and diff) all file types, as shownin Figure 130.

« An Abort button, shown here, appears at the bottom of the Diff Folders dialog box if
the operation you are performing (loading or diffing a directory with alarge number
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of files, for example) is taking more time than usual. Clicking the Abort button
cancels the operation.

Shaws files of type:

|Loading zource folders tree. .. Ahbort
Figure 131. Abort Button Lets You Cancel Long Load Operations

Tip Thisfeatureis aso part of the XML Diff Viewer.

« The Diff Files button allows you to perform a diff of XML documents in the source
and target folders. See “How to Diff Documents from the Diff Folders Dialog Box”
on page 184for more information on this topic.

How to Diff Folders

O To diff folders:

1. Select Tools > Show Differences In > Folders from the Stylus Studio menu.
The Diff Folders dialog box appears.

Diff Folders X
Source folder: Target folder.
| =1ji of
/
Choose Folder buttons
Show files of type:
ML Files (*.sml] v |
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2. Click the Choose Source Folder button (g).
The Select Source Folder dialog box appears.

Select Source Folder

Desktop Open |
8
My Camputer

“webDAY Server

FTP Server

3. Expand the Desktop tree and navigate to the folder you want to use as the source
folder for the diff.

4. Click Open.
Thefolder is displayed in the Source folder window of the Diff Folders dialog box.

5. Repeat Step 2 through Step 4 for the target folder.
Stylus Studio performs the diff as soon as you select the target folder for comparison.
6. Optionally, usethe Show files of type drop-down list to filter the display to show only

thosefiles of the type you specify. (By default, Stylus Studio shows XML files—files
with a .xm1 extension.)
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How to Diff Documents from the Diff Folders Dialog Box
You can diff XML documents in the source and target folders directly from the Diff
Folders dialog box.
0 To diff two files from the Diff Folders dialog box:

1. Click thefile you want to diff.

The document is shown as selected in both the Source folder and Target folder
windows. In thisillustration, the document authors_new.xm1 was selected.

Diff Folders

Source falder: Target folder:

|fi\e:./'x’c:\Program FileghStylus Studiot>kLdiff g |Ii|e:z’x’c:\Deve\op><ML g
=7 file:/ e Program Files/Stylus Studio/=L =[] file: e ADevelopstL
[ authors.dif 01 authors. dif
~ [ e N [ authars_mads.sml
S [ authors_old.xml N [ authars_ld.sml
[ diff_source.xml & [] bookstare.did
Tip Noticethat, even though thefile names are different, Stylus Studio isabletoinfer that

authors_new.xm1 and authors_mods.xm1 are actually the same document.

If you select a document that cannot be diffed, you will not see the selection in the
opposite window.

2. Click the Diff Files button.
Stylus Studio displays the XML Diff Viewer window.

For more information on diffing documents, see “ Diffing a Pair of XML Documents’ on
page 191.

The XML Diff Viewer

Thissection describesthe XML Diff Viewer and itsfeatures, including the different views
available for comparing documents, the XML Diff Viewer tool bar, and tools for loading

documents.

This section covers the following topics:
“Split View - Tree” on page 185
“Split View - Text” on page 186
“Merged View” on page 187
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“View Symbols and Colors’ on page 188
« “The XML Diff Viewer Tool Bar” on page 188
« “Toolsfor Working with Documents’ on page 191

Split View - Tree

You use the XML Diff Viewer to compare two or more XML documents. By default, the
XML Diff Viewer displays the diffed documents on the Split View - Tree tab. This view,
shown in Figure 132, shows the documents side-by-side using a tree/node representation.

@ Stylus Studio XML Enterprise Edition - [authors.dff] =1
AP File Edit Wiew Project Debug XML Diff SourceControl Tools Window Help x
- Buttons for adding and
£2 a“‘h"“‘-d"| removing documents
ull | @ | file: fifc: jprogram files/zonicsoftwaresstylus studiofexamplesidiff_target > @.
= "g:a‘;t.rl'xoo‘:s Source = "g.a[:t.rl';a‘:s Target ~
'[: <unchanged: "[: <unchanged:>
=™ au_lname =-®T§ au_lname
oy Hennings . White
.'II= <unchanged:> "II= <unchanged:>
- =-™8 city "% <unchanged:
= Menlo Park =-®*® row
'II: <unchanged:> Split‘ter ] "II: <unchanged:>
=% row +* =-™§ city
" cunchanged:> Ll Oakland
"% <unchanged:> +* =% state
& Ci
+ =8 zip
£ 94618
& =-*® contract -
\ Split Wiew - Tree A Split Wiew - Text }‘ Merged View ./
Status bar
For Help, press F1 UM

Figure 132. XML Diff Viewer — Split View - Tree

Insplit views (thereisalso asplit view that shows documentsin XML), source documents
are displayed on the left, the target document on the right. A splitter between the two
panes allows you to change the width of the source and target document panes by
dragging the splitter to the left and right.
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Split View - Text

The Split View - Text tab also shows source and target documents side-by-sidein plain

XML.

Stylus Studio - [authors.dff]
_Ff'J File Edit “iew Project Debug XML Diff SourceControl Tools Window Help

_FPJ authors. dff |

!-|| o|<?|Ent|E|3

f.

E[%]wr
1l

<?xml version="1.0" encoding="UTF-8" A
<authors> ¥ |
= o
€au 1d=lTZ2-32-1176</au id=

<?xml wversion="1.0" encoding="UTF-2'~a
<authors> ¥ |
o
<au 1d»l72-32-1176</au id=

N <au_lname>Hennings</au lname! N, <au_lname>White</au lname> —
<au fname=Johnson</au fname> <au_ frname>Johnson</au frname:
<phone>408 496-722Z23</phone> <phone>408 496-72Z3</phonex
<address»10932 Bigge Rd.</ad <address»10932 Bigge Rd.</ac

Il “city»Menlo Park</ it
<state>CA</state> <state>CA</state>
<zipx94025</ zip> <zipx94025</ z1ip>
<contractrtrue</contracts <contractrtrued/contracts

</ o </ ow
L O r O
<au 1d=Z13-46-8915</au_ id= <au 1d>213-46-8915</ a0 1d>
[ (R R — [ [ S —
< | > < | >
;‘ Split View - Tree }\ Split iew - Text ‘/{ Merged Yiew /
For Help, press F1 UM

Figure 133. XML Diff Viewer — Split View - Text
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Merged View

If you prefer, you can select the Merged View tab, which folds the nodes from the source
and target documentsinto a single window, as shown in Figure 134.

EEX
B9 File Edit Wiew Project Debug XML Diff SourceControl Tools Window Help X

[ aulhors.dﬂ|

o |<?|Ent| £,

i @| file: fffc: jorogram files/zonicsoftwareistylus studiofexamplesidiff_tarm |@|

= ™5 authors \\

BmE oy Add and remove source files

Ll
'[: <unchanged:
=™ au_lname
- a=
"3 <unchanged:>
S t}:;nlu iy Red for removed items...

Yellow for changed items...

"1 <unchanged:>
=-® row
"3 <unchanged:>
B cicy And green for new items
Oakland
=-™8 state
cL

plit Wiew - Tree }\ Splitigw - Text }\ Merged View ./

w4 g g g

For Help, press F1

MM

Figure 134. XML Diff Viewer — Merged View

The merged view displays changed itemsin pairs — the item from the target document
appearsfirst, the item from the source document is shown second, as shown in Figure 135.

=™ authors
=-*® row
.'[: <unchanged’- .
o %® au lname |~ Item in target document

R White //

Heabhihos  ——|tem in source document

Figure 135. Close-up of Merged View

In this example, the line through the <au_1name> element in the source document,
Hennings, indicates that it has changed to white in the target document.
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View Symbols and Colors

All views use the same symbols and color schemes to identify the types of changes
detected by the Stylus Studio diff calculation — by default, green for added items, yellow
for changed items, and red for removed items. In addition, the text font and size are
controlled by the settings for the XML Editor on the Editor Format page of the Options
dialog box.

See “ Symbols and Background Colors” on page 179 for more information on thistopic,
and to learn how you can assign custom colors to the results of standard differencing
operations.

The XML Diff Viewer Tool Bar

The XML Diff Viewer tool bar, shown in Figure 136, provides toolsto help you

o Manually start the diff calculation

« Navigate source and target documents

« Change default display and diff settings

« Show or ignore differences in document items such as text nodes and attributes

FEl authors.dif |

y o B (8| 5| o [<?|ent]em| £

Figure 136. The XML Diff Tool Bar

-0 =0
= | Be

The following table identifies the individual tools and tells you where to find more
information.

Table 17. XML Diff Tool Bar Buttons

Tool Button Description

Calculatesthe differencesin the documents you have selected. Thisbuttonis
active only when Stylus Studio detects the need to calcul ate differences. This
button is disabled if you have selected On changes and If files modified
settings. See “Engine Settings’ on page 200.

Skips to the next (previous) diff in the currently selected document. You
must select aline in the document to enable these buttons.
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Table 17. XML Diff Tool Bar Buttons

Tool Button Description

By default, Stylus Studio displays collapsed documents when the diff isrun.
You can override this setting using the tool bar button, or you can change it
permanently on the Options. page. See “Engine Settings’ on page 200.

2l By default, Stylus Studio collapses any unchanged blocks to smplify the
display. You can override this setting using the tool bar button, or you can
change it permanently on the Options. page. See “Engine Settings’ on
page 200.

= By default, Stylus Studio uses URIsto compare namespaces when diffing
documents. You can override this setting using thetool bar button, or you can
change it permanently on the Options. page. See “Engine Settings’ on
page 200.

Note that changing this setting requires documents to be diffed again.

ol By default, Stylus Studio expands entity references when diffing documents.
You can override this setting using the tool bar button, or you can change it
permanently on the Options. page. See “Engine Settings’ on page 200.

Note that changing this setting requires documentsto be diffed again.

T By default, Stylus Studio considers text formatting characters (new lines,
carriage returns, tabs) when diffing documents. You can override this setting
using the tool bar button, or you can change it permanently on the Options.
page. See “Engine Settings’ on page 200.

I By default Stylus Studio shows differences in comments. You can override
this setting using the tool bar button, or you can changeit permanently onthe
Options. page. See “Engine Settings” on page 200.

Note that this feature affects only the display, and not the cal culation, of
comment differences.

£ By default Stylus Studio shows differencesin text blocks. You can override
this setting using the tool bar button, or you can changeit permanently onthe
Options. page. See “Engine Settings” on page 200.

Notethat thisfeature affects only the display, and not the calculation, of text
block differences.
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Table 17. XML Diff Tool Bar Buttons

Tool Button Description

¢ By default Stylus Studio shows differences in attributes. You can override
this setting using the tool bar button, or you can changeit permanently onthe
Options. page. See “Engine Settings’” on page 200.

Note that this feature affects only the display, and not the calculation, of
attribute differences.

=7 By default Stylus Studio shows differences in processing instructions. You
can override this setting using the tool bar button, or you can change it
permanently on the Options page. See “ Engine Settings” on page 200.

Note that this feature affects only the display, and not the cal culation, of
processing instruction differences.

Ent By default Stylus Studio shows differencesin entities. You can override this
setting using the tool bar button, or you can change it permanently on the
Options page. See “Engine Settings’ on page 200.

Note that this feature affects only the display, and not the calculation, of
entity differences.

By default Stylus Studio shows differences in entity references. You can
override this setting using the tool bar button, or you can change it
permanently on the Options page. See “ Engine Settings” on page 200.

Note that this feature affects only the display, and not the calculation, of
entity differences.

Allows you to change the font of documents displayed in the XML Diff
Viewer.
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Tools for Working with Documents

The XML Diff Viewer provides several tools for working with source and target
documents:

« Add/Remove document buttons. When you click the add or set document button,
Stylus Studio displays the Open diaog box. The add button for source documents
displaysagreen plussignonit () to alert you to the fact that you can add multiple
source documentswhen diffing XML documents. You can specify only asingletarget
document, however.

You use the remove button, the fol der with the red minus sign on it ([(=1]), to remove
the current source document from the XML diff calculation.

Tip If Stylus Studio determinesthat theload or diff operation for agiven XML document
will take more than amoment, it displays a message and an Abort button at the
bottom of the XML Diff Viewer window. You can click the Abort button to terminate
the operation at any time. The message and the button are removed from the XML
Diff Viewer window once the operation is complete or cancelled.

« Drop-down list. You use the drop-down list to change the current document in the
XML Diff Viewer. When you change the current doc in a multi-document diff, the
target document display — specifically, the symbols and colors used to identify
documents—typically changes, aswell. See“ Symbols Used in the Target Document
Window” on page 194 for more information.

Removing a Target Document

You cannot remove atarget document. You can specify a different target document by
clicking the set target button (|(=]) again. This replaces the current target document with
the document you select.

Diffing a Pair of XML Documents
This section describes how to use Stylus Studio to diff apair of XML documents.

Before continuing with this section, you should read “ Overview” on page 175, which
describes basi ¢ information about the Stylus Studio Diff tool, and “ The XML Diff
Viewer” on page 184, which describes features of the XML Diff Viewer and how to use
them.
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How to Diff a Pair of Documents

0 To diff a pair of documents:

Tip

1.

Select Tools > Options > Show Differences > Files from the Stylus Studio menu.
Stylus Studio displays the XML Diff Viewer.

In the source document window, click the add button () to add the source
document.

Stylus Studio displays the Open dialog box.

You can drag and drop afileinto the entry field to load the document in the XML Diff
Viewer.

Navigate to the document you want to load in the XML Diff Viewer.

Click Open.

Repeat Step 2 through Step 4 for the target document, using the set button for the
target document window ([)).

By default, Stylus Studio runs the diff calculation automatically when you select the
target document. If the default On changes setting has changed, you need to run the
diff calculation manually by clicking the Calculate diff button (| | ).
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Diffing Multiple Documents
This section describes how to use Stylus Studio to diff multiple XML documents.

Before continuing with this section, you should read “ Overview” on page 175, which
describes basi ¢ information about the Stylus Studio Diff tool, and “ The XML Diff
Viewer” on page 184, which describes features of the XML Diff Viewer and how to use
them.

This section covers the following topics:

“Document Focus’ on page 193
o “SymbolsUsed in the Target Document Window” on page 194

Document Focus

Diffing multiple XML documentsis much the same as diffing a pair of documents—you
specify the source documents (one at atime), atarget document, and Stylus Studio
calculates the diff.

Note When you diff multiple source documents against the target, Stylus Studio considersthe
target document to be the baseline, and the XML Diff Viewer shows how the source
documents vary from the target.
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When you diff multiple documents, however, only one source document can have focus
at atime. Consider the following illustration, which shows three source documents
(sourcel.xml, source2.xml, and source3.xm1) and atarget document (target.xm1).

(ﬂ

Figure 137. Example of Document Focus

In this example, the sourcel.xm1 document currently has focus. You set the focus on a
given source document by selecting that document from the drop-down list at the top of
the source document window.

When a source document has focus:

. Diffsaredisplayed for that document only, even if you have selected the Merged View
tab for display.

. Clicking the remove document button (|(=|) removes that document from the XML
diff calculation.

Symbols Used in the Target Document Window

When diffing multiple documents, Stylus Studio uses an additional set of symbolsin the
target document window. These symbols, which are displayed in the side bar of the XML
Diff Viewer window alongside the standard set of symbols described in “ Symbols and

Background Colors’ on page 179, indicate the ways in which the change identified in the
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current source document differs from changes to the same node in other source

documents.
Change relative file: ftfc: Program Files/Stylus StudioMMLdiftidiff_target xml @
to current target
and current source = .'[: authors Y

=- %" row

. + au id
Change in current source o

relative to other source =% au_lname
documents — '} =

+- au_fname

Figure 138. Example of Symbols Used When Diffing Multiple Documents

Asshown in Figure 138, symbolsin the column closest to the document tree identify the
changesrd ativeto the currently selected source. Here, the edit symbol () indicatesthat
the value in the target document, whi te, differs from that in the currently selected source
(which happens to be Black in this example).

Thefirst column of symbols characterize changesin the currently selected source relative
to other source documents. Here, for example, the red exclamation point ( 1) indicates
that there are conflicting modifications in other source documents — that is, other source
documents contain a value other than Black. As shown in Figure 139, when you click on
asymbol in the first column, Stylus Studio displays

« A message describing the precise nature of the change
« A menu that identifies the documents in which the change occurs.

file: fic: DevelopHMLIIF_target sxmi @

=T, authors -
=-®8 row
+ % au_id

+-®® address

Figure 139. Easily Navigate to Changed Nodes in Other Source Documents

Clicking on a document in this menu changes the current focus to that source document,
allowing you to easily navigate to the same node in a different document.

Stylus Studio® 2009 User Guide 195



Editing and Querying XML

The additional symbols used by Stylus Studio when diffing multiple documents are
described in Table 18.

Table 18. Symbols Used to Specify Changes in Source Documents

Symbol

Description

Meaning

A

Yellow circle

Modified in other documents — The abject in the target and
the current source document are the same, but another source
document is different.

Red exclamation
point

Conflicting modification in other documents—The object in
the current source differs from that in the target document.
Other source documents differ from both the current source
and target.

Yellow diamond

Same modification in other documents — The source
documents all differ from the target document in the same
way.

L1

Yellow equal sign

Unchanged in other documents — The current source
document differsfrom thetarget, but other source documents
are the same as the target.

Consider the example in Figure 140, which illustrates diffing three documents. In this
example, the node in question is circled in red.

Figure 140. Diffing Three Documents

196

Stylus Studio® 2009 User Guide




Diffing Folders and XML Documents

Notice that:

o sourcel.xml currently hasfocus.
« sourcel.xml and the target document node have the same value (<abc>)
« Thenodein question variesin both of the remaining source documents (it is<abc> in

one and <abc> in the other).

Table 19 shows the symbols that might appear based on changing valuesto the node in
guestion. The exampleillustrated in Figure 140 is shown in the first row. Asvaluesin the
source documents change, Stylus Studio changes the diff symbol accordingly.

Table 19. Symbols Used to Specify Changes in Source Documents

Symbol target.xml sourcel.xml source2.xml source3.xml
A <abc> <abc> <Xyz> <123>
! <abc> <Xyz> <jk1> <mno>
P <abc> <Xyz> <Xyz> <Xyz>
— <abc> <Xyz> <abc> <abc>

Note Changingthetarget-sourcepairing, that is, changing the current source document, affects

the symbols that are displayed.

How to Diff Multiple Documents

0 To diff multiple documents:

Tip

1. Select Tools > Options > Show Differences > Files from the Stylus Studio menu.
Stylus Studio displays the XML Diff Viewer.

2. Inthe source document window, click the add button () to add the first source
document.

Stylus Studio displays the Open diaog box.

You can drag and drop afileinto the entry field to load the document in the XML Diff
Viewer.

3. Navigate to the document you want to load in the XML Diff Viewer.
4. Click Open.
5. Repeat Step 2 through Step 4 for additional source documents.
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6. Repeat Step 2 through Step 4 for the target document, using the set button for the
target document window (|C1).
By default, Stylus Studio runs the diff calculation automatically when you select the
target document. If the default On changes setting has changed, you need to run the
diff calculation manually by clicking the Calculate diff button (| J= ).

Modifying Default Diff Settings

Default settings for the behavior of the Diff engine and the appearance of diffed
documents and folders are on the Engine and Presentation pages, respectively, of the
Options dialog box. The Engine page, shown here, has settings that determine the
conditions under which Stylus Studio runs the diff automatically, which itemsin a
document (comments and text, for example) you want the diff engine to ignore, and
settings that allow you to choose diffing algorithm tunings optimized for change
description or time, for example.

Options

B ack-mapping
Spell Checking
File Types
Java Virtual Maching
Custom Tools
Custom File Systems
Customn Document Wizards
Customn Validation Engines
Custom <ML Converters
i3 Module Settings
£ DBtoxML
Default Connection
3 Java
Debugger
(£33 %ML Diff
N
Presentation
£ %ML Editor
#ML Settings
3 %ML Schema E ditar
Diagram
ML Schema to XML
Documertation

-

by o

General
Autorun diff
[ Automatically expand al diffs On changes
Collapse unchanged blacks [11f fles madified
Engine Options
Uze URI to compare namespaces [ lgnore text farmatting characters
Expand entity references
Show differences in
Comments Attributes
Text Processing instructions
Entities Entitiy References
Perfarmance
(¥) Autodetect () Optimize change description () Dptimize calculation time
[ Optimize: for large documents with few changes

Figure 141. Engine Options Page for XML Diff
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Settings on the Engine page are reflected in the Diff editor tool bar, and in the XML Diff
menu, shown here.

il Stylus Studio - [authors.dff]

6 G ; 3 : "
F? File Edit VWiew Project Debug KML,PIFF SourceContral Tools Window Help

0= W) Add source document &

Remove source document
L] aulhors.d[[| Set target docurment
CAEIESESIal
| file: fifc: forocram filesfzonicsoftwareistylus igram filesfzoniceoftwareistylus studicexamplesidiftf_target xml |@|
=-®% authors [ Expand &l Differences authors =
=8 row [t} collapse identical blocks " row

"3 <unchanged:>

| "% <unchanged:
- au_lname

o Use LRI to
se L compare namespaceslk 5% au_lnewe

Expand Entity References

s Jefferson ) White
=2 cunchanged> TT Ignore text for matting "= cunchanged>
=-®8 row [1=] compare comments "3 row
"3 <unchanged:> Corpare Text "3 <unchanged:>
" <unchanged> Iz‘ Cornpare Attributes &M city
Cormpare Processing Instructions e Sl
state
i Compare Entities
T ci
=8 zip
* 94615 v
\ Split View {i Merged View /'
Instructs XML diff engine to use URIs to compare narmespaces. MU

Figure 142. XML Diff Menu

Tip YoucanoverrideEngine page settings using the Diff editor tool bar or the XML Diff menu.
Overrides do not change the settings on the Engine page.

This section covers the following topics:
“Opening the Options Dialog Box” on page 199
“Engine Settings’ on page 200
“Presentation Options’” on page 202

Opening the Options Dialog Box

0 To open the Options dialog box:

1. Click Tools > Options on the Stylus Studio menu.
The Options dialog box appears.

2. If necessary, expand the tree for Module Settings > XML Diff.
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3.
4.

Click the page that contains the settings you want to modify.

To save achanged setting, click OK. Click Cancel to revert to closethe dial og box and
revert to the previous settings.

Engine Settings

This section describes the settings that affect the behavior and performance of the Diff
engine.

General

Thefieldsin the General group box affect the initial display of diffed documents and the
conditions, if any, under which Stylus Studio runs the diff automatically.

Automatically expand all diffs — By default, Stylus Studio collapsesthe display of the
diffed documents. If you select this option, all nodes containing diffs are expanded
when the diff is run.

Collapse unchanged blocks — By default, Stylus Studio collapses any block that does
not contain any changesto save spacein the XML Diff Viewer window. These blocks
aredisplayed as <unchangeds> in the document tree. You might prefer to havetheentire
document structure visible, to provide context for changed nodes, for example.

Autorun diff — By default, Stylus Studio runs the diff operation if you make a change
to one of the settings on the Engine page of the Options dialog box. You can also
specify that Stylus Studio run the diff operation when the source or target documents
change. If you select If files modified, Stylus Studio runsthe diff operation when you
saveasourceor target file. If neither of these optionsis selected, you must run the diff
manually. See “When Doesthe Diff Run?’ on page 178 for more information on this
topic.

Engine Options

Thefieldsin the Engine Options group box affect how Stylus Studio diffs source and
target documents.

Use URI to compare namespaces — Controls whether or not URIs are used to
compare namespaces in source and target documents.

Expand entity references — Controls whether or not entity references, whichin some
cases can includefiles external to the source or target document, are expanded by the
Stylus Studio diff engine for purposes of comparing one block with another.
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« Ignore text formatting characters — Controls whether or not text formatting
characters (new line, carriage return, and tab) are ignored when comparing source and
target documents. This option is off by default.

« Show differences in — Provides granular control of what itemsin XML documents
are diffed. There are separate settings for comments, text, entities, attributes, and
processing instructions.

Performance

Diffing large, numerous, or complex documents can be time-consuming. Stylus Studio
provides controls that let you choose agorithm tunings that have been optimized for
change description or calculation time.

o Autodetect — Stylus Studio determines which algorithm tuning to use based on the
number, content, complexity, and size of the source and target documents. Stylus
Studio first tries to use the tuning that is optimized for change description; if it
determines that processing resources are limited, it reverts to the algorithm tuning
optimized for speed. This setting is on by defauilt.

« Optimize change description — Provides the most economical set of changes
possible. This calculation, though it yields the best results, can be costly in terms of
time and processing resources.

« Optimize calculation time — Provides the set of changesin the shortest time possible.

« Optimize for large documents with few changes — Helps speed the diffing of large
(greater than IMB) documents by folding similar blocks before comparing nodes.
This setting can be used in conjunction with any of the algorithm tuning settings and
ison by default.

Tip The default setting, Autodetect and Optimize for large documents with few changes,
yields the best results when time and processing resources are not considerations.
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Presentation Options

Presentation options allow you to modify the settings for the background colors Stylus
Studio uses to identify the types of changes detected in diffed documents and folders

Options ['S_<|

Back-mapping ,\ Added items
Spell Checking |
File Types
Java Virtual Maching
Custom Tools Removed items
Custom File Systems
Customn Document Wizards
Customn Validation Engines
Custom <ML Converters Changed items
I3 Module Settings
5 DBtoxmL Background colaor:
Default Connection
£ Java
Debugger
55 =ML Dift Background colar:
Engine

Background colar:

Background colar:

Collapzed items with changes

i 3 3 3

&
£ %ML Editor
#ML Settings
[ %ML Schema E ditor
Diagram
ML Schema to XML

Figure 143. You Can Change Colors Used to Identify Document Changes

You can change the background colors for the following:
o Addeditems

« Removeditems (that is, items that are present in the target, but are not present in the
source, for example)

« Changed items (the same element or attribute, but a different name, for example)
« Collapsed items with changes

Running the Diff Tool from the Command Line

In addition to using the Diff tool from the Stylus Studio user interface, Stylus Studio also
provides acommandl line utility, StylusDiff.exe. This command line utility allows you
to perform many of the same functions, and to use many of the same options, as the
graphical Diff toal.
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Restrictions

The following restrictions exist for using StylusDiff.exe:
« You cannot use StyTlusDiff.exe to diff folders
o StylusDiff.exe can diff only one pair of documents at atime

Usage

The stylusDi ff.exe utility has the following usage:

StylusDiff -source <sourceURI> -target <targetURI>
[-expandPrefixes/collapsePrefixes] [-expandERs/colTlapseERs]
[-comments/nocomments] [-attributes/noattributes] [-text/notext] [-pi/nopi]
[-er/noer] [-entities/noentities] [-formatting/noformatting] [-fold/nofold]

[-auto/best/fast]

Table 20 describes the usage for the Sty1usDiff command. For a complete description of
these and other options that affect the XML Diff engine, see “Engine Settings’ on

page 200.

Table 20. StylusDiff Command Line Parameters

Parameter

Description

-source <sourceURI>

The path of the XML document you want to use as the source
document in the diff. Required.

-target <targetURI>

The path of the XML document you want to use as the target
document in the diff. Required.

-output <outputURI>

Saves the differences between the source and target files, if
any, to the file you specify. Output files are saved with a . dff
extension. Optional.

-expandPrefixes Whether you want the XML Diff engine to use the URI

-collapsePrefixes (-expandPrefixes) or ignore the URI (-collapsePrefixes)
when comparing namespaces. The default is
-collapsePrefixes.

-expandERs Whether you want the XML Diff engine to compare entity

-collapseERs

references (-collapseERs) or values referenced by entity
references (-expandERs). The default is -expandERs.
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Table 20. StylusDiff Command Line Parameters

Parameter Description
-comments Whether you want the XML Diff engineto compare comments
-noComments

(-commments) or to ignore comments (-noComments). The
default is -comments.

-attributes

Whether you want the XML Diff engine to compare attributes

-noAttributes (-attributes) or to ignore attributes (-noAttributes). The
default is -attributes.

-text Whether you want the XML Diff engine to compare text

-noText (-text) or to ignore text (-noText). The default is -text.

-pi Whether you want the XML Diff engine to compare

~noPI processing instructions (-p1) or to ignore processing
instructions (-noPI). The default is -pi.

-er Whether you want the XML Diff engine to compare entity

~noER references (-er) or to ignore entity references (-nokR). The
default is -er.

-entities Whether you want the XML Diff engine to compare entities

-noEntities

(-entities) or to ignore entities (-noEntities). The default
is-entities.

-formatting
-noFormatting

Whether youwant the XML Diff engineto compareformatting
characters (-formatting) or to ignore formatting characters
(-noFormatting) when comparing text nodes. The default is
-formatting.

-fold Whether you want the XML Diff engineto fold similar blocks

-nofFold before diffing (-foldunchangedBlocks) or to expand and diff
nodes (-diffunchangedBlocks). The default is
-foldUnchangedBTocks.

-auto Controlsthat let you choose between diffing algorithm tunings

:?:i that have been optimized for time (-fast) and thoroughness (-

best). A third choice, -auto, lets Stylus Studio determine
which tuning to use. The default is -auto.
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Using Schemas with XML Documents

Stylus Studio allows you to associate one or more schemas with each XML document. A
schema can beaDTD or an XML Schema.

There are several ways to associate a schema with an XML document:

To associate an external schema with a document, ensure that an XML document is
active. Then, from the Stylus Studio menu bar, select XML > Associate XML with
Schema.

To define an internal DTD, specify itinthe XML editor Text tab or Schema tab.
To have Stylus Studio generate aschema, in the XML editor, click the Schema tab. If
the XML document has some contents, Stylus Studio promptsyou to indicate whether

you want Stylus Studio to generate a schema from the contents. See “Having Stylus
Studio Generate a Schema” on page 206.

This section discusses the following topics:

“Associating an External Schema With a Document” on page 205

“Having Stylus Studio Generate a Schema” on page 206

“Validating XML Documents’ on page 206

“Updating a Document’s Schema” on page 207

“Removing the Association Between a Document and a Schema” on page 207

Associating an External Schema With a Document

0 To associate an external schema with an XML document:

1.

4.

Open the XML document you want to associate with a schema. See “Opening Files
in Stylus Studio” on page 87.

From the Stylus Studio menu bar, select XML > Associate XML with Schema.

In the Open dialog box that appears, navigate to and select the schema you want to
associate.

Click Open. The selected schema is now associated with the document.

To associate an XML document with an XML Schema, the XML document must contain
aroot e ement.
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After you associate a schema with a document, you can view atree representation of the
schemain the XML editor window. Click the Schema tab. See “Updating a Document’s
Schema” on page 207.

Having Stylus Studio Generate a Schema

Inthe XML editor, you can click the Schema tab to view the schema for your document.
If your document does not specify a schema, Stylus Studio displays the Schema Not
Found dialog box. This dialog box prompts you to indicate whether you want Stylus
Studio to create a schema for your document based on its contents.

You can select Generate XML Schema or Generate DTD. If you select Generate XML
Schema, you must specify an absolute path for the file that contains the new schema.

If you select Generate DTD, you must indicate whether you want the DTD to be internal
or external. If itisinternal, Stylus Studio insertsitimmediately after the XML declaration.
If it isexternal, you must specify or select an absolute path for the file that contains the
new DTD.

After you click OK, Stylus Studio displays the new schemain the Schema tab.

Validating XML Documents

Note

At any time, you can validate your XML document against its schema. Click Validate
Document in the window of the document you want to validate.

Stylus Studio displays a message that indicates whether or not your document isvalid. If
your document does not conform to its schema, Stylus Studio displays alist of error
messages that describe the inconsistencies. Thislist includes line and column numbers
that indicate the location of the error. When you click inan XML document, Stylus Studio
showstheline and column number in the bottom right corner of the Stylus Studio window.

When Stylus Studio validates a document, it also checks for well-formedness.

Stylus Studio uses font color to indicate valid and invalid element names. Purple fonts
indicate valid elements. Orange fonts indicate el ements that are not in the schema.

Stylus Studio uses Apache's Xerces XML Parser to validate XML documents. Error
messages about invalid documents are generated by the Xerces XML Parser. Stylus
Studio has no control over the contents of these messages. If you have trouble
understanding such a message, try searching the W3C XML Schema Recommendation
for the main phrase in the error message.
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Updating a Document’'s Schema

How you update your document’s schema depends on whether the schemaisinternal or
external. If the schemaisan internal DTD, you can update it in the Schema tab of the
XML editor.

If the schemaisnot aninternal DTD, you can updateit only inthe DTD editor or the XML
Schema editor. You can, however, view the schemain the Schema tab of the XML editor.

When Stylus Studio displays the schemafor your document, you can also view the
properties for each node in the schema. If the Properties window isnot already in view,
select View > Properties. Click on any node in the schema view to see the properties for
that node.

To view the text of an externa schema or to edit an external schema, you must display it
inthe DTD editor or the XML Schema editor. To do this, select XML > Open Associated
Schema from the Stylus Studio menu bar, or click Open Schema &%, inthe Stylus Studio
tool bar.

Instructions for updating aDTD arein “Defining Document Type Definitions” on

page 651. Instructionsfor updating an XML Schemaarein “Creating an XML Schemain
Stylus Studio” on page 556. If you update a schemain Stylus Studio and that schemais
associated with an XML document that is open in Stylus Studio, Stylus Studio refreshes
the schema information for the open XML document.

Removing the Association Between a Document and a Schema

To remove the associ ation between adocument and an external schema, you must edit the
XML document in the Text or Tree tab. Remove the text or nodesthat specify the external
schema.

To remove an internal DTD from a document, delete the text or nodes that specify the
internal DTD.
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Converting XML to Its Canonical Form

By default, Stylus Studio creates XML that conforms to the W3C XML 1.0
recommendation. You can also convert any XML document to its canonical form. When
you convert XML to its canonical form, the resulting document conforms to the W3C
Canonical XML 1.0 recommendation.

Tip Although you can undo conversion to canonical form, consider using Save As to create
acopy of the XML document prior to conversion.

0 To convert an XML document to its canonical form:
1. Openthe XML document you want to convert to canonical XML.

2. Select Edit > Make Canonical XML from the Stylus Studio menu.
Alternative: Click the Make Canonical XML button ([4]) on the tool bar.
The XML document is converted to its canonical form.

You can undo this operation (Edit > Undo) if necessary.

Querying XML Documents Using XPath

You can usethe XML Path Language (X Path) to query XML documentsto obtain asubset
of theinformation in that document. You can also query XML Schemaand XSLT,
provided you open the XSLT using the XML Editor. (You cannot query DTD schema
becauseit isnot XML.)

In Stylus Studio, you query XML documents using the X Path Query Editor. To learn more
about X Path and how to use the X Path Query Editor, see“Writing X Path Expressions’ on
page 677.

Printing XML Documents

You can print the raw XML text view of your document. You cannot print the other views
of your document.

0 To print a document:
1. Inyour XML document, click the Text tab.
2. Inthe Stylus Studio tool bar, click Print or press Ctrl+P.
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0 To preview your document before you print it, select File > Print Preview from the
Stylus Studio menu bar.

0 To specify print options for your document before you print it, select File > Print
Setup from the Stylus Studio menu bar.

Saving XML Documents

When you save adocument, Stylus Studio savesit in the encoding that is specified in the
initial XML processing instruction.

0 To save an XML document:
1. Ensure that the window that contains your XML document is the active window.

2. From the Stylus Studio menu bar, select File > Save.
Alternatives. Press Ctrl+Sor click Save in the Stylus Studio tool bar.

Options for Saving Documents

TheApplication Settings page of the Options dialog box contains two optionsthat affect
when and how documents are saved in Stylus Studio. You can choose to have Stylus
Studio

« Save modified documents every few minutes. This option is off by default, and has a
default setting of 10 minutes.

« Create abackup copy of adocument wheniit is saved.

More About Backup Files

Backup copies are created with a* .bak extension appended to the original document
name when saved to the Stylus Studio file system. For example, the backup copy of
books .xm1 would be books .xm1.bak. If you are saving to an external file system (such as
Raining Data® TigerLogic® XDMS), the file system manages the backup file name.

Backup files are written to the same file system as the original document. They are not

displayed in the Project window, and they appear in the File Explorer window only if you
change the filter to display * .bak files.
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Opening a Backup File
You can open a backup file

« FromtheFile Explorer window, by double-clicking the file name or selecting Open
or Open With from the file's shortcut menu, for example

« From the Project window, by selecting the file and then selecting either
0 Open Latest Backup from thefile's shortcut menu (right-click to display), or
0 Project > Open Document’s Latest Backup from the Stylus Studio menu
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{f"ﬁ DataDirect XML Converters™ and custom XML conversions are available only
in Stylus Studio XML Enterprise Suite.

Stylus Studio uses DataDirect XML Converters™ to convert incoming streams of data
from native formats to outgoing streams of XML, and vice-versa. XML Converters™
support standard file formats, including EDI, CSV, binary, and many others. XML
Converters al so support the conversion of custom or proprietary formats that you specify
using a custom XML conversion definition.

This chapter describes how to use DataDirect XML Converters to convert standard and
proprietary filesto XML in Stylus Studio, how to create your own custom XML
conversion definitions, and how to use files you convert on-the-fly elsewherein Stylus
Studio —as asource for XQuery and XSLT design, for example.

Watch it! You can view a video demonstration of this feature by clicking the
television icon or by clicking this link: watch the Introduction to the Custom XML
Conversions module video.

You can read about other video demonstrationsfor the custom XML conversion definition
module here: http://www.stylusstudio.com/Tearn_convert_to_xml.html#converttoxml.

A complete list of al the videos demonstrating Stylus Studio’s featuresis here:
http://www.stylusstudio.com/xml_videos.html.

This chapter covers the following topics:

« “Introduction” on page 212

o “Custom XML Conversions’ on page 219

« “Creating a Custom XML Conversion Definition” on page 220
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o “The Custom XML Conversion Definition Editor” on page 223

o “Partsof an Input File" on page 234

« “Working with Regions’ on page 236

o “Working with Fields’ on page 245

o “Controlling XML Output” on page 253

o “Using Custom XML Conversion Definitionsin Stylus Studio” on page 264
o “The Converter URI Scheme” on page 267

« “Working with EDI Conversions’ on page 274

« “Custom XML Conversion Definitions Properties Reference” on page 278

Introduction

DataDirect XML Converters are high-performance Javaand .NET components that
provide bi-directional, programmatic accessto virtually any non-XML fileincluding EDI,
flat files, and other legacy and proprietary formats. DataDirect XML Converters allow
developers to seamlessly stream any non-XML data as XML to industry-leading XML
processing components or to any application. They support StAX, SAX, XmlReader,
XmlWriter, DOM and I/O streaming interfaces, and can be embedded directly for
tranglation purposes, or as part of achain of programsincluding XSLT and XQuery, or
even inside XML pipelines. DataDirect XML Converters maximize developer
productivity and provide afast, scalable solution for converting between EDI and other
legacy formats and XML.

How XML Converters are Used in Stylus Studio

The DataDirect XML Converters conversion engine is used throughout Stylus Studio to

convert non-XML filesto XML and vice-versa. You can access DataDirect XML

Converters:

« When you open and save files

o Inthe EDI to XML module (see Chapter 4 “Converting EDI to XML"” for more
information on this module)

o As XML pipeline ConvertToXML and ConvertFromXML nodes (see Chapter 14
“Building XML Pipelines’ for more information)

« Using the converter:URI scheme
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Example

When you open or save afile in Stylus Studio, you have the option of converting that file
to or from XML using DataDirect XML Converters, as shown in the following

illustration:
Open @g|
'\@ Look i | (] testing iy 1 =g FE”E”
My Eio-mjputer E] autormap_command. bt @ bikes_fied_ansi tat i
E bar.jpg E] bikes fiwed_new_line.tst E]
@ R barmjpg [Z] bikes_fixed_nao_end_space.tst
W_E.[TQV batch. sl @ bikes_fiwed_wariable_row.txt
= e batch.xsd @ bikes_header_fixed.txt
Eg@ [Z] bikes.tst [Z] bikes_region.tst
— E] bikes_comma.txt @ bikes_space.tut J
Secure WebDAY [Z] bikes_component.txt [Z] bikes_tab.tat =
@ [Z] bikes_components. et [Z] bikes_toss.tat &
L E] bikes_delimited et books. small =ml @
[ErfF r% bikes_fixed.tat baoks. small. xml.bak ,Q]
£ >
TigerLogic XDMS  JRL: bikes_region. bt
% Files of tvpe: | Al Fles (7]
Froject Files pen uzing #ML Converter g >

Figure 144. Open Using XML Converters Check Box

In the Open dialog box and elsewhere in Stylus Studio, you can choose an XML
Converter for a

« Specificfileformat (likeEDI, CSV, dBase, or RTF, for example). See*“ Typesof XML

Converters’ on page 214 for a complete list of standard files supported by the XML
Converters.

« Custom file definition created using the Stylus Studio Custom XML Conversion
Definition Editor. You can create custom XML conversion definitions to handle

proprietary file formats or extensions to formats already supported by DataDirect
XML Converters™.

XML Converters Run-Time Components

DataDirect XML Converters are also available as a standal one run-time component on
both Java™ and .NET platforms. DataDirect XML Converters are bundled with Stylus
Studio 2009 XML Enterprise Suite.
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This chapter describes how to use DataDirect XML Convertersin Stylus Studio. Tolearn
about the DataDirect XML Converters standal one components for Javaand .NET, seethe
DataDirect XML Converters documentation at http://www.xmlconverters.com/doc/.

Other Ways to Convert Files to XML

In addition to using XML Converters, you can convert filesto XML using Stylus Studio
document wizards — Stylus Studio document wizards help you convert XML Schema,
DTD, and HTML to XML. See“Using Document Wizardsto Create XML" on page 137
for more information.

Types of XML Converters

DataDirect XML Converters support numerous file formats, as shown in the following
table.

Table 21. Types of Files Handled by XML Converters

File Type Description

Base-64 Converts any file, text or binary (such asan image), into a
XML document with asingle element containing the Base-64
encoded content of the input file.

Binary Similar to the Base-64 XML Converter, except with
hexadecimal output. Other options allow output in other
bases, such as decimal or octal or even binary.

Comma-separated Converter for comma-separated values (CSV) files. Supports
value (CSV) multiple encodings and options to tune the quote and escape
characters. Supports delimiters besides commas.

Custom Custom or proprietary file formats described using a Stylus
Studio custom XML conversion definition.

dBase Support for dBase 1, I11, 111+, IV, and V formats.

Data Interchange Data Interchange Format (DIF) is a spreadsheet-based file

Format (DIF) format. There are also XML Convertersfor SDI and SY LK.

DotD Support for Progress Software's OpenEdge text dump file
format.
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Table 21. Types of Files Handled by XML Converters

File Type Description

EDI Automatically detects and parses ATIS, EANCOM,
EDIFACT, Edig@s, HIPAA, HL7, IATA, NCPDP,
TRADACOMS, and X12 EDI messagetypes, with optionsfor
custom message types and message extensions to cover
proprietary EDI-based formats.

JavaProps Support for Java .properties file format, which are used for
program configuration, translation, and data storage.

JSON Uses the algorithms on the JSON.org website to read from
XML and write to JSON (JavaScript Object Notation), and
vice-versa

Line Readsin text one line at atime, wrapping an element around
each line and escaping any embedded & or > or < symbols.

Pyx Support for this line-oriented notation for expressing tree-
oriented data.

RTF Convertsrich-text format (RTF) into XML, and vice versa.

SDI Super DataInterchange (SDI) is another popular spreadsheet-
based fileformat. Therearealso XML Convertersfor DIF and
SYLK.

SYLK SYLK (Symbolic Link) isanother popular spreadsheet-based
file format. There are also XML Convertersfor DIF and SDI.

TAB Tab-separated values format commonly associated with MS
Excel spreadshests.

Winlni Converter for Windows .ini configuration files.

WinWrite Converter for Microsoft WinWrite files; renders XHTML.
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XML Converters Can Be Configured

Each of the DataDirect XML Converters has numerous properties that allow you to
configure the converter to suit your needs, like those for the EDI XML Converters shown

here:
Select XML Converter E|
B —
Hi| BaseBd encoding of a binary file a: A Property Walue e

:3 Comma-Separated Yalues [C5W) Line g#farator cilf
B Customn XML Corversion oding e
:a Drata Interchange Format [DIF) wtension map file
| dBaze |l [dBase_ll) Enable validation ves
] dBase Il (dBase_Ill) Comment code list data yes
@] dBase lll+ [Base ll_phis) Comment element types yes
| dBaz= IV [dBase_IV) Strict validation on valug leng... | no
Strict segment-ordering chec... | yes

) dBaseV [dBaze V)
]k refint orce eror if value notin cod... | pes

lectanic D ata |nterchange [EDI) datatype content chec...

»
5

Add linefeeds between seqmm.

URL: ‘ converter: ED| Hile:/ v \estinghbikes_region. txt

[ 0K ] [ Cancel ]

Figure 145. Select XML Converter Dialog Box

Some XML Converters, for example, let you specify the line separator character, escape
character, root element name, and other aspects of the output format.

See Chapter 4, XML Converters™ Properties, in the DataDirect XML Converters™

User’'s Guide and Reference for more information. Documentation for DataDirect XML

Converters™ isavailable:

o Inthe\doc folder for DataDirect XML Converters where you installed Stylus Studio
—\components\XML Converters for .NET\doc, for example

« OntheDataDirect XML Converters™ web site: http://www.xmlconverters.com/doc/
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Using XML Converters to Open a Non-XML File as XML

0 To open anon-XML file as XML using XML Converters:

1.

Select File > Open from the Stylus Studio menu.
Stylus Studio displays the Open diaog box.

Navigate the file system that contains the file you want to open as XML. If necessary,
change the value in the Files of type field to filter the files that are displayed.

Select the Open using XML Converters check box.

'\@ Look in: |Dtesting V| 1 =g FE”E”

My Eio-mjputer E] autormap_command. bt @ bikes_fied_ansi tat m
E bar.jpg E] bikes fiwed_new_line.tst E]

@ R barmjpg [Z] bikes_fixed_nao_end_space.tst
W_E.[TQV batch. sl @ bikes_fiwed_wariable_row.txt

= s batch.xed @ bikes_header_fixed.txt
Eg@ [Z] bikes.tst [Z] bikes_region.tst
— E] bikes_comma.txt @ bikes_space.tut
Secure WebDAY [Z] bikes_component.txt [Z] bikes_tab.tat -j
@ [Z] bikes_components. et [Z] bikes_toss.tat &
L E] bikes_delimited et books. small =ml @

r% bikes_fixed.tat baoks. small. xml.bak @]

i kS
TigerLogic XDMS  JRL: |b|kes_reg|0n.txt ‘ [ Open: i]
% Files of type: [l Files 7] v [ cancel |

Froject Files pen uzing #ML Converter g >

Figure 146. Open Using XML C_onverters Check Box

Click the Open button.
Stylus Studio displays the Select XML Converter dialog box. (See Figure 145.)

Select the XML Converters you want to use to convert your non-XML fileto XML.

Optionally, change the default values of the conversion properties to be used when
converting your file. See Chapter 4, XML Converters™ Properties, in the DataDirect
XML Converters™ User’s Guide and Reference if you need help with this step:
http://www.xmlconverters.com/doc/.

Click OK.

Stylus Studio converts the file you specified in step 2 to XML using the DataDirect
XML Convertersyou selected in step 5. Thefileis displayed in anew instance of the
XML Editor.
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Saving an XML File in Another Format

Most DataDirect XML Converters are bi-directional —you can use them to convert native
fileformatsto XML, and vice versa. (Custom XML conversions you define using the
Stylus Studio Custom XML Conversion Definition Editor convert proprietary filesto
XML only.) In order to save an XML file in another format, however, the XML file you
are saving needs to have an XML Schema consistent with that expected by the XML
Converters. There are anumber of ways to achieve thisin Stylus Studio:

« Saveback apreviously converted file. Imagine using the CSV XML Convertersto
convert bikes. txt t0 bikes.xml1. You could modify the datain bikes.xm1 and save it
back using the CSV XML Converters. Stylus Studio could savethe XML fileas CSV
as long as you made no changes to the document structure (adding no new € ements
or attributes, for example).

« UseaDocument Wizard to createan XML Schemafrom an EDI messagetype (ATIS,
EANCOM, EDIFACT, Edig@s, HIPAA, HL7, IATA, NCPDP, TRADACOMS, or
X12, for example), and use that XML Schema as the target document in an XQuery
or XSLT mapping. The XML document resulting from the X Query or XSLT
transformation based on that XML Schema would conform to the XML Schema
expected by the EDI XML Converters.

For more information on Document Wizards, see “Using Document Wizardsto

Create XML" on page 137. For more information about working with EDI files as
XML, see “Working with EDI Conversions’ on page 274.
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Custom XML Conversions

In Stylus Studio, you can create a custom XML conversion definition that allows the
DataDirect XML Converters™ engine to convert proprietary files and extensionsto
standard formatsto XML.

You create a custom XML conversion definition by selecting an input file and then using
the Custom XML Conversion Definition Editor, shown in Figure 147, to specify the
properties you want to use to convert that file— and other filesthat share the same format.

4 Stylus Studio - [Untitled3.cony *] CEX
;"‘m Eile Edit ¥iew Project Debug CornwertToxML SourceContral Tools Window Help x
1 a e
HIEAE ™ 09w 0 =
F ] T
* E 1
prete Properties window L x| ;
== Input File Heotfburftestin,., o~ | = Untitled...
=] Input Encoding windows-1252 3 ] = [ee| — |[ex
= [2 WML Dutput URL > & i = (58] = |[EE[=] ]
[Z» Output Encoding > ficld Document pane ~ | |- oot
2> Root Element Name oat vl Eike Inventory Overview 2004- £ (Region1)
[=» Mamespace Prefix ) oo - ® raw
[ Namespace vIPAE uropean; . R i
[2» DOCTYPE Syster ID viEERake Model Year Mile R fickd
[® DOCTYPE Publc ID g 4 R1150RS | 2004 1427 "= field
[=» %ML Schema Document vEDucati 5TZ 19977 240C
[5 XML Schema Namespace vREJictoGuzzi LeMans 2001 1235
7 =
,__\E%’!”de{“xw' e % 7 e R1150R | =002 1743
=B eqion Tppe Ine-orente f Schema pane
Riegion Element Name v DucgtJl_ Mongter | 2000 156E
Elemert Mame 5 ource Uszer-Supplied v Oﬁ)rllla Futura 2001 173z
Rows to Skip a (%410 598 T
Ot from Output false vilBlTapanese |
IgineTetrm\nator EH'LF 41 2 ILENE Mode 1 Tear Mile,
5 Separator : p__ = PN K P P PP B PR Y P pm Py
Dielimiter Pairs < > B
Eomment String |1 Bike Inventory Dverview 2004-10-01 03
For Help, press F1 Row 1 Col 1 Char 35 (0x0023) UM

Figure 147. Custom XML Conversion Definition Editor

The Custom XML Conversion Definition Editor displaysinformation read from the input
file, aswell anumber of other propertiesyou can specify (such aswhether or not you want
element names based on the file'sfirst row, for example) that are used when thefileis
converted from its native format to XML.

Stylus Studio® 2009 User Guide 219



Converting Non-XML Files to XML

When to Create a Custom XML Conversion Definition

Consider creating a custom XML conversion definition any time

« You need to convert afile that does not conform to one of the standard file types
already supported by DataDirect XML Converters

« You want to exercise more control over the XML that is output by the conversion

Converting Non-Conforming EDI

The Custom XML Conversion Definition Editor lets you create custom conversion
definitions for many file types, including EDI. You can learn more about using the
Custom XML Conversion Definition Editor to convert custom EDI formats here:
“Working with EDI Conversions’ on page 274.

However, Stylus Studio and XML Converters both support the Standard Exchange Format
(SEF), which allows you to defined extensionsto EDI standards. The Stylus Studio EDI
to XML module allows you to easily create SEF files to manage conversion of custom
EDI formats. Its graphic user interface can simplify the process of converting non-
conforming EDI to XML —and vice versa. See Chapter 4 “Converting EDI to XML” for
more information.

Creating a Custom XML Conversion Definition

This section describes how to create and save acustom XML conversion definition (. conv
file) in Stylus Studio.

Choosing an Input File

Theinput file you specify when creating acustom XML conversion definition can be any
type. If you plan to usethe custom XML conversion definition to convert other non-XML
filesof thistype, theinput file should be representative of that broader class of files—files
with the same extension (. txt, for example), encoding, numbers and types of regions, and
so on. You can aways fine-tune the custom XML conversion definition to accommodate
characteristics that are not embodied in the input file, but as a general rule, use afile that
is as close to others of itstype as possible.

Stylus Studio’s heuristics are also used to determine the field separator character being
used (if any), the delimiting character being used (if any), and so on. The assumptions
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Stylus Studio makes are reflected in the Properties window in the Custom XML
Conversions Editor once the input file is opened.

Specifying File Settings
Stylus Studio also allows you to specify thefile's

« Encoding (Windows-1252 or ANSI, for example)
« Layout (line-oriented or fixed-width, for example)

Unless you are certain of the file's encoding and layout, consider |eaving the default
settings as they are — Stylus Studio will determine encoding and layout properties when
it reads thefile.

How to Create a Custom XML Conversion Definition

0 To create a custom XML conversion definition (.conv file):

1. Select File > New > Custom XML Conversion from the Stylus Studio menu.
The New Custom XML Conversion Definition dialog box appears.

MNew Custom XML Conwversion Definition

1. Select an input file to be converted ta kML

2. Specify the encoding

(%) Let Stylus Studio determine the encading automatically

) The encoding is

() The file iz binary and haz no encading

3. Specify the general layaut of the file

(%) Let Stylus Studio determine the layout automatically

() Line-oriented [comma-separated valugs or EDI files, for example)

) Fized-width [database dumps o textual printer capture files, for example)

Cancel

Figure 148. New Custom XML Conversion Definition Dialog Box

2. Click the browse button (_..]) and select the file you want to use to configure the
custom XML conversion definition settings. See “ Choosing an Input File” on
page 220 if you need help with this step.
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Tip

Tip

10.

11.

The Open dialog box appears. By default, the Files of Type field filter is set to display
.txt, .edi, .csy, .tab, .log, and .bin files.

Thefileyou select should be representative of other files of thistype that you wish to
convert to XML using the custom XML conversion definition you are creating.

Click the Open button.

Stylus Studio displaysthefile URL in thefirst field of the New Custom XML
Conversion Definition dialog box.

Optionally, change the default file encoding and layout settings. See “ Specifying File
Settings” on page 221 if you need help with this step.

Click OK.

Stylus Studio displays the file you selected in the Custom XML Conversion Editor.

Examine the file and its properties as it was read into the Custom XML Conversion
Editor by Stylus Studio.

Modify thefile layout, itsregions, and its fields as needed. See “Working with
Regions” on page 236 and “Working with Fields” on page 245 if you need help with
this step.

Modify the properties that govern XML output as needed. See “Controlling XML
Output” on page 253 if you need help with this step.

Click the Preview Results button ( B ).
Stylus Studio displays the Save As dialog box.
Enter a name for the custom XML conversion definition and click Save.

If the results are not what you expect, return to step 7 and to step 8. You might also
considering revisiting the input file, making fundamental changes there, and then
reloading it.

The steps in this process are described in greater detail in the following sections.

Once you have created and saved a custom XML conversion definition, you can useit to
open other non-XML files of the same type, just as you would with any other DataDirect
XML Converter. See “Using XML Converters to Open aNon-XML File as XML” on
page 217 for more information.
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The Custom XML Conversion Definition Editor

You use the Custom XML Conversion Editor, shown in Figure 149, to build a custom
XML conversion definition. The Custom XML Conversion Editor appears when you
create anew custom XML conversion definition, or open an existing one (a . conv file).

4 Stylus Studio - [Untitled3.cony *] CEX
= File Edit “iew Project Debug CorwertToxML SourceControl Tools Window Help x
= n L EE
DT e AR (7} %=
£ = @
-properties Properties window R
By 2 5
== Irpust File fle:/tivntestin,.. o~ | 2 Untitled.
—[B Input Encoding windows-1252 3 = — (gl — |[E=
= [= ®ML Output URL b @ i = “‘h Em
[=» Dutput Ercoding ST icld Document pane A | |28 oot
[2p Root Element Name oot vl EBike Tnventiory Overview =2004- £ [Region 1]
[Z» Mamespace Prefix ¥ - E Uropean oo SR
= Mamespace G : fiield
E}DDETYPES}IstemID vEEFiake Moidiel [¥lesr ML 1 :gnem
[5» DOCTYPE Public D i 4 R1150RS | 2004 14z "2 figld
[Z» XML Schema Document vREDucat i T2 1997 240C
[Z» XML Schema Namespace — vEJUotoGuzzi LeMans 2001 123¢%
,__\E%’!”di”‘x“'” e % 7 A R1150R | 2002 1743
-3 Region Type ine-rigfite: : Schema pane
Fiagion Elemant Ham v Joucaci Monster 2000 156¢ p
Element Mame 5ource U zer-Supplied vRIiprilia Futura 2001 173z
Fiows to Skip i villd 7
Ormit frarm Output false viBRTapaness
5 Line Terminatar CR.LF :
Soparslor x 12! ake . Model Tear Mllfv
== Delimiter Pairs < >
=] b
Comment Siring |4 Bike Inventary Dverview 2004-10-01 03
For Help, press F1 Row 1 Caol 1 Char 35 (0x0023) TLIM

Figure 149. Custom XML Conversion Editor

Theinput fileis displayed in a document pane; properties that both describe the existing
file (encoding and size, for example) and define the XML output that will be generated
when converting thisfile (root and field element names, and whether or not you want the
XML to be indented, for example) are displayed in the Properties window. The schema
pane shows arepresentation of the XML Schemathat will be output for the converted file.
Finally, in addition to current row and column position, note that the status bar also shows
the Unicode value of the current character.
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This section describes the main features of the Custom XML Conversion Editor,
including how it interacts with the XML Converters engine. This section coversthe
following topics.

« “Document Pane” on page 224

o “Properties Window” on page 231

« “SchemaPane” on page 233

Document Pane

The document pane displaystheinput file'slayout, including spaces, field separators, and
control characters. Theinput file's appearance in the document pane is determined, in
part, by itsformat.

This section covers the following topics:

. “Example— .txt Files’ on page 224

. “Display of Delimiting and Control Characters’ on page 226
. “Field Names’ on page 227

« “Document Pane Display Features’ on page 228

« “Moving Around the Document” on page 230

Example — .txt Files

Stylus Studio usesdightly different displaysfor character-separated and fixed-width . txt
files. Consider this file, which uses commas as the field separator:

Make, Model , Year, M | eage

BMN R1150RS, 2004, 14274
Kawasaki , GPz1100, 1996, 60234
Ducat i, ST2, 1997, 24000

Mot o Quzzi, LeMans, 2001, 12393
BMN R1150R, 2002, 17439

Ducat i , Monst er, 2000, 15682
Aprilia, Futura, 2001, 17320
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Figure 150 shows how this character-separated input file appears in the Custom XML
Conversion Editor’sdocument pane. By default, Stylus Studio alignscolumnsand fillsthe
empty cells of the shorter rows with alight blue to aid readability:

i UnlilledB....‘

P& B o == [E= ==

field field fieldfield

1 MEYEE Model vearfiileage |
2 EXlint r1150rsf=0n0 414274 ]
Elxawasaki crz1l100f199efs0z234 0]
[dDucati 3T 199724000
Hicto GuzzifLeMans B2001412323
(B MTT R1150R 2002417439
fADucati Monsterfe 00015682
faprilia Futura M2001817320

Figure 150. Character-Separated File with Aligned Fields

You can remove these spaces from the display and view thefilein its native format by
clicking the Align Fields button ([Ei] ) on the tool bar, or by selecting
CustomXMLConversion > Align Fields on the menu. Thisresultsin the layout shown in

Figure 151.

% Untitled6.__|

e o === E
akeModelYearMileage.‘ A
Hlevwlr1150rs 200414274
Elxawazakiflerz1100f1996cfs0234
Moucatiflstzf1o978z4000

uoto cuzzifieMansfzo01f12333
Herwlr1150rR2 00217439 :
oucatiflMonsterflzooofis6sz2
flipriliaffruturaljzoo1 17320

Figure 151. Character-Separated File without Aligned Fields

Fixed-width files are displayed in adlightly different fashion. Consider this fixed-width

input file:
Deep- sea oct opus Bat hypol ypus arcticus http://ww:. dal . ca/ ~ceph/ TCP/ barcti c. ht m
Bl ue-ri nged octopus Hapal ochl aena | unul at ahtt p: // www. dal . ca/ ~ceph/ TCP/ | unul at a. ht m
Cari bbean reef octopusCctopus bri areus http: //ww. dal . ca/ ~ceph/ TCP/ obri ar. ht m
G ant oct opus Cct opus dof | ei ni http: //ww. dal . ca/ ~ceph/ TCP/ gi ant . ht m
Common oct opus Cct opus vul gari s http: //wwmn. dal . ca/ ~ceph/ TCP/ Cct opusvul gari s. ht
Red oct opus Cct opus rubescens http://ww. dal . ca/ ~ceph/ TCP/ r edoct o. ht m
Cctopus Sal uti i Cct opus sal utii http: //wwm. dal . ca/ ~ceph/ TCP/ Gsal utii . ht m
Cct opus Macr opus Cct opus nmacr opus http://ww. dal . ca/ ~ceph/ TCP/ Ovacr opus. ht m
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In afixed-width file, the empty cells represent actual values (spaces) in the input file. In
the second row of thisinput file, for example, there are three spaces between the first and
second columns:

5 Untileds.. |

P e@ e == =l

field field
plElc e p-=ca octopus Bathypolypus arcticus httpl//www. dal.ca/~ceph/TCE/barctic. html
FAElus-ringed cctiopus Hapalechlaena lunulatahttpf//www. dal.ca/~ceph/TCE/lunulata. html
ElCcaribbean reef octopusOctopus briareus http@/ / www. dal.ca/~ceph/TCP/obriar. html
[1ciant octopus Octopusz dofleini httpfll/ /www. dal. ca/~ceph/TCE/ giant. html
FCommon ectopus Octopus vulgarils httplll/ / www. dal.ca/~ceph/TCP/Dctiopusvulgaris. htm
[JrRed cctopus Octopus rubescens http@/ / www. dal.ca/~ceph/TCE/ redoctio. html
octopus Salutii Octopus =alutii httpfll/ /wwwi. dal. ca/~ceph/TCE/ Ogalutii. html
[Joctopus Macropus Octopus macropus httpl/ / www. dal.ca/~ceph/TCE/Omacreopus. html

Figure 152. Fixed-Width File

Display
Styl

of Delimiting and Control Characters
us Studio displays delimiting and control charactersin away that distinguishes them

from plain text values.

Delimiting characters, like the comma used in the example in Figure 150, are
displayed with adark blue background. For filesthat include sub-fields or arrays (like
EDI, for example), the sub-field separator character is shown in a different shade of
blue. Sub-sub-fields delimiting characters are shown in a shade of purple.

Control characters(linefeedsand carriagereturns, for example) are shown using their
abbreviated ASCI| value. A carriagereturn (0xOD) line feed (0xOA) is shown as [25],
for example. ASCI| abbreviations are aligned vertically, to preserve space, as shown
in this representation of the ASCI| value for tab (0x09): [3].

Stylus Studio understands all Unicode characters,. When editing Line-Oriented
Region and Field Name values in the Properties window, you can enter mnemonic
values for the C1 and CO control charactersin the following ranges:

= CO control characters with a value from >= 0x00 to <= Ox1F

» C1 control characters with a value from >=0x80 to <= Ox9F

For example, you could enter TAB or HT in the Field Separator field in the Properties
window, and Stylus Studio would correctly interpret that value. For alist of
commonly used control characters, see* Specifying Control Characters’ on page 309.

Charactersthat are discarded from output (like line terminators such as CR and LF
and comment lines) are displayed against a gray background.

226

Stylus Studio® 2009 User Guide



The Custom XML Conversion Definition Editor

You can hide control characters by clicking the Toggle Control Characters button ([3z])
on the tool bar, or by selecting ConvertToXML > Toggle Control Characters from the
menu.

Field Names

User-defined field names — values that Stylus Studio uses to create the element namesin
converted XML — are displayed in green, as shown here:

Pl %! E Untitled1
Collapse Cons... | false A~ |
Diouble Delimit... | true s | (0] | =z |[E2E
=-*= Row Element Mame | row i x_u.u..
IR gt e field fieldfield
=i Field Element Name_ field Model vearfuileage
: e Tompanent rR11c0rsfzo0al1427 40"
:E :uh'cﬂ“[’)'j?”i ;Lt"?mm'j””e”‘ ] awasaki zrz 1100l 199 cls0z34 .“\f-‘;
T Left Padding TAB." ot GuzziMLeMans 2001 12393.“\5\
T RightPad.. Tag' rR1150r MzoozM17439: 2
T Omit Only then ... Monsterflzoooficaszi
% TMiDuT"{ slement Aaprilia Futura Mz001l1732000
ookup List

Figure 153. User-defined Field Names are Shown in Green

You can edit these names
« In-place, by double-clicking the field name
« IntheField Element Name field of the Properties window

If the field names are taken from arow within thefileitself, Stylus Studio displays ablue
arrow in the document pane margin to indicate this.

Properties x| = Unlilled...’|
. Heglon Tupe Line-Oriented A

Region Elementtlarms

Ao sae oo D © [ED
B Fows fo skl i c Rlake Model Year Mlleage.,.,.\
Line Terminator CRLF PAE T Bri1c0rzfz004@14274, 2
Separator vEJkawasaki WMerpziioof12s6cfenz2340 0
ga“f""e'tp;"s vlpucat i . B j1oo7f240000 0

Ll e > wa viEpicte CuzzifLeManz Be00 112393,
E:cape Characters e
Key=\ialue Character v[AEMT BE1150FR BZ00ZH 17439._-,_-:
Toss Characters vilDucati Bionster@200 015682, 0
Component S eparator vilaprilia Brutura Wz001817220,
Sub-Component Sepa...

Figure 154. Blue Arrow Indicates Field Names Taken from the File

See “Naming Fields’ on page 245 to learn more about naming fields for XML output by
custom XML conversion definitions.
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Document Pane Display Features

In addition to aligning fields in character-delimited files, the Custom XML Conversion
Editor’s document pane has several other features that aid readability.

Ruler
You can display aruler that identifies each column:

s Untitleds...|
2@ o =EEEN

field ‘ | field
ililc=p-=ea octopus Bathypolypus arcticus httpf//www.dal.ca/~ceph/TCP/barctic.html
PlElue-ringed octopus Hapalochlaena lunulatahttpl// www.dal. ca/~ceph/TCE/lunulata. html
ElCaribbean reef octopusOctepus briareus httpl/ / www.dal.ca/~ceph/TCP/obriar. html
LIciant octiopus Octopus dofleini httpl/ / www.dal.ca/~ceph/TCP/giant. html
Flcommon octopus Octopus wulgaris httpl/ /www. dal. ca/~ceph/TCE/ Octopusvulgaris. html
JRed occteopus Octopus rubsscens httpl/ / www.dal. ca/~ceph/TCP/redocto. html
octopus Balutii Octopus salutii httpl// www.dal.ca/~ceph/TCP/Osalutii. html
Bloctopus Macropus Octopus macropus httpll/ /www. dal.ca/~ceph/TCP/ Omacropus. html

Figure 155. Ruler Helps Identify Columns

To display the ruler, click the Toggle Ruler button ([=]) on the tool bar, or select
CustomXMLConversion > Toggle Ruler from the menu.

Displaying Pattern Matches

You can define match patterns using regular expressions to control which rows are
converted to XML and, optionally, the nameto use for theserows. You can highlight rows
that match the patterns that you have defined, as shown here:

Properties x
Sub-Compone... ~
Region T ermin
. Collapse Cons... | false
. Double Delimit... | tue

% Untitied__=|

=k <oty

jldlccp-seca cctopus Bathvpolypu = Regian
PdElue-ringed occtopus Hapalochlas @

ElCaribbean reef coctopusOctopus bri

== Row Element Name | o
= Match F'attem oct
=- e F|s i T Tield

d
i ] Enmpnnant EI companent

"8 Sub-Compone... | subcomponent jiCont] oStiopus PSEilEus] diolf
= ™ SouceData Sting FConmorn octopus Octopus wul
T Momalize . | tue (JR=d occtopus Cctopus rub
T LetPaddi. | TAB," Xlcctopus Salutii Octopus sal
% S'Dhtpad--- ;AFWh = xiJoctopus Macropus Octopus mas
mit hly =l
T #ML Outp... | lement < > |
$ Lookup List =] Deep sea Uclupus BalhyDDbqus arclicus hllp

hlnbon

Flgure 156. Matchmg Rows Are Dlsplayed in Yellow

To highlight matching rows, click the Highlight Matching Rows button ([Z]) on the tool
bar, or select CustomXMLConversion > Highlight Matching Rows from the menu.
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Matching rows are displayed in light yellow, with agreen check in the pane’s margin. A
red X identifiesrowsthat do not match the current pattern. Gray squaresidentify rowsthat
match a pattern other than the pattern defined for the row that currently has focus. See

“Specifying Multiple Match Patterns’ on page 257 for more information on this feature.

Tip Only rowsthat match the same pattern that the current row matches are highlighted. Also,
tooltips appear when you hover the pointer over the match symbols. These tooltips
display the pattern that the row matches.

See “Pattern Matching” on page 255 to learn more about using regular expressions to
define match patterns.

Grid Lines

The document pane displays both vertical and horizontal lines by default; you can
hide/show them independently. In the example shown in Figure 157, horizontal lines are
hidden from the display:

B Untited.."|

rem o =M=EH=N) =
field field

- cp-=2ea octopus Bathypolypus arcticus httpl// www.dal. ca/~ceph/TCE
MElue-ringed cctopus Hapalechlaena lunulatahttpf//www.dal.ca/~ceph/TCP
ElCaribbean reef octopusOctopus briareus httpf// www. dal.ca/~ceph/TCP
Iciant occtopus Octopus dofleini httpfl// www.dal.cal~ceph/TCD
Hcommon octopus Octopus wulgaris httpfl/ /www. dal. ca/~ceph/TCP
[Jred octopus Octopus rubsscens httpl// www. dal. ca/~ceph/TCP
flcctopus Salutii Octopus salutii httpfl// www.dal. caf~ceph/TCD
Hloctopus Macropus Octopus macropus httpll/ /www. dal. ca/~ceph/TCP

< >

Figure 157. You Can Hide Horizontal and Vertical Grid Lines

To hide horizontal and vertical grid lines, click the Toggle Horizontal Grid Lines (&)
and/or Toggle Vertical Grid Lines ([|]]]) buttons on the tool bar, or select ConvertToXML >
Toggle Horizontal Grid Lines and/or Toggle Vertical Grid Lines from the menu.

Tip Hiding horizontal lines while displaying the ruler is an effective way to quickly scan
columns.

Fonts

By default, the input document is displayed using the Courier New font in 12pt. You can
change the display font to suit your personal preference using the Edit > Change Font and
Edit > Font Size menus.
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Moving Around the Document

You can move the cursor around the document using
o The Space bar on your keyboard

« Thedirectiona arrows and Page Up, Page Down, Home, and End keys on your
keyboard

« Your mouse (click on the character on which you want to place the cursor)
o TheGo To dialog box

Go To §|

GoTo M asimuirn:
1 - 752

1
() Cursar Pasition in Flegion 7h2
() Row in Cunent Region: 8
() Column in Cunent Row: 94

[ Cancel 1 [ ok ]

Figure 158. Use the Go To Dialog Box to Navigate the Document

Using Go To

You use the Go To dialog box to jump to a specific location in the file you are using to
create your custom XML conversion definition. You can use it to move the cursor to a

specific
« Positionin thefile
« Region

« Position or row within aregion
o Column within the current row

When you first display the Go To dialog box, valuesin the Go To fieldsreflect the cursor’s
current location within the file. The valuesin the Maximum fields display the maximum
valuesfor each category (file size, number of regions, and so on) for the portion of thefile
read into the Custom XML Conversion Editor Editor by Stylus Studio.
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0 To display the Go To dialog box, select Edit > Go To from the menu.

Properties Window

TheProperties window, like the one shown in Figure 159, displaysinformation about the
input file, aswell as settings that Stylus Studio will use convert filesto XML.

Properties b4
= —:B Input File file: /v Mtestinghbikes_... &
—:ﬁ Input Encoding ulf-8
€ Physical Size 208 bytes
€ Portion Loaded 208 bytes
e Characters Loaded 208

e Character Unicode VYalue | 77 [Ox4d)
=-[= <ML Output URL

[= Root Element Name oot

E) Mamespace Prefis

E) Mamespace

[5 DOCTYPE System 1D

[® DOCTYPE Public ID

[= %ML Schema Document

E) #ML Schema Namesp

E) Indent XML? true
= Fiegion Type Line-Oriented

Region Element Mame

Element Mame Source Fram First Baw

Rows to Skip 1]

e Size 208 characters
€ Portion of File 1 to 208

€ Row Count 8

e Longest Row Lenath 30

Line T errinator CR.LF
Separator '

Delimiter Pairs
Comment String
J Y R

v

Figure 159. Properties Window for a .txt File

Information in the Properties window includes

« Information read or inferred from the input file when it isfirst opened in the Custom
XML Conversion Editor. Examples include the file name, file size, and number of
characters that were read. Some values, such as the type of encoding, can be edited.
Informational fields that cannot be edited are identified with ablue circle: .

« Vauesyou want the XML Converters engine to use when converting this input file
and other files of thistypeto XML. Output propertiesinclude the root element name,
the namespace and namespace prefix, and the field element name. Thesefields are
identified with a green arrow over a document icon: [=].
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How Properties are Organized

Properties displayed in the Properties window are organized in the following categories.

Input File —read-only information read or inferred from the input file, and editable
propertiesthat affect XML output. These properties affect the file asawhole when it
is converted to XML. Input file properties are identified by thisicon: [2]].

XML Output URL — properties that affect the XML document created by the custom
XML conversion definition, including the name you want to use for the root element,
and whether or not you want to indent the XML. Output URL propertiesareidentified
by thisicon: [=.

Region Type —read-only information inferred from the input file, and editable
properties that affect XML output. Examples include line terminating and escape
characters. These properties affect a contiguous portion of the file (that is, agiven
line-oriented or fixed-width region) when it is converted to XML. Region properties
areidentified by thisicon: [&].

Row Element Name — properties that affect which rows of the input file are output to
XML and how they are output, including the name you want to use for the row. Row
properties are identified with thisicon: P=].

Field Element Name —read-only information read or inferred from the input file, and
editable properties that affect XML output. These properties affect only fieldsin a
given region of the file when it is converted to XML. Field properties are identified
by thisicon: [*&].

Note Informational properties, that is, propertiesthat do not affect XML output, are displayed
with the following icon: . These properties are displayed when you click the Toggle
Informational Properties button.

Properties for Fixed-Width and Line-Oriented Input Files

Fixed-width and line-oriented input files have different properties — line-oriented
propertiesinclude the line terminator and field separator characters, and fixed-width files
have arow length, for example. See “ Custom XML Conversion Definitions Properties
Reference” on page 278 to learn more about individual properties.
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Schema Pane

The schema pane displays a representation of the XML Schema for the XML document
that will be output when the input file is converted to XML.

i wa edi.cony = | i
» 2@ o E=h=m=l B EE
1 el [l : | | [l : | = cediz
pAcslcrle o877 6651122334455 =0 [ = Regond
3B T!B 3 l!D 0ilzE0nn1l~ <!ntelchange_control_hefader?m ISﬁ.
. <interchange_control_trailers ""1E&:
id AF GNHD D'B 8=00)0/0 1l2 DD41=01x <functional_group_header> ""GS:"
L 9!}3 T!B 8200001~ <transaction_set_headers ""ST:"
6 i RN!llB 8200001~ <beginring_segmenty "“BGN:"
7B MT!Z!l ooooo. o0~ <reference_identifications "N3:"
8 [l Y! 4 6! 1B <functional_group_trailer> ""GE:"
<hanzaction_set_trailers "SE:"
E)==f7@o01z8001~ caquantis 0T
10 = l 1! 128~ <monetary_amounts "AMT:"
BR e f] 1 foooo3z1z235~ <traces " TRM:"
112 B
< ¥ p
BGH

Figure 160. Schema Pane Shows Output Schema Representation

You can double-click on arow element to display the Set Node and Match Pattern dialog
box, shown in Figure 161. This functionality provides an alternative to editing the row
name and specifying a match pattern in the Properties window. (To learn more about
patterns and how to use them in your custom XML conversion definitions, see “Pattern
Matching” on page 255.)

Set Node and Match Pattern

Fiow Element Name:

Match Patterm: "M

[ 0K ] [ Cancel ]

Figure 161. Set Node and Match Pattern Dialog Box

You can also edit schema node names directly in the schema pane —just click twice to
place the node name in edit mode.

See “Rows’ on page 235 to learn more about specifying conversion properties for rows.
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Parts of an Input File

Input files displayed in the Custom XML Conversion Editor’s document pane consist of
regions, rows, and fields. Each section hasits own set of properties. Some, like Region
Type, areread or inferred from thefile; others, like Region Element Name, are valuesyou
provide that affect the XML output.
This section covers the following topics:
« “Regions’ on page 234

“Rows’ on page 235
. “Fields’ on page 236

Regions

A region isthe largest organizational component in an input file. Regions are interpreted
by Stylus Studio when theinput fileisfirst read into the Custom XML Conversion Editor.
You can use the editor to define your own, aswell.

Aninput file can contain one or more regions; every input file has at least one region that
starts at offset 0. Multiple regions are common in binary files, which often contain afixed-
size header and then one or more records containing the actual data. Regions arefixed in
size and cannot repeat.

In the Custom XML Conversion Editor, regions are numbered, starting with 1, followed
by the row number. For example, in an input file with two regions, you might see rows
labeled asfollows; 1:1, 2:1, 2:2, 2:3, and so on, as shown here:

» & @ [0][E =k= E=]
fieldfield [fieldfield
: 1 IGE=NY hModethearhMlleage
field field fleldfleld
R1150rRsfz004f1a274 02
AR wasaki crzllnof19oclenz34, "
iDL cat i gT2 19978240000
Hhicte cuzzifuemans Wzooi1f1z39200
R1150R Wzoozf17439: 2
Hjrucati Monsterfzo0ol1s6520 0
% 2 : 7 EC e Futura Wzoo1l173z0. 0

Figure 162. Rows in Regions Are Numbered Independently

234

Stylus Studio® 2009 User Guide



Parts of an Input File

Region Types

Regions can be fixed-width or line-oriented. You can also set the Region Type property
to No-output. Regions that are marked as No-output are grayed out in the Custom XML
Conversion Editor, and they are not converted to XML.

Managing Regions

Stylus Studio provides tools that let you create new regions, and join one region with
another. You can also change a region’stype, define different line terminators across
regions, and mark aregion sothat it isexcluded from output. For information on these and
other topics, see “Working with Regions’ on page 236.

Rows

A row iseguivalent to arecord, line, or tuplein the input file; arow is made up of fields.
An example of arow is an employee record; examples of fields in an employee record
include employee_id, Tast_name, first_name, and So on.

Every region can have one or morerows. (A region cannot be empty.) In addition, aregion
can have multiple row types. Rows are selected for conversion to XML based on the
match patterns expressed in the Match Pattern field of the Properties window. See
“Omitting Regions and Fields, and Rows’ on page 254 for more information.

Rows in afixed-width region have the same width as the region itself; fields within each
row are defined by afixed number of columns. Stylus Studio uses a default value of 80
characters for row length in fixed-width regions, but you can adjust this as required from
within the Custom XML Conversion Editor. See “Adjusting Fixed-Width Regions’ on
page 239 for more information.

In afixed-width region, you can

o Explicitly specify the fields within a row

« Adjust the size of the fields you specify

In aline-oriented region, fields are separated by a separator character or string. These

characters are inferred by Stylus Studio when it first reads the file, but you can change
these and other characters if needed.

See “Working with Fields” on page 245 for more information.
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Fields

A field isone or more columnsin arow that contains data. Each different row type hasits
own independent set of fields. An example of afield in an employee record is
empTloyee_id.

Stylus Studio supports many data types (string, Boolean, number, date, time, and so on)
and recognizes many different input formats (like different date formats, for example).
Properties vary based on datatype —the Base property, for example, is applicable only to
Number data types.

You can define your own fields in fixed-width input files. See “Defining Fields” on
page 248 for more information.

Component and Sub-Component Fields

Some fileformats, including many EDI dialects, allow fieldsto be subdivided into arrays,
sub-fields, or composite fields. Collectively, these fields are referred to as component
fieldsin custom XML conversion definitions, and they are fully supported, both in terms
of recognition and output. You can name the container e ement using the Component
Element Name and Sub-Component Element Name properties.

Working with Regions
This section describes some of the features you can use to work with input file regions. It
covers the following topics:
« “Converting the Region Type” on page 237
o “Adjusting Fixed-Width Regions’ on page 239
« “Defining and Joining Regions’ on page 241
« “Controlling Region Output” on page 244
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Converting the Region Type

The Region Type field in the Properties window displays information about the type of
region Stylus Studio inferred when the file was first read. Its value is either Fixed-width,
Line-oriented, or No-output.

Tip Information about No-output regions is not displayed in the Properties window.

Regions with CR/LF control characters are interpreted as line-oriented regions. There
might be occasions, however, when you want to change the region type from line-oriented
to fixed-width, or vice versa. This section describes the tools you can use to change a
region from one type to another.

Consider the following file fixed-width file:

Make Model Year M | eage
BMV R1150RS 2004 14274
Kawasaki GPz1100 1996 60234
Ducat i ST2 1997 24000
Mot oQuzzi LeMans 2001 12393
BMV R1150R 2002 17439
Ducat i Monster 2000 15682
Aprilia Futura 2001 17320

Itisasimple .txt file with fields (Make, Mode1, and so on) that have been created using
spaces. Each new row was created using the Enter key in the text editor, resulting in
CR/LF control characters at the end of each line that cause Stylus Studio to interpret the
file asasingle line-oriented region, like this:

P & (2

field £
ake IIIIIIIModel

BMW 1] Bl=1150Rs |2DD4 Bl <=74
Kawasaki [N 1100 | MEEE || EilEEe
Ducati || HEEEE - -Blll= <000

Blzoo01 1] e
Blzo0z= ||| Pl

| BEEIE || | PG
Figure 163. Fields are Aligned by Default

B M
Ducati

ield field fiel:«
||| NS Hlilcagei
I::::

For display purposes, we can remove the spaces Stylus Studio hasinserted for readability
(the cells with the light blue shading) by clicking the Align Fields ([Ef] ) button. This
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resultsin adisplay that resembles the source (Figure 164), but Stylus Studio till
considers the region to be line-oriented.

= == s=[N]  E
IModelIIIIYearIIIIMileageﬁi
|

L
7 itverad | ||| | dereEeees | B | | | EEEEE |
8 [N | [ | | SR | | B | | | EelslEn) |

Figure 164. Turning Off Align Fields Can Aid Readability

When you convert aline-oriented region to a fixed-width region, Stylus Studio removes
spaces it added for readability and depicts only the spacesin the original input file used
to create the fields and the field va ues themsel ves, as show in Figure 165.

p2@ O ==k=EE

field

ake Mode 1 Year Mileage, EBMW R1150RrRS | 2004 14274 | | Eawal
=aki GPz1100 1296 60234 | .Ducati 5TZ 1297 24000 . MotoGuzz
i LeMans 2001 12393 o BME R1150R 2002 17439 coDucat i
onster | 2000 15682 | Aprilia Futura 2001 17320

Figure 165. Line-Oriented Regions Converted to Fixed-Width

By default, Stylus Studio displays fixed-width files using an 80-character row. This
accounts for the input files appearance when it isfirst displayed as a fixed-width file — if
you scan the document, you can see that all of the file’'s original information, including
the CR/LF control characters has been retained, but that the formatting differs —the
original input file had eight rows; now it has four rows of 80 characters.

Tip You can adjust the width of fixed-width regions. See “Adjusting Fixed-Width Regions”
on page 239.
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How to Convert a Region Type

0 To convertaregion type:

1. Place the cursor anywhere in the region you want to change.

2. Click the Convert to Fixed-Width Region (|EE)) or Convert to Line-Oriented R